Bug Hunting Session
Bug 124983 - EDITING Calc: After hiding a column, column breaks and row breaks are inserted
Summary: EDITING Calc: After hiding a column, column breaks and row breaks are inserted
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Ilhan Yesil
URL:
Whiteboard: target:6.4.0
Keywords:
: 120009 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-26 12:37 UTC by Ilhan Yesil
Modified: 2019-11-21 12:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
An empty calc document (8.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-05-03 06:58 UTC, Ilhan Yesil
Details
Picture shows two column breaks after hiding first column (57.49 KB, image/png)
2019-07-05 13:00 UTC, Ilhan Yesil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ilhan Yesil 2019-04-26 12:37:38 UTC
Description:
If a calc file is opened and a column is hidden by menu, the column is hidden, but extra column breaks and row breaks are in the sheet. 

Steps to Reproduce:
1. Create a new calc file and save it, close it and reopen it
2. Hide a column


Actual Results:
Extra column breaks and row breaks are in the sheet, before there was none.

Expected Results:
If before none of these breaks are in the sheet, they should not be inserted by hiding a column.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 raal 2019-05-02 15:54:48 UTC

Hello,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you

I cannot reproduce in Version: 6.3.0.0.alpha0+
Build ID: 83abdf803a023067ebc207fd82dde987df233754
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win;
Comment 2 Ilhan Yesil 2019-05-03 06:58:43 UTC
Created attachment 151146 [details]
An empty calc document
Comment 3 Ilhan Yesil 2019-05-03 07:06:55 UTC
Just open the attached empty document.
Then hide the first column.

Result: 
Periodical column breaks between "H" and "I", "O" and "P", "V" and "W", and so on.
Periodical row breaks between "51" and "52", "102" and "103", "153" and "154" and so on.
Comment 4 Ilhan Yesil 2019-07-05 13:00:51 UTC
Created attachment 152591 [details]
Picture shows two column breaks after hiding first column
Comment 5 Ilhan Yesil 2019-07-09 10:27:25 UTC
Self confirming according to https://wiki.documentfoundation.org/QA/Guidelines_for_public_and_private_sector_deployments. Issue has originally been reported by another user in our internal issue tracker.
Comment 6 Xisco Faulí 2019-09-26 09:45:48 UTC
Hello Ilhan,
I think the problem is that the page break are not displayed by default. You see the same problem if you go to print preview and back to normal view ( bug 120009 )
I guess both bugs have the same root cause ?
Comment 7 Ilhan Yesil 2019-09-26 10:09:57 UTC
I remember that I've seen this effect also in my tests, so it should be the same reason. I've a solution already:

https://gerrit.libreoffice.org/#/c/75355/

but wait that the reviewers accept it.
Comment 8 Commit Notification 2019-10-01 20:14:02 UTC
Ilhan Yesil committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/caeb7b141280a65e60525f11a7e6514b76e12e11

tdf#124983 In calc make printable page borders also initially visible

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Michael Weghorn 2019-10-07 13:27:18 UTC
This is fixed by the commit from comment 8.
Comment 10 Michael Weghorn 2019-10-07 13:27:50 UTC
*** Bug 120009 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2019-10-07 13:30:32 UTC
Verified in 

Version: 6.4.0.0.alpha0+
Build ID: 52cda5c5ae426761ccbdb4f20419098eab195303
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Nice!!!

@Ilhan Yesil, thanks for fixing this issue!!