Download it now!
Bug 130584 - Calc: "Display Page break" option activates itself (without user activities!) when opens spreadsheet with many data
Summary: Calc: "Display Page break" option activates itself (without user activities!)...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Options-Dialog-Calc regressions-printable-page-borders
  Show dependency treegraph
 
Reported: 2020-02-11 10:17 UTC by Roman Kuznetsov
Modified: 2020-02-13 19:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example spreadsheet (112.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-02-11 10:19 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2020-02-11 10:17:17 UTC
Description:
Calc: "Display Page break" option activates itself (without user activities!) when opens spreadsheet with many data

Steps to Reproduce:
1. Open Calc
2. Tools->Options->LibreOffice Calc->View
3. Disable "Page break" option
4. Restart Calc
5. Create a new spreadsheet => There are no dashed page breaks on sheet. It's OK
6. Open file from attach => There are dashed page breaks on sheet! How?!
7. Close the file
8. Open a new file => There are no dashed page breaks on sheet again!

Actual Results:
"Display Page break" option activates itself (without user activities!) when opens spreadsheet with many data

Expected Results:
"Display Page break" option stays in disabled status always if it was disabled by user


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 41177730421f9be9ad955766a5a19667d8003b11
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2020-02-11 10:19:26 UTC
Created attachment 157789 [details]
Example spreadsheet
Comment 2 Eike Rathke 2020-02-11 11:02:41 UTC
This is likely due to the implementation for bug 124983 (with follow-up bug 129552).

Cc'ing ilhanyesil, vmiklos
Comment 3 Xisco Faulí 2020-02-13 15:58:54 UTC
Indeed. Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=caeb7b141280a65e60525f11a7e6514b76e12e11

author	Ilhan Yesil <ilhanyesil@gmx.de>	2019-07-10 15:41:27 +0200
committer	Eike Rathke <erack@redhat.com>	2019-10-01 22:13:09 +0200
commit	caeb7b141280a65e60525f11a7e6514b76e12e11 (patch)
tree	4f7b1f0db28fc7229b89a7f198eb87596135c4d8
parent	32f28dfa4c1de2b92664a5c0c3eca4fffecc0b28 (diff)
tdf#124983 In calc make printable page borders also initially visible

Bisected with: bibisect-linux64-6.4

Adding Cc: to Ilhan Yesil
Comment 4 Xisco Faulí 2020-02-13 19:35:04 UTC
Problematic commit reverted in https://git.libreoffice.org/core/commit/c4281cb41e6b76cabd5fe42fc707877e864dfb82
Closing as RESOLVED FIXED