Bug 130457 - Impress: Edit Style > Customize selects two levels at the same time
Summary: Impress: Edit Style > Customize selects two levels at the same time
Status: RESOLVED DUPLICATE of bug 127112
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-05 13:27 UTC by Leopoldo Saggin
Modified: 2020-02-22 02:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The attachment contains images Bug1.png, Bug2.png, Bug3.png and Bug4.png (66.20 KB, application/pdf)
2020-02-05 13:45 UTC, Leopoldo Saggin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leopoldo Saggin 2020-02-05 13:27:12 UTC
Description:
I want to edit the style of a slide, in particular the appearence of one of its levels. When I move from a level to another one, the previous level selected stays selected.
In the attached images it is visually reported what happens.

Steps to Reproduce:
1. Open Impress in LibO 6.4.0.3 64bit (no idea for 32bit)
2. Open Impress and load a template
3. Create a slide
3. Try to modify the style of some part of this slide
4. To do this, right click the mouse selecting a certain point of the slide.
5. From the context menu select "Edit Style..."
6. Select the "Customize" tab
7. Select Level1 (see attachment, Bug1.png) => This is OK.
8. Now decide to move to Level2 instead of 1. When you select Level2 the Level1 stays selected (see attachment, Bug2.png)
9. To test if this is just for this combination of Levels, I tried to select Level3. In this case Level1 becomes unselected but both Level2 and Level3 are selected (see attachment, Bug3.png)
9. For investigating if this happens only when you select consecutive Levels, I tried to select Level10. At this point Level2 becomes unselected, while Level3 and 10 are selected (See Attachment, Bug4.png).

Actual Results:
So two levels are selected at the same time if you change idea and tried to modify another Level instead of the first one you selected.

Expected Results:
Only one selection at a time should be selected, unless one presses also CTRL or Shift key.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
No idea of what happens with other versions of LibreOffice. I never used Impress before yesterday.

Regards,
Topoldo
Comment 1 Leopoldo Saggin 2020-02-05 13:45:30 UTC
Created attachment 157672 [details]
The attachment contains images Bug1.png, Bug2.png, Bug3.png and Bug4.png
Comment 2 Xisco Faulí 2020-02-21 15:40:36 UTC
i can't reproduce it in

Version: 7.0.0.0.alpha0+
Build ID: d7cab304e7dd22fd12443a1ee3b6a9c463bf9a3d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2020-02-21 15:49:16 UTC
it seems to be a duplicate of bug 127112

*** This bug has been marked as a duplicate of bug 127112 ***