Download it now!
Bug 130499 - kf5: Crash when closing Writer after D'n'D of text
Summary: kf5: Crash when closing Writer after D'n'D of text
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.2
Keywords:
: 131178 (view as bug list)
Depends on:
Blocks: KDE Drag-and-Drop
  Show dependency treegraph
 
Reported: 2020-02-07 07:44 UTC by Michael Weghorn
Modified: 2020-03-23 06:09 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (6.26 KB, text/plain)
2020-02-07 07:45 UTC, Michael Weghorn
Details
Screencast showing the issue (8.66 MB, video/webm)
2020-02-07 07:48 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2020-02-07 07:44:22 UTC
Description:
Writer crashes when closing it with kf5 VCL plugin after dragging and dropping text, e.g. for the following case

Steps to Reproduce:

0. Use kf5 VCL plugin on X11
1. open a new Writer doc
2. type "Hello world"
3. select the text "Hello" with the mouse
4. Drag'n'drop the text to after the second word "world"
5. Close Writer

Actual Results:
Crash due to segfault

Expected Results:
No crash. LibreOffice should close normally


Reproducible: Always


User Profile Reset: Yes



Additional Info:
does not happen e.g. with gtk3 (s.a. backtrace); I didn't check on Wayland

Version: 7.0.0.0.alpha0+
Build ID: 017ae620604de06414dc3f780804c241b87e45c6
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Deban testing with KDE Plasma
Comment 1 Michael Weghorn 2020-02-07 07:45:43 UTC
Created attachment 157719 [details]
Backtrace
Comment 2 Michael Weghorn 2020-02-07 07:48:27 UTC
Created attachment 157720 [details]
Screencast showing the issue

I came across this while looking at bug 103182, but it looks unrelated.
Comment 3 Roman Kuznetsov 2020-02-09 09:59:17 UTC
no repro in

Версия: 6.4.0.3
ID сборки: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
Потоков ЦП: 4; ОС: Linux 5.5; Отрисовка ИП: по умолчанию; VCL: kf5; 
Локаль: ru-RU (ru_RU.UTF-8); Язык интерфейса: ru-RU
Calc: threaded


nor in

Версия: 7.0.0.0.alpha0+
ID сборки: d1d328441118fb978cf3233a461ad95bdb092934
Потоков ЦП: 4; ОС: Linux 5.5; Отрисовка ИП: по умолчанию; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-02-07_04:59:38
Локаль: ru-RU (ru_RU.UTF-8); Язык интерфейса: ru-RU
Calc: threaded
Comment 4 Jan-Marek Glogowski 2020-02-21 09:27:46 UTC
Can reproduce with my current 7.0 master.
Comment 5 Commit Notification 2020-02-22 00:17:03 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c6fb366e05370af553af2130b370909ed4495cff

tdf#130499 Qt5 no qApp == main thread

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-02-22 09:04:48 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/3e1ae2e28718b7e9dda6a4a6e08dd4a512828858

tdf#130499 Qt5 no qApp == main thread

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Michael Weghorn 2020-03-23 06:09:19 UTC
*** Bug 131178 has been marked as a duplicate of this bug. ***