Bug 130535 - Export as PDF doesn't save last path used and uses the same path as current document
Summary: Export as PDF doesn't save last path used and uses the same path as current d...
Status: RESOLVED DUPLICATE of bug 126665
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-02-08 21:07 UTC by João Paulo
Modified: 2021-10-12 11:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description João Paulo 2020-02-08 21:07:12 UTC
Running LibreOffice 6.4.0.3 64 bits on Windows 10 64 bits, I noticed that PDF exporting doesn't save the last path used anymore as it did on LibreOffice 6.3.4.

That's annoying, as my ODFs folders are not the same as my PDFs folders.  I think other users also save PDFs on different folders from the source documents, as PDFs is mainly used to show the final work to others.

In my workflow, I have source (internal) documents on a folder; when they need to be printed out or sent to a web portal, I export them as PDFs on another folder.  Saving source documents on an organized folder structure allows for easy managing documents by subject, allowing for easy “remixing”, i.e., when parts of one document which has a subject that can be used on another new document, with the same subject, but meant to be sent for a different person.  It's like copying and pasting software sources from one file to another file, but adapting the access tokens and other variables for each use case.

I also know of a coworking site's workflow that has a human print manager who gets the PDF exported file on its local folder (which is shared on the network) and then prints it on request by users of the coworking site.

Could you please revert to the old behavior of PDF Export saving the last path used to export?  It would really be easier to work this way.
Comment 1 Mihkel Tõnnov 2020-08-06 13:29:13 UTC
On Linux, this is how it's been like since at least 3.6.7 (and probably before), and it works well for my workflow (as I mostly want to have the PDFs in the same place as the source files).

I don't know if the previously different behaviour on Windows was changed/unified by accident or intentionally. If some users (like you) want the old behaviour and others (like me) prefer the new, then probably there should be a setting to control the default export location: "last used directory" or "same dir as source document".

Anyway, needs UX evaluation.
Comment 2 Heiko Tietze 2020-12-14 12:38:44 UTC
We decided similar requests as wontfix in the past, see bug 134530. Point is that your workflow might involve different path but other users keep everything regarding one project together. 

But otherwise it makes sense to remember the last choice over the session. Making your request a duplicate and comment there. Feel free to reopen if you disagree.

*** This bug has been marked as a duplicate of bug 126665 ***
Comment 3 JaredMante 2021-10-12 11:44:21 UTC Comment hidden (spam)