Bug 130542 - Manual break causes page style to revert to default, if "Style" is not specified in "Insert Break" dialog
Summary: Manual break causes page style to revert to default, if "Style" is not specif...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Styles Writer-Styles-Page
  Show dependency treegraph
 
Reported: 2020-02-09 16:53 UTC by TorrAB
Modified: 2020-12-18 18:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
file with page style Chapitre (16.81 KB, application/vnd.oasis.opendocument.text)
2020-02-09 16:57 UTC, TorrAB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TorrAB 2020-02-09 16:53:04 UTC
Description:
	1: Open PageHeada.odt. First page has page style Chapitre, without header. Put cursor before 'def'.
	2: Insert -> More Breaks -> Manual Break -> Page Break. Or hit ^Enter.
	This opens page 2, default page style, with header.
	3: Double-click style Chapitre: page style is shown as Chapitre, but header stays. Why?
	4: Move cursor (Left) back to page 1, and back (Right) to p.2: page style is default! Double-clicking style Chapitre (step 3) did not really work.


Steps to Reproduce:
1. Open PageHeada.odt. First page has page style Chapitre, without header. Put cursor before 'def'.
2: Insert -> More Breaks -> Manual Break -> Page Break. Or hit ^Enter.
	This opens page 2, default page style , with header.
3: Double-click style Chapitre


Actual Results:
Double-clicking style Chapitre (step 3) does not change the style.

Expected Results:
Double-clicking style Chapitre should change the page style to Chapitre.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 TorrAB 2020-02-09 16:57:16 UTC
Created attachment 157758 [details]
file with page style Chapitre
Comment 2 Dieter 2020-02-10 15:58:48 UTC
I confirm, that it is not possible to change page style with double click. I see two possibilities:
a) It's the intended behaviour. But in this case, focus should go back to the used style to avoid confusion. That's a bug or enhancemen (I'm not sure)
b) It's a bug.

=> NEW and cc: Design team for further input
Comment 3 Heiko Tietze 2020-02-18 11:19:50 UTC
(In reply to TorrAB from comment #0)
> 	2: Insert -> More Breaks -> Manual Break -> Page Break. Or hit ^Enter.

Ctrl (or Cmd) + Enter is not the same as a page break with style. If you go via Insert -> More Breaks -> Manual Break -> Page Break and set any style but None you can switch per double-click to Chaiptre.

Admittedly, None is actually leading to Default and not being the same is confusing. I don't know why and if we can solve this.
Comment 4 R. Green 2020-03-04 17:59:43 UTC
> Admittedly, None is actually leading to Default and not being the same is
> confusing. I don't know why and if we can solve this.

Exactly. If nothing is specified in "Insert > More breaks > Manual break", then page style should NOT change.

Actually, there is actually more than one bug in this thread, namely:

1) Manual page break causes style to revert to default if no page style is specified (in "Insert > More breaks > Manual break").

2. Header does not update correctly when you change to another page style. You have to save, close and reload the file.

Can I suggest dedicating this thread to fixing bug 1 (above), and I will create another thread to address bug 2 link to follow).
Comment 5 R. Green 2020-03-04 18:24:03 UTC
For bug 2, see Bug 131132.
Comment 6 Heiko Tietze 2020-03-05 10:39:50 UTC
Sounds reasonable, removing UX.
Comment 7 Justin L 2020-12-18 18:22:22 UTC
Everything here is working as intended. Chapitre is set so that the following page will be Default Style. So the first page is going to be Chapitre, and the rest will all be default style unless you insert a page-style-break.

Double-clicking on Chapitre resets the "chain" of pages to start with Chapitre - and since that was already true, nothing happened. Chapitre stays highlighted in the page style list because that is what you clicked. Clicking any style in that list will take the highlight. So the only way to reset that is change pages. The alternative of NOT highlighting the item the user clicked and staying on the current page's style would violate all kinds of normal principles of UI. (Yes, I realize the discussion is about a double-click. And the cursor focus does stay on page 2, so one could push the argument further - but I'm not sure that would help in understanding very much.)

Sure, it is confusing when the page styles are all strung out in first-follow configuration, but the computer has no way of knowing what you want to do if you aren't inserting a page break.

So there is no "revert to default" by the manual break. Chapitre specifically states that the following page must use the default page style.