Bug 130547 - Function & Hotkey to Paste Format only in LO Writer - Enhancement Request
Summary: Function & Hotkey to Paste Format only in LO Writer - Enhancement Request
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2020-02-10 04:53 UTC by stefane.guevremont
Modified: 2020-02-21 14:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stefane.guevremont 2020-02-10 04:53:14 UTC
Description:
When using the "Clone Formatting" tool, as soon as the mouse button is released, the paintbrush function is "disbanded" and you must click the clone icon every time you want to clone formatting.

There is the "Double Click" on the Paintbrush icon to clone multiple times. I have not found a shortcut key that duplicates this function though.

The advantage with a "Paste Formatting" function, is the system keeps in memory the last text format that was copied. You can then perform other functions in between and re-execute the "Paste Formatting" function, and you then paste the format of what still is in memory.

I use this function quite a bit in Google Docs & Google Sheets (Ctrl + Alt + v).

Actual Results:
Paste Formatting in only one instance

Expected Results:
Paste Formatting in multiple instances, as long as format copied stays in memory.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Heiko Tietze 2020-02-18 12:04:27 UTC
Do you mean with "Paste Formatting" to paste the styles and direct formatting from a copied source? If so, what happens when you copy a paragraph with style Citation and some words have a character style Emphasis and some are links with Internet Link. Or you copy two paragraphs, one with Citation the other with Source Text, plus a lot of bad direct formatting. How should that be applied to the target cursor?

in case of Clone Formatting it's clear, you take only the current cursor position.
Comment 2 stefane.guevremont 2020-02-21 05:21:10 UTC
That's actually a good question. 

It could be the same functionality as with the "Clone Formatting". E.g. If a Non-formatted text and a bold text are in the same selection, then the clone tool is pressed, when pasted, the clone tool seems to ignore any format selected. It's too confusing to know what the user wants to paste, and I agree with that.

In Google Docs, they seem to have a different approach. I haven't quite figured out the logic behind the function. Sometimes some attributes get pasted and other times, others.
Comment 3 Heiko Tietze 2020-02-21 08:35:44 UTC
Let's not copy GDoc. It's pretty good at what it does - collaboration and simplicity - but not comparable as a full featured office suite / text processor. 

The recommended workflow is to use sidebar, menu, or "formatting (styles)" toolbar to apply paragraph style for the whole content and the document structure (headings, citations etc.). And to use character style to highlight parts, eg. Strong Emphasis to make it bold. It's a more or less one-click interaction and everything beyond makes not much sense.
Comment 4 V Stuart Foote 2020-02-21 14:28:54 UTC
concur with a WF
Comment 5 stefane.guevremont 2020-02-21 14:51:08 UTC
The point is not to copy GDocs. The point is to have the best functionalities, regardless of where they come from. So far as I can tell LibreOffice Writer seems to be the best Word processor and this is one other functionality to make it even better.

However, it seems like the implementation of it is not gaining in popularity. That is Ok.

Cheers guys