Bug 130549 - LibreOffice Writer - Paste Special = LibreOffice Calc - Paste Special
Summary: LibreOffice Writer - Paste Special = LibreOffice Calc - Paste Special
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-02-10 06:38 UTC by stefane.guevremont
Modified: 2021-06-25 07:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Reference: LO Calc - Paste Special Sub Menu Pop Up Window (11.86 KB, image/png)
2020-02-10 06:43 UTC, stefane.guevremont
Details
Mockup (55.50 KB, image/png)
2021-06-24 09:20 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefane.guevremont 2020-02-10 06:38:16 UTC
Description:
In LibreOffice Writer, it would be useful to have the same "Paste Special" Popup menu, as it is in LibreOffice Calc. Not all functions are transferable, but some are: Paste all, Text, Comments, Formats, etc.

Actual Results:
Current "Paste Special" menu item in LO Writer offers "Unformatted Text" and "More Options..." only.

Expected Results:
Add a "Paste Special..." sub menu item to the "Paste Special" menu item.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 stefane.guevremont 2020-02-10 06:43:08 UTC
Created attachment 157762 [details]
Reference: LO Calc - Paste Special Sub Menu Pop Up Window
Comment 2 Dieter 2020-02-11 16:24:55 UTC
Stefane, I don't know, where I can find the dialog of your attachment. I know there is Edit => Paste Special but couldn't find your pop up window

cc: Design-Team for enhancement request
Comment 3 V Stuart Foote 2020-02-11 17:17:42 UTC
@Dieter, that is the specialized "Paste Special..." dialog for Calc [1] from OOo and now as UI, only active and supplements the generalized Paste Special... dialog when clipboard source includes sc (Calc) described XML content.

IMHO it would not be appropriate alternative dialog for use in Writer which has the generalized Paste Special... dialog already.

=-ref-=

https://opengrok.libreoffice.org/xref/core/sc/uiconfig/scalc/ui/pastespecial.ui?r=70d6e8e1
Comment 4 stefane.guevremont 2020-02-12 03:01:40 UTC
With sincere respect I believe it would be good for these reasons:
- It would standardize menus between Calc and Writer
- It would be useful to have the Options of pasting:
  - Paste all
  - Text
  - Comments
  - Formats
  - Objects (although I'm not certain what objects are)
  - Link

The rest, of course, is non-applicable to Writer.

Personally, one thing I would like to do, is to create a Macro to paste Formats, and this would allow for this.

Cheers!
Comment 5 V Stuart Foote 2020-02-12 07:26:57 UTC
(In reply to stefane.guevremont from comment #4)
> With sincere respect I believe it would be good for these reasons:
> - It would standardize menus between Calc and Writer
> - It would be useful to have the Options of pasting:
>   - Paste all
>   - Text
>   - Comments
>   - Formats
>   - Objects (although I'm not certain what objects are)
>   - Link
> 

The 'Paste Special...' dialog is already standardized--that is the generalized dialog handles non-Calc type clipboard formats consistently. Including its use when pasting onto Calc sheets.

Only Calc cell/formula objects described in XML clipboard items are detected, and trigger launch of the specialized Calc object 'Paste Special...' dialog. 

It has been like that since OOo era--see no compelling reason to implement a new dialog for the other modules.
Comment 6 stefane.guevremont 2020-02-12 14:28:59 UTC
I see.

Would there be a way to "paste formats" in LibreOffice Writer? (may it be via a "paste special" sub-menu or any other way). I don't mean the "clone tool", I mean "paste formats" as it is in Libre Office Calc.
Comment 7 Heiko Tietze 2020-02-18 13:32:06 UTC
(In reply to stefane.guevremont from comment #4)
>   - Paste all
Exists as Paste

>   - Text
Exists as Paste Special

>   - Comments
>   - Objects (although I'm not certain what objects are)
>   - Link
Would be new (objects are shapes, text boxes, OLE objects...)

>   - Formats
This makes no sense to me, see bug 130547 comment 1.


Would be a very limited functionality. Writer as well as Impress/Draw are just not structured like Calc. So I believe this idea is a WF.
Comment 8 Heiko Tietze 2021-06-24 09:20:05 UTC
Created attachment 173148 [details]
Mockup

This is what I have in mind for a Paste Special dialog with more options. Not sure it's worth the effort.
Comment 9 Heiko Tietze 2021-06-24 09:22:39 UTC
Mike, what do you think? Also in context of recent discussions to clear formatting on bug 89960 or bug 130930.
Comment 10 Mike Kaganski 2021-06-24 09:44:36 UTC
WF imo.

1. Should we only have the proposed dialog for same-instance pastes? Note that the Calc's specialized dialog is not even for Calc XML content, but for same-instance - you will not have the dialog, even for different instances of the same application - e.g., copy something from Calc, close LO, open LO, open Calc, paste special - and generic dialog opens.

1.1. If not, then why? Can't we want to not paste objects when pasting from, say, browser?

1.2. If yes, then isn't it inconsistent again between Calc and Writer?

2. The Calc's paste options are applied *globally* for each Calc's "micro-document" which is each cell. In Writer, there's no such structure, as Heiko mentioned in comment 7. So this new function would have to behave *very* differently, doing some magic on parts of content of the same document text - and what if the result doesn't make sense? Like the "apply format", again mentioned in the same comment, because you don't have a strict pattern - "the whole cell at offset 0,0 at insertion site gets format taken from the whole cell at offset 0,0 of original site; the whole cell at offset 0,1 gets ..."? Comments? Where do you paste comments if you do not paste text? Same for objects - they may be anchored to paragraphs, characters, pages, frames, as characters - how do you paste all those if you don't paste their anchorings?

But maybe there could be a compelling mockup suggesting a good workflow that I don't realize?
Comment 11 Heiko Tietze 2021-06-24 11:45:58 UTC
The probably not so compelling mockup is attached. Stephane's idea was maybe to copy content from one document/page to another document/page (keeping ODF). And sometimes the use case is to drop a comment or to not apply the formatting. We discuss this issue from the other side: what to do when a format is not appropriate, eg. unintentionally pasted. 

Let's resolve this ticket as WF unless someone has good arguments to invest effort to build the bridge from both sides. Or different use cases.