Download it now!
Bug 130620 - Add help about "Windows Default Apps" button in Tools - Options - LibreOffice - General
Summary: Add help about "Windows Default Apps" button in Tools - Options - LibreOffice...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures Options-Dialog
  Show dependency treegraph
 
Reported: 2020-02-12 13:19 UTC by sdc.blanco
Modified: 2020-02-14 14:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-02-12 13:19:37 UTC
Tools - Options - LibreOffice - General - LibreOffice File Associations - Windows Default Apps

Pressing the "Windows Default Apps" button has no obvious effect.

Is that a bug?  

(have set OS to Windows - but maybe the problem is more general?)

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 61e1e0413296928d929f99c0f006c6cbbcf4ac40
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: en-US (en_DK); UI-Language: en-US
Calc: threaded

The documentation:

https://help.libreoffice.org/7.0/en-US/text/shared/optionen/01010600.html

does not give any advice (and could not find anything from searching help).
Comment 1 Ming Hua 2020-02-12 14:26:33 UTC
The WIP release notes for 7.0 on wiki [1] has this item:

Windows Default apps button was added to Options ▸ LibreOffice ▸ General, to call Windows file associations management. This button behaves according to Microsoft file association management policy, which is to open "Default apps" on Windows 7, 8, and 8.1; and to show a message telling user how to open that applet manually in Windows 10. This only works with registered application, so would not work for portable or testing (e.g. beta, when not using WRITE_REGSITRY=1 installation option) releases tdf#44462 (Mike Kaganski, Collabora)

So it's probably expected that the button in daily build version doesn't do anything.

[1] https://wiki.documentfoundation.org/ReleaseNotes/7.0
Comment 2 sdc.blanco 2020-02-12 17:12:38 UTC
Thanks Ming. I will change Component to "Documentation"
Comment 3 Commit Notification 2020-02-14 14:54:39 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/0b1d0df74b7b9dc98c18fccd375272f2dbe77256

tdf#130620  add help about File associations