Download it now!
Bug 130623 - Base: Empty Field Properties (gtk3)
Summary: Base: Empty Field Properties (gtk3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.1
Keywords: bibisected, bisected, regression
: 130022 130516 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-12 16:49 UTC by Xisco Faulí
Modified: 2020-02-17 13:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-02-12 16:49:39 UTC
Steps to reproduce:
1. Open an existing database or create a new one
2. Go to Table - Create Table in Design View
3. Type something in Field Name

-> Field Properties on the bottom is blank

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: 718f540fb63af27c1336f89213444e9af753b8a9
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-02-12 16:51:15 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8c66efa030e98cfdf5da20be368566d64e43c5d1

author	Caolán McNamara <caolanm@redhat.com>	2019-09-05 12:22:38 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2019-09-12 20:28:14 +0200
commit	8c66efa030e98cfdf5da20be368566d64e43c5d1 (patch)
tree	88c9fb335349fd1b7b285d46108e5d41a3c9aac4
parent	8150219824a1d08c4a22fd8bb7cc63fe2aa88074 (diff)
weld OCopyTableWizard cluster

Bisected with: bibisect-linux64-6.4 

Adding Cc: Caolán McNamara
Comment 2 Xisco Faulí 2020-02-12 16:52:36 UTC
it's also happening in gen but the properties are displayed if the dialog is resized...
Comment 3 Xisco Faulí 2020-02-12 16:53:54 UTC
*** Bug 130022 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2020-02-12 16:59:22 UTC
*** Bug 130516 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2020-02-13 08:51:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2921147f01129ac77a0a8cabc27e9c856c4e68b3

tdf#130623 owner of FieldControl needs to set its allocation

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-02-13 08:51:32 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dcf6fd8bb66cddbd54ec3f019ea606d2c99d9e08

tdf#130623 host gtk FieldControl within the design view

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2020-02-13 08:53:08 UTC
this works for me in master now, backport for 6-4 in gerrit
Comment 8 Commit Notification 2020-02-13 10:26:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/96018929add55cff71a036be3a67df385b023471

tdf#130623 owner of FieldControl needs to set its allocation

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Julien Nabet 2020-02-13 14:31:27 UTC
On Win10 with master sources updated today, I confirm I don't reproduce this anymore.
I'll give a try on pc Debian x86-64 after my daytime job.
Comment 10 Xisco Faulí 2020-02-14 19:40:55 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 54acab919e7c7c5d60fc697bda54278861ac250e
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 11 Xisco Faulí 2020-02-14 19:41:43 UTC
Also verified in

Version: 7.0.0.0.alpha0+
Build ID: 54acab919e7c7c5d60fc697bda54278861ac250e
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Commit Notification 2020-02-17 13:15:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-1":

https://git.libreoffice.org/core/commit/4d59f79bd3993c59cd04707db8f95787554b3a63

tdf#130623 owner of FieldControl needs to set its allocation

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.