Bug 130645 - Up and down arrow in data ranges work the other way around
Summary: Up and down arrow in data ranges work the other way around
Status: RESOLVED DUPLICATE of bug 130389
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-13 23:19 UTC by johantop
Modified: 2020-02-14 08:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johantop 2020-02-13 23:19:29 UTC
Description:
The up and down arrow in data ranges don't work as expected.
The up arrow moves down, down arrow moves up.

This gif shows it:
https://imgur.com/1Kr8fJ8

Steps to Reproduce:
1.Create a table with multiple columns
2.Create a graph of those columns as data ranges
3.Try to set an order for these data ranges
4.Use the up-arrow
5.Use the down-arrow

Actual Results:
Using the up-arrow makes the chosen range go down
Using the down-arrow makes the chosen range go up
The arrows become greyed out in the 'correct' position if the arrow would've been working as expected. So the upper most item cannot be moved downwards. The lower most item cannot be moved up.

Expected Results:
The down-arrow should move the range down, and the up-arrow should move the range up.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
See this gif:
https://imgur.com/1Kr8fJ8
Comment 1 Julien Nabet 2020-02-14 08:53:32 UTC
It should be fixed from next release 6.4.1

*** This bug has been marked as a duplicate of bug 130389 ***