Download it now!
Bug 130676 - LibO Calc: Insert Time Shortcut (Ctrl + shift + ;) Doesn't Work Properly
Summary: LibO Calc: Insert Time Shortcut (Ctrl + shift + ;) Doesn't Work Properly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2020-02-15 04:55 UTC by Rania Amina
Modified: 2020-07-07 08:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rania Amina 2020-02-15 04:55:33 UTC
Description:
To insert date and time quickly, actually we hold down ctrl + ; (for date) and ctrl + shift + ; (for time). Insert date work properly, but not for insert time shortcut. When i hold down ctrl + shift + ; appear ( : ) character instead time.

I try to look for keyboard shortcut list on Tool menu -> Customize -> Keyboard. At insert functions list, there no option for Time, so i can't make custom shortcut.

Steps to Reproduce:
1. Open LibreOffice Calc
2. Hold Down Ctrl + Shift + ; button

Actual Results:
Appear ( : ) chararter inside cell

Expected Results:
Appear current time inside cell


Reproducible: Always


User Profile Reset: No



Additional Info:
I tried on newest LibreOfficedev but this problem still exist.
Comment 1 Ming Hua 2020-02-15 06:50:05 UTC
Hi Rania,

Thanks for reporting the bug.  What operating system and what keyboard layouts are you using?  It is also helpful if you can paste the inforamtion about your system in the Help > About LibreOffice dialog (the text can be selected by mouse) here.

This is a known problem for some keyboard layouts, see for example, the dependency list of bug 107243.
Comment 2 Rania Amina 2020-02-15 14:25:23 UTC
I use Debian Linux with KDE.
The keyboard is QWERTY (US)
Comment 3 Ming Hua 2020-02-16 10:14:38 UTC
US keyboard shouldn't have this problem.  Let's ping the KDE meta bug to see if it's KDE5-specific, then.

@Rania Amina, you need to provide more information, for example content of "Help > About LibreOffice" dialog, like this (from my version of LibreOffice):
Version: 6.3.5.1 (x64)
Build ID: 9a62adaf9abe90e8fef419f29114b0176dd66801
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded

... as well as your Debian version.  Is it Debian 10 (stable/buster)?  Also where did you download LibreOffice, is it official DEB package from www.libreoffice.org?

Meanwhile, you can check the Tool > Customize... > Keyboard dialog again, make sure "Calc" is selected on the top right corner, instead of "LibreOffice".  Then choose "Insert" in the Category column, and find "Insert Current Time" in the Function column, you should be able to change the key combination (at least that's the case for my 6.3.5 version).
Comment 4 Jan-Marek Glogowski 2020-03-01 16:46:20 UTC
Please provide the requested info and reset the status to UNCONFIRMED.

There was just a fix in the keyboard handling for the kf5 VCL backend: https://gerrit.libreoffice.org/c/core/+/89663

With current master, "ctrl + shift + ;" inserts the time in Calc for me.
Comment 5 Michael Weghorn 2020-07-07 08:00:51 UTC
Works fine for me as well with current master.

If there was still an issue, that one might also have been fixed by https://gerrit.libreoffice.org/c/core/+/94305 , s. tdf#130676.

Since there hasn't been a reply in over 4 months, let's close as WORKSFORME. Please reopen and add additional information if you still see this issue.

Version: 7.1.0.0.alpha0+
Build ID: 9af38b4504ccda57a0c32eb8bdd03e5a8ca29ddc
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: kf5
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded