Bug 130701 - VCL kf5 is blurry on Wayland
Summary: VCL kf5 is blurry on Wayland
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 127687
Blocks: KDE
  Show dependency treegraph
 
Reported: 2020-02-16 09:23 UTC by johann.hoechtl
Modified: 2020-04-06 15:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johann.hoechtl 2020-02-16 09:23:12 UTC
Libreoffice integration of Wayland into the kf5 backend is not at feature parity with the gtk3 backend: When the desktop is scalend (eg. when using a HiDPI laptop as I do) image elements in eg. writer documents are blurry and font rendering is very blurry.

Starting libreoffice on wayland plasma with SAL_USE_VCLPLUGIN=gtk3 as ssen on #121275 makes libreoffice crisp and working very well, unfortunately with the bug that GTK3 dialogs have issues when resizing ("jumping around") (Besides that when using libreoffice on KDE, libreoffice should use KDE-dialogs)
Comment 1 johann.hoechtl 2020-02-16 09:42:59 UTC
It's worth noting that starting libreoffice with 

SAL_USE_VCLPLUGIN=gtk3_kde5

gives me the best of both worlds:
* Sharp text
* Sharp (and working) KDE dialogs

According to https://bbs.archlinux.org/viewtopic.php?id=245601 it's deprecated? Works well for me though.

Nonetheless the bug stands in that libreoffice should be crisp out of the box on plasma wayland.
Comment 2 Jan-Marek Glogowski 2020-02-23 01:42:58 UTC
Maybe a duplicate of bug 127687? But that is just about UI scaling, not about blurry fonts. gtk3_kde5 just has the KDE file picker. But since gtk3 is comparably more mature then the qt5 backend and even uses native widgets (see bug 130857), it even looks better if the breeze gtk theme is used.

Nobody will or even plans to remove it in the near future (a sin years), but kf5 is now the default plugin for the plasma desktop.

(In reply to johann.hoechtl from comment #1)
> According to https://bbs.archlinux.org/viewtopic.php?id=245601 it's
> deprecated? Works well for me though.

That statement is definitely wrong. The code base for gtk3 and gtk3_kde5 is the same, except for the different file picker, which is handled by an external picker program.
Comment 3 Xisco Faulí 2020-04-06 15:13:19 UTC
Based on comment 2, could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build