Download it now!
Bug 130750 - Kanji disappears when ods saved in Excel is opened in Calc
Summary: Kanji disappears when ods saved in Excel is opened in Calc
Status: RESOLVED DUPLICATE of bug 129940
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Ruby CJK CJK-Japanese
  Show dependency treegraph
 
Reported: 2020-02-18 04:17 UTC by nogajun
Modified: 2020-02-18 04:36 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
ods file from saved Excel (82.77 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-02-18 04:19 UTC, nogajun
Details
Screenshot from Calc (75.09 KB, image/png)
2020-02-18 04:20 UTC, nogajun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nogajun 2020-02-18 04:17:40 UTC
Description:
Kanji disappears when opening an ods file saved in ods from Excel(2019 or Office 365) from LibreOffice Calc.

Steps to Reproduce:
1. Input kanji with Excel(2019 or Office 365) in Japanese environment.
2. Save the file in ods format [OpenDocumen Spredsheet(*.ods)].
3. Open the saved ods file from LibreOffice Calc.

Actual Results:
Kanji is not displayed.

Expected Results:
Kanji is displayed.


Reproducible: Always


User Profile Reset: No



Additional Info:
Excerpt from content.xml.
Kanji included in ods saved from Excel has ruby attached. (Kanji is not displayed) 

----
<table-cell office:value-type="string" table:style-name="ce1">
    <p>
        <ruby text:style-name="ru1">
            <ruby-base>
                日本語
            </ruby-base>
            <ruby-text text:style-name="T1">
                ニホンゴ
            </ruby-text>
        </ruby>
    </p>
</table-cell>
----

No ruby in Hiragana. (Hiragana is displayed)

----
<table-cell office:value-type="string" table:style-name="ce1">
    <p>
        ひらがな
    </p>
</table-cell>
----


バージョン: 6.4.0.3 (x64)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 2; OS:Windows 10.0 Build 18363; UI render: default; VCL: win; 
ロケール: ja-JP (ja_JP); UIの言語: ja-JP
Calc: threaded
Comment 1 nogajun 2020-02-18 04:19:17 UTC
Created attachment 157966 [details]
ods file from saved Excel
Comment 2 nogajun 2020-02-18 04:20:23 UTC
Created attachment 157967 [details]
Screenshot from Calc
Comment 3 Naruhiko Ogasawara 2020-02-18 04:36:52 UTC
This could be duplicated tdf#129940

*** This bug has been marked as a duplicate of bug 129940 ***