Download it now!
Bug 130802 - WRITER EDITING: Frame goes out of the shape after moving
Summary: WRITER EDITING: Frame goes out of the shape after moving
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords:
: 133064 (view as bug list)
Depends on:
Blocks: Anchor-and-Text-Wrap Shape-Textbox
  Show dependency treegraph
 
Reported: 2020-02-20 10:55 UTC by NISZ LibreOffice Team
Modified: 2020-06-24 17:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Writer (8.57 KB, application/vnd.oasis.opendocument.text)
2020-02-20 10:59 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in Writer (40.61 KB, image/png)
2020-02-20 11:00 UTC, NISZ LibreOffice Team
Details
How it looks in LibreOffice 7.1 (394.29 KB, video/x-matroska)
2020-06-16 11:26 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-02-20 10:55:50 UTC
Description:
Frame in shapes while the shape moved the frame does not move with the shape.

Steps to Reproduce:
    1. Create a new text document in Writer 7.0
    2. Create 10 paragraphs
    3. Insert a Shape (for example a rectangle) and anchor it to the 10th paragraph
    4. Add a frame to the shape (add textbox option)
    5. Type something to the frame
    6. Change the anchor of the shape to the 1th paragraph
    7. Notice the shape moved with 8 paragraphs width and the frame still the same place hoewer it should move with the shape.

Actual Results:
The frame does not follow the shape

Expected Results:
The frame should move with the frame


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 4328255429e47d9e8278845422d3f11eebef3742
CPU threads: 8; OS: Windows 10.0 Build 17134; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-02-20 10:59:47 UTC
Created attachment 158031 [details]
Example file from Writer
Comment 2 NISZ LibreOffice Team 2020-02-20 11:00:11 UTC
Created attachment 158032 [details]
Screenshot of the problem in Writer
Comment 3 Dieter 2020-02-20 15:46:34 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: eeb2d19e77d6dc47c68e8ba0920a02cf64a1247b
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

and also with

Version: 6.3.4.2 (x64)
Build-ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

additional information: this doesn't happen, when I move the shape for the first time. It happens only, if Imove it again to another paragraph.

Related to bug 122887
Comment 4 Aron Budea 2020-02-22 15:38:00 UTC
What is supposed to be bibisected here? No working previous version, or changed behavior compared to a previous version is mentioned.
Comment 5 László Németh 2020-03-09 09:45:03 UTC
@Áron: you are right. This is a problem of the original implementation.
Comment 6 Commit Notification 2020-06-10 08:46:48 UTC
Attila Bakos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a938ead6639777337267f613cb0dea9c326c15b0

tdf#130802 SwTextBoxHelper::syncFlyFrameAttr: fix dragging

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Attila Bakos (NISZ) 2020-06-10 11:57:50 UTC
*** Bug 133064 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2020-06-16 11:26:12 UTC
Created attachment 162048 [details]
How it looks in LibreOffice 7.1
Comment 9 Xisco Faulí 2020-06-16 11:27:40 UTC
Hello Attila, NISZ team,
I still reproduce the issue in

Version: 7.1.0.0.alpha0+
Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

or is it another issue ?
Comment 10 NISZ LibreOffice Team 2020-06-16 11:54:17 UTC
(In reply to Xisco Faulí from comment #9)
> Hello Attila, NISZ team,
> I still reproduce the issue in
> 
> Version: 7.1.0.0.alpha0+
> Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
> CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc: threaded
> 
> or is it another issue ?

From the commit message:

Dragging the selected shapes resulted broken text boxes:
the text showed outside of the shapes. This is fixed in
the case of paragraph, character and page anchoring.

I understand this fixed the shape dragging case (anchor also moves when the shape is dragged). 
What you did in the video is anchor dragging, which is different still existing problem, and is being worked on under bug #122887
Comment 11 Xisco Faulí 2020-06-16 11:58:08 UTC
(In reply to NISZ LibreOffice Team from comment #10)
> (In reply to Xisco Faulí from comment #9)
> > Hello Attila, NISZ team,
> > I still reproduce the issue in
> > 
> > Version: 7.1.0.0.alpha0+
> > Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
> > CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
> > Locale: en-US (en_US.UTF-8); UI: en-US
> > Calc: threaded
> > 
> > or is it another issue ?
> 
> From the commit message:
> 
> Dragging the selected shapes resulted broken text boxes:
> the text showed outside of the shapes. This is fixed in
> the case of paragraph, character and page anchoring.
> 
> I understand this fixed the shape dragging case (anchor also moves when the
> shape is dragged). 
> What you did in the video is anchor dragging, which is different still
> existing problem, and is being worked on under bug #122887

oh right, thanks for the clarification. Putting it back to RESOLVED FIXED
Comment 12 Commit Notification 2020-06-19 13:12:21 UTC
Attila Bakos committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/c1c93987acbb83d8352656d77ee515e98c63d46b

tdf#130802 SwTextBoxHelper::syncFlyFrameAttr: fix dragging

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 BogdanB 2020-06-24 17:23:54 UTC
It's ok now
Verified in:
Version: 7.0.0.0.beta2+
Build ID: 77e4943cc6cf206a45901e5c87fabf0f783c8262
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2020-06-24_02:22:53
Calc: threaded