Bug 130850 - Calc still shows a validity's drop-down icon after you selected another sheet
Summary: Calc still shows a validity's drop-down icon after you selected another sheet
Status: RESOLVED DUPLICATE of bug 61623
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
3.4.0 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Calc-UX Cell-Validity
  Show dependency treegraph
Reported: 2020-02-21 15:56 UTC by oldeng.readnews
Modified: 2022-07-15 09:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

test data validity.ods (8.94 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-02-21 18:12 UTC, Oliver Brinzing

Note You need to log in before you can comment on or make changes to this bug.
Description oldeng.readnews 2020-02-21 15:56:17 UTC
I select a cell that is configured as a pick list. The cell gets the focus and displays a down arrow icon to its right. I click on the pick icon and a list is displayed. That works fine. If I leave the cell selected with the pick icon displayed and change to a different sheet then the icon is still displayed on the different sheet. I'm using 6.4.0. I reinstalled it and also tried 6.3.1. I tried resetting all options.  Reproduced same issue in Safe Mode.

Steps to Reproduce:
1. Create two sheets
2. Create cell with Vality Range of Cells on sheet one
3. Give that cell focus to display down arrow.
4. Leave cell active with down arrow displayed and change to other sheet.

Actual Results:
The down arrow icon persists on the second sheet selected.

Expected Results:
The down arrow should be dismissed when the other sheet is selected.

Reproducible: Always

User Profile Reset: Yes

OpenGL enabled: Yes

Additional Info:
It is as if the down arrow selection arrow is disconnected from its owner cell.  Perhaps the selection of the second sheet is not getting a focus on one of its cells?  The same issue exists in Safe Mode.  I do not have OpenGL installed.
Comment 1 Oliver Brinzing 2020-02-21 18:12:12 UTC
reproducible with:

Version: (x64)
Build ID: aa58c380894dd384f6ce1efc62b3932136f2f477
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

Version (Build ID: e183d5b)

but *not* reproducoble with AOO 4.1.5
Comment 2 Oliver Brinzing 2020-02-21 18:12:38 UTC
Created attachment 158088 [details]
test data validity.ods
Comment 3 QA Administrators 2022-02-21 03:33:29 UTC Comment hidden (obsolete)
Comment 4 Roman Kuznetsov 2022-02-22 21:11:10 UTC
Still rerpo

Version: (x64) / LibreOffice Community
Build ID: b438854a0b5148880e455cbeeff14d4e3d825711
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL Jumbo
Comment 5 Gabor Kelemen (allotropia) 2022-07-15 09:13:31 UTC

*** This bug has been marked as a duplicate of bug 61623 ***