Download it now!
Bug 130890 - Please no false autocorrection by default!
Summary: Please no false autocorrection by default!
Status: RESOLVED DUPLICATE of bug 59754
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2020-02-24 00:59 UTC by peter.reitinger
Modified: 2020-02-24 10:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter.reitinger 2020-02-24 00:59:50 UTC
Description:
At least in German, the autocorrection by default is absolute bullshit (sorry). When I am typing quickly, the result is absolute nonsens because of the many wrong automatic corrections!
It was impossible to switch it off easily. I tried: 
- deactivate Extras/Automatische Rechtschreibprüfung
- deactivate Extras/Autokorrektur/Während der Eingabe

None of the above prevented libre office writer to correct words in my input lines. Why?? I can write on my own, I do not want to be corrected. Thank you! :-)

Actual Results:
Type german text in german LibreOffice Writer and there will be a lot of wrong corrections that maybe make sense SOMETIMES but it is absolutely annoying to undo all of these wrong corrections. It prevents absolutely from quick typing!!!

Expected Results:
As said, many wrong autocorrections without any confirmation of mine


Reproducible: Always


User Profile Reset: No



Additional Info:
No autocorrections by default, only after user choses a menu or whatsoever to make the software correct one!
Comment 1 Kevin Suo 2020-02-24 05:43:30 UTC
You can disable auto correction by deselect:
Tools > Auto Correct > When Typing.

Auto correct works in many other languages such as English etc, I don't think it is worth disabling by default? 

Actually for me it really does not matter as I use Simplified Chinese and this feature never work in Chinese language.
Comment 2 Dieter 2020-02-24 10:53:20 UTC
(In reply to peter.reitinger from comment #0)
> Description:
> At least in German, the autocorrection by default is absolute bullshit
> (sorry). When I am typing quickly, the result is absolute nonsens because of
> the many wrong automatic corrections!
> It was impossible to switch it off easily. I tried: 
> - deactivate Extras/Automatische Rechtschreibprüfung
> - deactivate Extras/Autokorrektur/Während der Eingabe
> 
> None of the above prevented libre office writer to correct words in my input
> lines. Why?? I can write on my own, I do not want to be corrected. Thank
> you! :-)

Peter, it should indeed solve your problem to deactivate the option in Extras => Autokorrektur => Während der Eingabe. If you only want to disable WordComplete you should try Exras => AutoKorrektur => AutoKorrektur Optionen => Wortergänzung => disable "Wortergänzung aktivieren"

Does this solve your problem? If not, you can use https://ask.libreoffice.org/ for further help.

Your proposal to disable autocorrect by default is a duplicate of bug 59754 and this idea has been rejected.

*** This bug has been marked as a duplicate of bug 59754 ***