Bug 59754 - Disable autocompletion/autocorrect by default
Summary: Disable autocompletion/autocorrect by default
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 99979 (view as bug list)
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2013-01-23 09:36 UTC by AaronPeterson
Modified: 2016-10-19 23:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description AaronPeterson 2013-01-23 09:36:18 UTC
Problem description: 

Steps to reproduce:
1. .... Try to write a document with any type of content.
2. ....Spread sheets go whacky crazy and input random stuff, Like I try to type do, and it fill in something like dog because I typed in dog earlier.
3. .... Word processor,  I try to make a simple list of stock sizes .75  .76  .77   And it freaking indents stuff, then deletes the numbers that I wrote down when I try to correct the formatting.


Current behavior:
I have to remember to turn off auto complete on every single computer I have libre (or open office) on.

Expected behavior:
Autocomplete should be off by default.  It only helps a few people in rare circumstances, other than that, it causes freaky weird errors that may not be caught.  and even loss of data (thankfully control Z worked.
              
Operating System: Ubuntu
Version: 3.5.3 release
Comment 1 Adolfo Jayme 2013-02-19 04:20:28 UTC Comment hidden (obsolete)
Comment 2 QA Administrators 2015-02-19 15:34:43 UTC Comment hidden (obsolete)
Comment 3 mahfiaz 2015-02-19 21:30:26 UTC
I agree, autocomplete more often annoys me and it being helpful is seldom. So some improvement would be welcome. Maybe autocomplete in Calc should only suggest a word which has been used at least two times as an exact verbatim copy (or at least exact same first one or more words).
Comment 4 Yousuf Philips (jay) (retired) 2015-02-22 00:33:27 UTC
Autocomplete does fix spelling mistakens and changes '---' into a horizontal line, so it does do somethings that are useful.
Comment 5 Jean-Baptiste Faure 2015-02-22 08:33:56 UTC
(In reply to Jay Philips from comment #4)
> Autocomplete does fix spelling mistakens and changes '---' into a horizontal
> line, so it does do somethings that are useful.

I agree. If you filled this bug report, that means you are aware of autocompletion and you are able to disable it for you if you prefer. So why your own preference should be made the default behavior for all users ?

So, as nobody gave clear data showing that autocompletion gives more issues than help for mean user, I propose to close this bug report as NOTABUG.

Best regards. JBF
Comment 6 Heiko Tietze 2015-02-22 08:55:49 UTC
Although Writer is meant to process words not numbers I agree with the use case. Two solutions come to mind: a) an easy way to temporarily disable auto-correction (toolbar/shortcut) and b) to extend the exception options with tables, areas, or styles.
Comment 7 Yousuf Philips (jay) (retired) 2015-02-26 04:03:35 UTC
Was rumaging through my backlog of tweets and found a user who had problems with it.

https://twitter.com/B4NTOtwit/status/545343328846630913
@libreoffice is it possible to turn of the double - when writing hello - hello ?
Libre makes it automatically hello -- hello why add extra -
Comment 8 Yousuf Philips (jay) (retired) 2015-02-27 06:23:08 UTC
One of the funny twitter discussions i had about autocorrect.

Libreoffice stop automatically changing sidewalk to pavement. I want sidewalk dammit! This is censorship! #OverdramaticWriterIsOverdramatic
https://twitter.com/griddles83/status/540387669767770112
Comment 9 Cor Nouws 2015-02-27 09:09:56 UTC
I tend to disagree with the request. 
Running into trouble with this features, is a great push/opportunity for users to get more knowledge of the powers of the office suite. Anyway, that's what one would hope. And if you do not stumble over it, there's no trigger to look and learn ..
(Ah well ;) )
Comment 10 QA Administrators 2015-04-01 14:51:43 UTC Comment hidden (obsolete)
Comment 11 Yousuf Philips (jay) (retired) 2015-04-15 12:52:06 UTC
Reopening this as ux-advise was discussing this and we had different opinions about it.
Comment 12 AaronPeterson 2015-08-17 06:35:17 UTC
Thank you for reopening.
I just started working on an important spreadsheet, and was changing a formulae from C10  to H10, and it replaced it with the HARMEAN() function.

This is 4.4.2
I am installing 5.0 right now.

I help seniors with their computers, and I can't even begin to explain why when they type something correctly it gets changed to something incorrect.

It's by plain observation that autocomplete is a UX nightmare, and while fun for computer science majors,  it's not appropriate to subject us users to experimentation.
Comment 13 AaronPeterson 2015-08-17 06:40:25 UTC
Actually, in Calc,  I can't find the way to turn off Auto[in]Correct.

I go to Tools-->AutoCorrect Options--> and get nothing to turn off the dang thing.
Comment 14 AaronPeterson 2015-08-17 06:42:40 UTC
This is the formulae that autocomples in a way that i have3n't figured out how to fix.

=C6*F6/60

should be
=H6*F6/60

but when I replace the C with H and hit enter, (which should work) it replaces with the Hermian whatever.

If I click elsewhere, it replaces it with the cell that I click on.

If I hit escape, it should revert to what it was.

I really don't know how to exit this.
Comment 15 Cor Nouws 2015-08-17 10:14:41 UTC
Hi Aron,

Thanks for the additional examples.
Those were triggered by another bug: #tdf 89031
Luckily fixed in the mean time.
Cor
Comment 16 Cor Nouws 2015-08-17 10:15:50 UTC
(In reply to AaronPeterson from comment #14)
> This is the formulae that autocomples in a way that i have3n't figured out
> how to fix.

Simply type <left> after you corrected the letter.
Comment 17 mahfiaz 2016-04-23 11:11:47 UTC
Aaron's use case annoys me as well. I got used to it, but it is stupid.
Comment 18 Jean-Baptiste Faure 2016-04-26 06:58:40 UTC
(In reply to mahfiaz from comment #17)
> Aaron's use case annoys me as well. I got used to it, but it is stupid.

So the right answer is not to disable autocorrection by default, but fix each autocorrection misbehavior. So, please, file _a_ bug report for _each_ autocorrection misbehavior you encounter and do not get lost in pointless generalities.

Closing as NotABug because autocorrection is activated by default by design.

Best regards. JBF
Comment 19 AaronPeterson 2016-04-27 05:39:04 UTC
I'm sorry,
every single time that autocorrect takes place, it is an error.
It should be off by default... I can't think of any time most users would use it, and for people who want it, they can turn it on and fight endless ambiguity.
Comment 20 Jean-Baptiste Faure 2016-04-27 10:43:39 UTC
(In reply to AaronPeterson from comment #19)
> I'm sorry,
> every single time that autocorrect takes place, it is an error.
> It should be off by default... I can't think of any time most users would
> use it, and for people who want it, they can turn it on and fight endless
> ambiguity.

I can return your argument to you: if you are not happy with autocorrection it is easy to disable it. Please do not presume what other users prefer.
From my own user experience since StarOffice 5.1, autocorrection works as expected and is an essential functionality for me. For the rare cases I encounter where it misbehaves, ctrl+Z allows to undo the autocorrection.

Another reason to not disable it by default, is that doing that will hide this functionality and make it very difficult to discover for new users.

Best regards. JBF
Comment 21 Adolfo Jayme 2016-05-19 08:52:37 UTC
Please don’t reopen this report again. We respect and understand your opinion on the AutoCorrect feature, but we won’t disable it by default for the rest of the users.
Comment 22 Yousuf Philips (jay) (retired) 2016-10-19 23:25:11 UTC
*** Bug 99979 has been marked as a duplicate of this bug. ***