Bug Hunting Session
Bug 89031 - EDITING - Calc Function suggestion too agressive
Summary: EDITING - Calc Function suggestion too agressive
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: All All
: medium minor
Assignee: Winfried Donkers (retired)
URL:
Whiteboard: target:5.1.0 target:5.0.1 target:4.4....
Keywords: regression
: 96986 (view as bug list)
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2015-02-02 00:03 UTC by alex
Modified: 2016-10-19 23:31 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alex 2015-02-02 00:03:30 UTC
Manually editing an existing formula now aggressively autocompletes function names.
Example: 
1/ I have a cell containing the formula =D1*5
2/ I want to edit the formula to reference cell E1 instead, so I postion my cursor in the Formula Editor, delete the letter 'D', type 'E' and press [ENTER].
3/ The formula is autosuggested to read =EASTERSUNDAY()*5

While not major, it interrupts workflow substantially for any user typing formulas with cell references: seems to have been in place since about 4.3.5.1, have verified that it wasn't the can in an old install of 4.1.6.2

I would like to turn it off: I don't suppose there's just a setting I've missed?
Comment 1 Cor Nouws 2015-02-02 10:20:04 UTC
Hi Alex,

I conform the issue. Experienced it myself, but didn't really check what is going on: just using RIGHT  before ENTER.
But I agree that it's annoying.

( did not search for duplicates
  did not search for first known commit/version that has the bug 
  therefore NEEDINFO - but not from Alex AFAIAC
)

Cor
Comment 2 Cor Nouws 2015-02-02 10:21:35 UTC
maybe the autocompletion of function should not work if there is no space after the cursor.
Comment 3 alex 2015-02-02 21:37:50 UTC
Thanks Cor.
As you note, it can be worked around relatively easily, but this is at odd with my decades-old editing habits.
That's likely to be the case for other users too, but mostly sits at the level of petty annoyance, where I make an edit without thinking, realise the formula is borked and have to go back to change.
Your suggestion of No autocomplete if there is no space after the cursor sounds good -probably best if it could still show the suggestion so user can select if they want, but not insert automatically.  THat way anyone with old habits is not impeded, which is better for switchers (and those upgrading from older LO releases.)
Thanks!
Comment 4 Octavio Alvarez 2015-02-25 06:48:33 UTC
I'm setting this back to NEW as the bug is already confirmed.

I want to re-confirm it. Found on LibreOffice 4.3.5.2, Build ID: 430m0(Build:2) on Ubuntu 14.04.1 LTS.
Comment 5 pavelz 2015-04-03 18:43:32 UTC
I also consider the autocomplete of formulas rather aggresive (LibreOffice 4.4.2.2).

It could be prevented, if suggestions started for at least two characters, I didn't find any setting for this.
Comment 6 raal 2015-04-07 19:48:44 UTC
Works OK in LibreOffice 3.5.0 Build ID: d6cde02 -> regression.
Very annoying, I think importance should be higher than minor
Comment 7 Eike Rathke 2015-06-17 09:37:34 UTC
@Winfried:
Maybe one for you, as you were already working in this area?
Function name completion should not hit when editing and the next character is alphanumeric, for example (just a quick guess).
Comment 8 Marek Dolezel 2015-07-07 21:56:26 UTC
also bad for these:
# bad: [f1142b286f151d5588a07bef2c2700a465160e3b] source-hash-4815d3da5647b274894bbf4edafcadab179ce8f0

# bad: [c820bc14ec13b8f216ebc27c0633b3006b4bc293] source-hash-8ac30e7c450acf3147454e6cb2a86978f1359c54

count go any further down because got terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException' on older versions
Comment 9 Winfried Donkers (retired) 2015-07-08 05:28:33 UTC
(In reply to Marek Dolezel from comment #8)
> also bad for these:
> # bad: [f1142b286f151d5588a07bef2c2700a465160e3b]
> source-hash-4815d3da5647b274894bbf4edafcadab179ce8f0
> 
> # bad: [c820bc14ec13b8f216ebc27c0633b3006b4bc293]
> source-hash-8ac30e7c450acf3147454e6cb2a86978f1359c54
> 
> count go any further down because got terminate called after throwing an
> instance of 'com::sun::star::uno::DeploymentException' on older versions

@Marek:
I'm on it, and know exactly where the problem is. Making the patch work for all languages (as formulas can be in all sorts of language, with their specific characters) takes some time.
Comment 10 Commit Notification 2015-07-13 13:20:48 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f3d748937a177cbbc0033bcf54d0d0fd57a1b409

tdf#89031 remove agressiveness from Calc function suggestions

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2015-07-13 13:30:55 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=579f5cbfc4636ae28e545b0d2e456e100b08b4ad&h=libreoffice-5-0

tdf#89031 remove agressiveness from Calc function suggestions

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2015-07-13 14:34:47 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=865afb6ed25891129efb6907595c892e417a191a&h=libreoffice-4-4

tdf#89031 remove agressiveness from Calc function suggestions

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Eike Rathke 2015-07-13 14:39:09 UTC
Pending review https://gerrit.libreoffice.org/17014 for 5-0-0
Comment 14 Commit Notification 2015-07-13 15:24:36 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0d83531e915cf5dda33c41025d4d6afba4d6908d&h=libreoffice-5-0-0

tdf#89031 remove agressiveness from Calc function suggestions

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Cor Nouws 2015-07-13 21:11:10 UTC
Thanks a lot Winfried - saves quite some recently learned additional key strokes in various operations ;)
Comment 16 alex 2015-08-06 03:28:34 UTC
Finally got to testing this - perfect!

Thanks!
Comment 17 Jean-Baptiste Faure 2016-01-16 09:07:13 UTC
It seems that $ should be added to the list of characters that disable autocomplete of preceding string, see bug 96986.

Best regards. JBF
Comment 18 Jean-Baptiste Faure 2016-01-16 09:08:39 UTC
*** Bug 96986 has been marked as a duplicate of this bug. ***
Comment 19 Winfried Donkers (retired) 2016-01-16 16:48:46 UTC
(In reply to Jean-Baptiste Faure from comment #17)
> It seems that $ should be added to the list of characters that disable
> autocomplete of preceding string, see bug 96986.

I will look into this and see if I can fix it soon.
Comment 20 Commit Notification 2016-01-19 13:10:39 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1e2bcb3177d58e6f446296ae28fcff7f5da9b620

follow-up of tdf#89031

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2016-01-19 13:24:12 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e2b222cc98b1378b85d0c37eb9f5ef562247b3cf&h=libreoffice-5-1

follow-up of tdf#89031

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2016-01-19 13:35:24 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=26bafaacd071dcba4bf7f75776e31c5786cfd725&h=libreoffice-5-0

follow-up of tdf#89031

It will be available in 5.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Jean-Baptiste Faure 2016-01-19 15:59:27 UTC
Tested on LO 5.1.1.0.0+ under Ubuntu 15.10 x86-64: works as expected.

Thank you very much. Closing again as Fixed.

Best regards. JBF