Bug 96986 - Formula Autocomplete When Editing Formula Using $
Summary: Formula Autocomplete When Editing Formula Using $
Status: RESOLVED DUPLICATE of bug 89031
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-09 16:12 UTC by John
Modified: 2016-01-16 09:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John 2016-01-09 16:12:21 UTC
Problem description:
When editing a formula in Calc, Calc autocompletes the formula if the cell is locked with $. 

Steps to reproduce:
1. Type =$c$4 into cell A1
2. Delete "c" and type "s", press enter
3. Autocompletition kicks in and you have =$search()$4

Expected behavior:
Autocompletition does not suggest function name. 

Currently Calc does not suggest a function name if the cell is not locked with $.

For example:
1. Type =c4 into cell A1
2. Delete "c" and type "s", press enter
3. Changes cell to =s4 as expected

This unintended autocompletion appears to happen with all formulas if the cell is locked with $.
Comment 1 m.a.riosv 2016-01-09 20:28:56 UTC
Hi @John, thanks for reporting.

I can't reproduce in Win10x64 with:
Version: 5.0.4.2 (x64) Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78

There was fixed a less aggressive behaviour in https://bugs.documentfoundation.org/show_bug.cgi?id=89031
Comment 2 Jean-Baptiste Faure 2016-01-16 09:08:39 UTC
Duplicate of bug 89031. The character $ should be added to the list of characters that disable autocomplete of preceding string.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 89031 ***