Download it now!
Bug 131121 - Chart misplaced after docx export
Summary: Chart misplaced after docx export
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
6.3.0.1 rc
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-compatiblityMode-15
  Show dependency treegraph
 
Reported: 2020-03-04 12:39 UTC by Samuel Mehrbrodt (CIB)
Modified: 2020-03-20 06:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Bugdoc (26.29 KB, application/vnd.oasis.opendocument.text)
2020-03-04 12:39 UTC, Samuel Mehrbrodt (CIB)
Details
Word PDF export (before Convert) (114.58 KB, application/pdf)
2020-03-04 12:40 UTC, Samuel Mehrbrodt (CIB)
Details
Word PDF export (after Convert) (293.27 KB, application/pdf)
2020-03-04 12:40 UTC, Samuel Mehrbrodt (CIB)
Details
cross_bc2win_2010_and_2016.pdf.zip: pdfs of before/after patch (574.99 KB, application/zip)
2020-03-17 06:37 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2020-03-04 12:39:40 UTC
Created attachment 158383 [details]
Bugdoc

1. Load Bugdoc in Writer
2. Save as docx
3. Open docx in Word

The chart on the second page is misplaced (on the first page).

Then go to Word "File" menu, click the "Convert" button in the "Compatibility mode" section.
After that, the document is displayed correctly (chart is on second page where it should be).
Comment 1 Samuel Mehrbrodt (CIB) 2020-03-04 12:40:32 UTC
Created attachment 158384 [details]
Word PDF export (before Convert)
Comment 2 Samuel Mehrbrodt (CIB) 2020-03-04 12:40:48 UTC
Created attachment 158385 [details]
Word PDF export (after Convert)
Comment 3 Xisco Faulí 2020-03-04 13:08:15 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ece4a0f78bb60ef079722e8fa029f0ec253d0452

author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2019-05-14 17:00:59 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2019-06-26 11:41:03 +0200
commit	ece4a0f78bb60ef079722e8fa029f0ec253d0452 (patch)
tree	ac56f8e9cad61bf99779b87a63f334f8e2f60173
parent	8fb35f06ddec551a6de887ce269d9196d9fe2337 (diff)
tdf#125518: docx export: save anchors for diagrams

Bisected with: bibisect-linux64-6.4

Adding Cc: to Vasily Melenchuk
Comment 4 Justin L 2020-03-16 18:28:17 UTC
The earlier identified 6.4 commit probably isn't very helpful - it was non-anchored placement to anchored placement fixes.

positioning was very poor earlier in 7.0 master, but mostly good as of
commit d9c535ead688e9f156dbcf43948df08a69e218be
Author: Bakos Attila  Date:   Fri Jan 10 10:49:14 2020 +0100
    tdf#128207: DOCX import: fix chart positioning

    Embedded graphic objects had got 0 values for vertical and horizontal
    positioning before, resulting overlapping, hidden charts,
    but now they are positioned according to the values in the document.
Comment 5 Justin L 2020-03-17 06:37:47 UTC
Created attachment 158733 [details]
cross_bc2win_2010_and_2016.pdf.zip: pdfs of before/after patch

The document never looks good in Word 2010. So that means that we have an import bug - because it looks fine in LO now, even though LO imports in 2010 mode. Likely no one cares too much about a 2010 import bug though...

It does seem to be JUST related to the compatibilityMode=15. I changed all of the other compatSettings, and that didn't affect the layout. compatibilityMode=14 is not enough to fix it either.
Comment 6 Samuel Mehrbrodt (CIB) 2020-03-20 06:08:17 UTC
This works now correctly after setting the docx compatiblityMode to 15 (bug 131304).