Bug 131136 - Remove option "Use printer metrics for document formatting"
Summary: Remove option "Use printer metrics for document formatting"
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.5.0, inReleaseNotes:7.5
Keywords:
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2020-03-04 23:06 UTC by Regina Henschel
Modified: 2023-11-20 12:55 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2020-03-04 23:06:40 UTC
Go to Tools > Options > Draw > General. It has a section 'Compatibility' with the option "Use printer metrics for document formatting".

The purpose of that option is not clear. Does it work at all? I see no difference whether it is on or off.

Option is obsolete => remove it
Option is broken => fix it
Option works as intended => Improve its description in the help
Comment 1 Xisco Faulí 2020-03-19 12:12:45 UTC
@Olivier, any idea about this option ?
Comment 2 G.Ostner (LOBugs) 2020-04-12 14:09:42 UTC
AFAIK, this is a compatibility option with Word where parts of the layout (like word wrap) are always dependent on the currently active printer driver, whereas LO always tried to be independent of the printer specs.

I often get slightly different layout when this is checked, and the document usually gets a bit longer. If space is tight, I usually see that it is unchecked, before I export to PDF.

What I find baffling is that it's difficult to make it stick: if I uncheck "Use printer metrics" and then click on the "use as standard" button on that dialog, it does not stick - the next document still has the option checked.

IIRC, there were versions of LO where the setting "stuck", was also applied to subsequent documents, but I haven't had any luck for a while, although I prefer the printer-independent layout, since it usually saves a little space.
Comment 3 Buovjaga 2020-06-19 15:05:44 UTC
I did some grepping and could not find anything under sd, but the thing leads to the property SC_UNONAME_PRMETRICS and the setting/getting of TextWysiwyg input option.

so we have this in sc/source/core/data/documen8.cxx:

OutputDevice* ScDocument::GetRefDevice()
{
    // Create printer like ref device, see Writer...
    OutputDevice* pRefDevice = nullptr;
    if ( SC_MOD()->GetInputOptions().GetTextWysiwyg() )
        pRefDevice = GetPrinter();
    else
        pRefDevice = GetVirtualDevice_100th_mm();
    return pRefDevice;
}
Comment 4 Heiko Tietze 2020-06-25 14:24:31 UTC
Miklos: "Let's just remove this option from the UI and have it at the advanced settings." Sounds like a good plan.

sw/uiconfig/swriter/ui/optcompatpage.ui
m_xFormattingLB in sw/source/ui/config/optcomp.cxx and related
Comment 5 Michael Stahl (allotropia) 2020-06-29 13:00:26 UTC
In ODF this is stored in settings.xml as "PrinterIndependentLayout".

The main reason why this option exists in the UI is so that users can turn it off when they load an ancient document / template that has it enabled... but this of course assumes that users a) know that this setting exists b) know that a printer dependent text layout is dumb.
Comment 6 Heiko Tietze 2022-09-07 11:37:10 UTC
In Calc we have the (same?) option under General > Input settings: "[ ] Use printer metrics for text formatting" (and a tip of the day advertising the option [1]), Writer has it under Compatibility for the current document "[ ] Use printer metrics for document formatting", and now I wonder if we really want to remove it from Draw/Impress (Impress has one more compatibility option [2]). 

Help [3] tells me: 
Use printer metrics for text formatting
Specifies that printer metrics are applied for printing and also for formatting the display on the screen. If this box is not checked, a printer independent layout will be used for screen display and printing.

Adding this to Michael's explanation in comment 5, I think we better keep the option. Forwarding the question whether the help needs improvement to the documentation team.

[1] "Want the same layout for the screen display and printing? Check Tools ▸ Options ▸ %PRODUCTNAME Calc ▸ General ▸ Use printer metrics for text formatting."
[2] sd/uiconfig/simpress/ui/optimpressgeneralpage.ui
[3] https://help.libreoffice.org/7.4/en-US/text/shared/optionen/01070500.html
Comment 7 Michael Stahl (allotropia) 2022-09-12 15:05:08 UTC
(In reply to Heiko Tietze from comment #6)
> In Calc we have the (same?) option under General > Input settings: "[ ] Use
> printer metrics for text formatting" (and a tip of the day advertising the
> option [1]),

> [1] "Want the same layout for the screen display and printing? Check Tools ▸
> Options ▸ %PRODUCTNAME Calc ▸ General ▸ Use printer metrics for text
> formatting."

what the seriously? no user should ever set this option, please remove this nonsense "tip".

i have a vague memory it was for ancient printers that had built-in fonts or something like that, in the late 1900s (as i've been told kids call it now).

might be best to remove the checkbox in the UI too.
Comment 8 Heiko Tietze 2022-09-13 06:32:54 UTC
(In reply to Michael Stahl (allotropia) from comment #7)
> what the seriously? no user should ever set this option, please remove this
> nonsense "tip".
> 
> i have a vague memory it was for ancient printers that had built-in fonts or
> something like that, in the late 1900s (as i've been told kids call it now).
> 
> might be best to remove the checkbox in the UI too.

Mind to file a new ticket? Tips were taken from https://pad.documentfoundation.org/p/marketing, AFAIK being the source for tips on Twitter
Comment 9 Heiko Tietze 2022-09-13 06:34:31 UTC
(In reply to Heiko Tietze from comment #8)
> Mind to file a new ticket?

Wait a second, thought this was resolved WF. But since it's still open we could remove the option from all modules.
Comment 10 Commit Notification 2022-09-14 18:29:59 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/130638cf417ad37c42c7da8c47f552ba791fe3a7

Related: tdf#131136 Don’t mention obsolescent “Use printer metrics” option in Help
Comment 11 Commit Notification 2022-10-06 16:56:09 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/27f98935f9207465186da96c85467f3c005662a6

[API CHANGE] Resolves tdf#131136 - Remove option "Use printer metrics"

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Stéphane Guillou (stragu) 2023-11-20 12:55:56 UTC
For the record, one example of it being useful, but that was quite a few years ago: https://ask.libreoffice.org/t/calc-text-does-not-fit-in-cell-when-printing-exporting-to-pdf/21494

Added this to release notes: https://wiki.documentfoundation.org/index.php?title=ReleaseNotes%2F7.5&type=revision&diff=707866&oldid=706180

Heiko, can you please check that it doesn't need more details?

Also, I noticed the Compatibility heading in "Tools > Options > Draw > General" is now useless. Do you want me to open a new report?

Version: 7.6.3.1 (X86_64) / LibreOffice Community
Build ID: c4af5b1259bceea6e979e6fe2435dbee7a5a87c2
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded