Download it now!
Bug 131160 - Writer Bullets and Numbering should include empty box and circle
Summary: Writer Bullets and Numbering should include empty box and circle
Status: RESOLVED DUPLICATE of bug 108697
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: All Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-05 15:33 UTC by Susan Cragin
Modified: 2020-03-05 20:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Susan Cragin 2020-03-05 15:33:40 UTC
Description:
In the latest OpenOffice, the selections under Format / Bullets and Numbering are all solid options. 
But what if you want to print out a to-do list and then give it to an employee to check off? 
There used to be a box outline to do this, but it has been replaced by a solid box. That is not a good idea. 
Bring back the empty box!

Steps to Reproduce:
1. open a document
2. select format / bullets
3. look in vain for an empty box

Actual Results:
As stated above

Expected Results:
The empty box you used to have. 


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
This is a regression.
Comment 1 Dieter 2020-03-05 17:56:00 UTC
(In reply to Susan Cragin from comment #0)
> There used to be a box outline to do this, but it has been replaced by a
> solid box. That is not a good idea. 

Do you remember the version of LO. I've checked back to LO 5.4.7, but couldn't find it. So perhaps indeed an enhancement request and not a regression. I support the idea, although an empty box for a checklist is something different than a bullet.

cc: Desing-Team for further input
Comment 2 Susan Cragin 2020-03-05 18:08:05 UTC
I can't honestly say when I last used the check box, or where, so enhancement it is. 

You are right, checkbox and bullet list are different. Presumably one could type in something into a real checkbox, but I never used mine for anything other than checking off on a paper copy. 

I'd be happy with just an empty square.
Comment 3 V Stuart Foote 2020-03-05 20:01:47 UTC
See no need for this.

Default bullets for the GUI are drawn from OpenSymbol font.  

Though we do need a little tweak there to move some PUA glyphs onto their correct Unicode point:

E00C -> U+25C6 BLACK DIAMOND
E00A -> U+25A0 BLACK SQUARE

And helpful would be the addition of a OpenSymbol appropriate glyph for U+2610 BALLOT BOX

Otherwise, U+25CB WHITE CIRCLE is available to assign as a bullet via the customize.  While any of:

U+25A1 WHITE SQUARE - □
U+274F LOWER RIGHT DROP-SHADOWED WHITE SQUARE - ❏
U+2750 UPPER RIGHT DROP-SHADOWED WHITE SQUARE - ❐
U+2751 LOWER RIGHT SHADOWED WHITE SQUARE - ❑
U+2752 UPPER RIGHT SHADOWED WHITE SQUARE - ❒

Are available from the OpenSymbol font to assign to a bullet listing--though the customization allows a selection from any font to be used as a bullet.

*** This bug has been marked as a duplicate of bug 108697 ***