Bug 131185 - LO Writer "hangs" on scrolling/saving of a document where embedded image doesn't exist
Summary: LO Writer "hangs" on scrolling/saving of a document where embedded image does...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1 all versions
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.0.0 target:6.4.3 target:6.3.6
Keywords: bibisected, bisected, perf, regression
: 130633 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-03-06 13:11 UTC by Gülşah Köse
Modified: 2020-08-03 16:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (10.10 KB, application/vnd.oasis.opendocument.text)
2020-03-06 13:12 UTC, Gülşah Köse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gülşah Köse 2020-03-06 13:11:41 UTC
Description:
LibreOffice hangs when we open the document at the attachment. Cursor slowdowns, can't update the cursor shape and some freezings happen.

Steps to Reproduce:
1.Open sample.odt
2.Try to add some paragraphs, move cursor, save the document.


Actual Results:
No matter how long we wait, some freezing occurs.

Expected Results:
Should be fluent.


Reproducible: Always


User Profile Reset: No



Additional Info:
There is an embedded image in the document it tries to download the image but the image doesn't exist. (404 not found can be seen in output logs)
Comment 1 Gülşah Köse 2020-03-06 13:12:25 UTC
Created attachment 158450 [details]
Sample file
Comment 2 Commit Notification 2020-03-10 10:16:52 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/30b23d77c894bdf6f7ae0d18d594ea267a80f662

tdf#131185 Prevent unnecessary SwapIn calls.

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Xisco Faulí 2020-03-10 11:04:13 UTC
it seems to be a regression from https://cgit.freedesktop.org/libreoffice/core/commit/?id=9fb7aaf570c03c8a26d763f1205fb8c890e8211a. Tagging it as so
Comment 4 Xisco Faulí 2020-03-10 11:20:50 UTC
*** Bug 130633 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2020-03-12 07:52:04 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c5ecde36b8e980cc4a0ca88ccebd95ac3155bdd9

tdf#131185 Prevent unnecessary SwapIn calls.

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-03-12 07:52:15 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/ddd7277b218204dca539b3f93d36098df0349b38

tdf#131185 Prevent unnecessary SwapIn calls.

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Timur 2020-03-31 09:13:47 UTC
(In reply to Xisco Faulí from comment #3)
> it seems to be a regression from
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=9fb7aaf570c03c8a26d763f1205fb8c890e8211a. Tagging it as so

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-04-13 16:58:49 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-04-16 02:52:02 +0200
commit	9fb7aaf570c03c8a26d763f1205fb8c890e8211a (patch)
tree	8f4466b24d9fcae2da5043479a57fabc662a2c43
parent	ba69036c8e889237da4bb312d7c5c94066abbfd3 (diff)
Make linked graphic register into LinkedManager again
Change-Id: I16b162f86d6221d120f6355f9a52c1abfcd0ac73
Reviewed-on: https://gerrit.libreoffice.org/52911
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Tomaž Vajngerl <quikee@gmail.com>


Looks OK, I set Verified.