Download it now!
Bug 131254 - Advance Timing Setting doesn't work correctly
Summary: Advance Timing Setting doesn't work correctly
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.0.0 target:6.3.6 target:6.4.4
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-10 13:28 UTC by Gülşah Köse
Modified: 2020-03-30 19:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (21.57 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-03-10 13:29 UTC, Gülşah Köse
Details
sample2.pptx (21.57 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-03-11 12:25 UTC, Gülşah Köse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gülşah Köse 2020-03-10 13:28:58 UTC
Description:
I've created a presentation consist of two slides (sample.pptx). First slide has 12 second Advance Timing setting to change next slide.

Steps to Reproduce:
1. Open sample file
2. Start presentation with F5
3. Change the last slide with the right arrow
4. Change the first slide with the left arrow


Actual Results:
It changes slide automatically the last slide

Expected Results:
It should wait 12 seconds to change the last slide


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Gülşah Köse 2020-03-10 13:29:25 UTC Comment hidden (obsolete)
Comment 2 Gülşah Köse 2020-03-10 14:01:58 UTC Comment hidden (obsolete)
Comment 3 Timur 2020-03-11 10:37:46 UTC Comment hidden (obsolete)
Comment 4 Gülşah Köse 2020-03-11 12:25:41 UTC
Created attachment 158606 [details]
sample2.pptx
Comment 5 Gülşah Köse 2020-03-11 12:28:07 UTC
Sorry, I've uploaded wrong sample file. Please ignore comment 2 and sample.pptx. Bug description with sample2.pptx still valid. Thanks for checking.
Comment 6 Timur 2020-03-11 13:03:33 UTC
OK, that's it. 
Looks like never was correct. 
OO didn't proceed after 12 secs and LO 4.0 didn't wait 12 secs.
Comment 7 Commit Notification 2020-03-26 18:37:21 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/80f386f787ad59936ead2022e6d932a6d441c6e9

tdf#131254 Prevent extra eventqueue empty call.

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-03-29 16:07:13 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/9861bb24b33346a73401bd5df1c5f243b245f427

tdf#131254 Prevent extra eventqueue empty call.

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-03-29 16:07:21 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/49e114d3803178f8720620834f97e2ab0962e826

tdf#131254 Prevent extra eventqueue empty call.

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-03-30 16:13:16 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/14a0727889699128f02ac0a79bdce0103c89bc01

tdf#131254 Follow-up Prevent extra eventqueue empty call.

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-03-30 18:47:07 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/30b6e95acde4072fb2978f73127bad002214a3d4

tdf#131254 Follow-up Prevent extra eventqueue empty call.

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-03-30 18:47:17 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/0f792853b550994cd14e30b78043586fba1995eb

tdf#131254 Follow-up Prevent extra eventqueue empty call.

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.