Bug 134133 - Go back in presenting mode leads to dropped animation steps
Summary: Go back in presenting mode leads to dropped animation steps
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.6.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.2.0 target:7.1.0.2 target:7.0.5
Keywords: bibisected, bisected, regression
: 136296 137212 138177 139597 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-18 19:53 UTC by Daniel Thomae
Modified: 2021-11-05 14:43 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
A sample file from impress to verify the bug. (12.41 KB, application/vnd.oasis.opendocument.presentation)
2020-06-18 19:55 UTC, Daniel Thomae
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Thomae 2020-06-18 19:53:48 UTC
Description:
Playing an animation backwards leads to dropped animation steps. It's like LO is miscounting on the next animation step while pressing the left-key on keyboard.

Steps to Reproduce:
1. Go to presenting mode (F5-button)
2. Press right-button on keybord (forth) two times
3. Press left-button one times
4. Press right-button 

Actual Results:
After 3.: The Animation steps back two steps
After 4.: Goes two the next slide. Misses one animation step and goes to next slide before all animation steps on the current foil are finished.

Expected Results:
After 3.: Go back one animation step.
After 4.: Go forth one animation step.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
The bug is severe and makes using Impress for presentations not possible.
OpenGL ist disable.
Operating System is Windows 7 X86 Professional
Comment 1 Daniel Thomae 2020-06-18 19:55:48 UTC
Created attachment 162188 [details]
A sample file from impress to verify the bug.
Comment 2 raal 2020-06-21 09:57:45 UTC
I can confirm with Version: 7.1.0.0.alpha0+
Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3

works in Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 3 raal 2020-06-21 10:06:49 UTC
This seems to have begun at the below commit.
Adding Cc: to Gülşah Köse; Could you possibly take a look at this one?
Thanks

ac2506f992af14b6172626a741ade87e14bca943 is the first bad commit
commit ac2506f992af14b6172626a741ade87e14bca943
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Mar 26 19:37:42 2020 +0100

    source sha:80f386f787ad59936ead2022e6d932a6d441c6e9

author	Gülşah Köse <gulsah.kose@collabora.com>	2020-03-23 15:33:40 +0300
committer	Gülşah Köse <gulsah.kose@collabora.com>	2020-03-26 19:36:07 +0100
commit	80f386f787ad59936ead2022e6d932a6d441c6e9 (patch)
tree	4b9d72b6c7d4988cf7fc0f010741e6a594ad117f
parent	c76fdcf1cfa1242e66b50ebe80d6eac1baae37a9 (diff)
tdf#131254 Prevent extra eventqueue empty call.
Comment 4 Kai 2020-07-01 05:06:15 UTC
Can confirm this for 7.0 beta2.
Comment 5 Timur 2020-11-14 10:34:22 UTC
*** Bug 138177 has been marked as a duplicate of this bug. ***
Comment 6 Telesto 2020-11-15 18:48:50 UTC
*** Bug 136278 has been marked as a duplicate of this bug. ***
Comment 7 Timur 2020-11-15 19:13:43 UTC
*** Bug 137212 has been marked as a duplicate of this bug. ***
Comment 8 Pierre C 2020-11-18 16:35:19 UTC Comment hidden (no-value)
Comment 9 Pierre C 2020-11-26 07:29:19 UTC Comment hidden (no-value)
Comment 10 Pierre C 2020-11-30 06:30:11 UTC Comment hidden (no-value)
Comment 11 Commit Notification 2020-12-26 22:12:15 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a63caf49958b40e33e0d7aaedbe6424f78ecdc46

tdf#134133 Check when the eventqueue needs to be emptied.

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Pierre C 2020-12-29 14:11:38 UTC
*** Bug 135787 has been marked as a duplicate of this bug. ***
Comment 13 Pierre C 2020-12-29 16:54:45 UTC
tested in 7.2 dev 29/12/2020
It works fine.
I hope the patch will be pushed to 7.0 and 7.1 branch soon

thanks for the work
Comment 14 Horst Schirmeier 2020-12-29 18:22:21 UTC
Tested with master~2020-12-28_21.50.05_LibreOfficeDev_7.2.0.0.alpha0_Linux_x86-64_deb.tar.gz: The issue seems somewhat changed but *not* fixed.

Reproducible with my attachment "simpler repro file" to bug #136278 (https://bugs.documentfoundation.org/attachment.cgi?id=165896):
- Start presentation with F5, 5x right arrow, 5x left arrow, 5x right arrow.
- Expected: Presentation should be in final state (five visible blue boxes).
- Instead: After 4x right arrow I see 3(!) blue boxes (#1, #2, and #4; #3 is missing), and after one additional right-arrow keypress (5 in total) the presentation surprisingly is in the white-on-black "Click to exit presentation..." end state.

Please reopen.
Comment 15 Gülşah Köse 2020-12-30 10:36:21 UTC
Hi Horst

I had sent https://gerrit.libreoffice.org/c/core/+/90913 to fix Advance Time setting problem. And it caused a regression as the content of tdf#134133 then I sent https://gerrit.libreoffice.org/c/core/+/108282 to fix this regression. And it works.

When I checked your bug report I can see the bug. To understand if this bug caused by me. I reverted that two patches but bug still there. You are right about first patch changed the behaviour of your sample file. But it changed again its first state with my second patch. It was already buggy and it is not related with me.

I'm changing the status as fixed again. tdf#136278 is not a duplication it is a separate bug and need bisect.
Comment 16 Xisco Faulí 2021-01-04 14:44:46 UTC
Verified in

Version: 7.2.0.0.alpha0+
Build ID: 2c9708cbb870483a8a1c93d722085be5f789d234
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Gülşah Köse, thanks for fixing this issue!!
Comment 17 Commit Notification 2021-01-04 14:45:53 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/8414b6167fb06bff660b9d7eca3939f439e96a3b

tdf#134133 Check when the eventqueue needs to be emptied.

It will be available in 7.1.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Xisco Faulí 2021-01-04 14:58:51 UTC
(In reply to Horst Schirmeier from comment #14)
> Tested with
> master~2020-12-28_21.50.05_LibreOfficeDev_7.2.0.0.alpha0_Linux_x86-64_deb.
> tar.gz: The issue seems somewhat changed but *not* fixed.
> 
> Reproducible with my attachment "simpler repro file" to bug #136278
> (https://bugs.documentfoundation.org/attachment.cgi?id=165896):
> - Start presentation with F5, 5x right arrow, 5x left arrow, 5x right arrow.
> - Expected: Presentation should be in final state (five visible blue boxes).
> - Instead: After 4x right arrow I see 3(!) blue boxes (#1, #2, and #4; #3 is
> missing), and after one additional right-arrow keypress (5 in total) the
> presentation surprisingly is in the white-on-black "Click to exit
> presentation..." end state.
> 
> Please reopen.

This issue has been fixed in https://cgit.freedesktop.org/libreoffice/core/commit/?id=b83c16834792874524019495662b2f23a066611c
Comment 19 Commit Notification 2021-01-04 20:56:36 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/aa87d3f825fcbe1641d9dbeac8293bf55d2f4273

tdf#134133 Check when the eventqueue needs to be emptied.

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Giuseppe Allodi 2021-01-17 21:05:10 UTC
*** Bug 139597 has been marked as a duplicate of this bug. ***
Comment 21 Buovjaga 2021-11-05 14:43:19 UTC
*** Bug 136296 has been marked as a duplicate of this bug. ***