Download it now!
Bug 131288 - FILESAVE DOCX Saving chart document twice results in broken DOCX file in Word16
Summary: FILESAVE DOCX Saving chart document twice results in broken DOCX file in Word16
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:7.1.0 target:7.0.1
Keywords: filter:docx, implementationError
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2020-03-11 15:26 UTC by NISZ LibreOffice Team
Modified: 2020-10-14 11:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Word (23.92 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-03-11 15:29 UTC, NISZ LibreOffice Team
Details
The example file after saving twice in Writer (11.10 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-03-11 15:30 UTC, NISZ LibreOffice Team
Details
Opening the file in Word 2013 works (73.71 KB, image/png)
2020-03-11 15:30 UTC, NISZ LibreOffice Team
Details
Opening the file in Word 2016 does not work (33.31 KB, image/png)
2020-03-11 15:30 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-03-11 15:26:39 UTC
Description:
When a Word-made DOCX file containing a simple chart is saved in Writer twice without reloading the resulting file is reported unreadable by Word 2016, but not by Word 2010.


Steps to Reproduce:
    1. Open attached document in Writer
    2. Modify it by adding a paragraph, save it.
    3. Continue editing without reloading – this is the important part.
    4. Add one more paragraph, save the file.
    5. Close the file and open it in Word 2016

Actual Results:
Word 2016 reports unreadable contents. This is because Writer created a 0 length xlsx file in word/embeddings.
Word 2013 does not complain, and Writer can reopen the file fine too.

Expected Results:
Word 2016 opens the file fine.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: cf96cb11e2a46c452a273ded1c66c556118983cf
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

Also happens in:
Version: 4.3.0.4
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0

But there was no word/embeddings folder exported in:
Verzió: 4.2.0.4
Build az.: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 1 NISZ LibreOffice Team 2020-03-11 15:29:39 UTC
Created attachment 158616 [details]
Example file from Word
Comment 2 NISZ LibreOffice Team 2020-03-11 15:30:05 UTC
Created attachment 158617 [details]
The example file after saving twice in Writer
Comment 3 NISZ LibreOffice Team 2020-03-11 15:30:32 UTC
Created attachment 158618 [details]
Opening the file in Word 2013 works
Comment 4 NISZ LibreOffice Team 2020-03-11 15:30:54 UTC
Created attachment 158619 [details]
Opening the file in Word 2016 does not work
Comment 5 Dieter 2020-03-17 15:46:36 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 5dcbd1bb557450a2d658a710c163b310c0cee157
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: CL
Comment 6 Commit Notification 2020-07-22 15:46:06 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b115d4899d827f885f7d35ced4cb64d2385e3422

tdf#131288 Chart: fix export of embedded xlsx

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-08-04 07:26:07 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/2a755d748aecd65d1a3d0c2685678a85472481cd

tdf#131288 Chart: fix export of embedded xlsx

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.