Bug 131436 - Improve support for Zotero's ReferenceMarks and Bookmarks
Summary: Improve support for Zotero's ReferenceMarks and Bookmarks
Status: RESOLVED DUPLICATE of bug 121945
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-20 10:08 UTC by Georgios
Modified: 2022-07-20 09:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Georgios 2020-03-20 10:08:39 UTC
Description:
At this moment, the functionality of Zotero in LibreOffice Writer is much worse than MS Word due to limitations in LO Writer.

Even though LibreOffice Writer has the option to apply field shadings, it does not do the same for bookmarks, so it is difficult to distinguish citations in text. This is because there's no shading for Bookmarks in LibreOffice, which also, unfortunately, makes it much easier to accidentally corrupt/edit citations in-text. 

Moreover, I used to be able to simply copy and paste Zotero citations in MS Word to other parts of the text. However, I noticed that in Linux with LO Writer saving in docx and storing references either as bookmarks or ReferenceMarks I cant. This is due to another limitation in LO Writer being able to cut and paste citations, but not make duplicates (copy-paste).

Zotero is the leading reference management software and it's really disappointing the due to LO Writer limitations many people heavily using reference manager software (e.g. academics) are forced to stick to MS Word just for that, when LO Writer is such a rich and mature software on par or many times better than MS Word. 

Please consider improving support for Zotero. 

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 V Stuart Foote 2020-03-20 13:05:32 UTC
see work on bug 121945 and bug 121958

*** This bug has been marked as a duplicate of bug 121945 ***
Comment 2 Georgios 2022-07-20 03:33:14 UTC
I'm reopening this as this is not duplucicate of bug 121945. I'm not asking for better in-built references, I'm pointing out about the field handling
Comment 3 Georgios 2022-07-20 03:34:34 UTC
LibreOffice Fields are not editable in-text which is a requirement for Zotero citations, so Zotero cannot use them. There is partial support for Word fields in LibreOffice, but there has not been any updates on that front in a while and the support isn't good enough for Zotero to be able to use it.
Comment 4 V Stuart Foote 2022-07-20 09:03:57 UTC
It is a straight up duplicate, do not reopen without understanding our BZ workflow for enhancement. Scope of work needed for bug 121945 fully encompasses the issue in OP here.

*** This bug has been marked as a duplicate of bug 121945 ***