Bug 131539 - FILESAVE DOCX OLE object anchored to character moves on saving
Summary: FILESAVE DOCX OLE object anchored to character moves on saving
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.0.0
Keywords: filter:docx
Depends on:
Blocks: DOCX-OLE-Objects
  Show dependency treegraph
 
Reported: 2020-03-24 15:02 UTC by NISZ LibreOffice Team
Modified: 2020-06-02 14:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Writer (35.07 KB, application/vnd.oasis.opendocument.text)
2020-03-24 15:02 UTC, NISZ LibreOffice Team
Details
The original file saved by Writer (19.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-03-24 15:08 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Writer (107.32 KB, image/png)
2020-03-24 15:08 UTC, NISZ LibreOffice Team
Details
Screenshot of the sample file in the Master (242.47 KB, image/png)
2020-05-14 06:30 UTC, Attila Bakos (NISZ)
Details
Sample file exported by Writer (current Master) (19.46 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-05-14 06:35 UTC, Attila Bakos (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-03-24 15:02:50 UTC
Created attachment 158945 [details]
Example file from Writer

Attached odt file contains two simple embedded OLE objects anchored to character.
When saving to DOCX the positioning and wrap settings of these objects change.

Steps to reproduce:
1.	Open attached odt file
2.	Save as docx and reopen in Writer or Word

Actual results:
Objects change position: first one jumps to the left margin, the second in the middle of the second example sentence.

Expected results:
Position unchanged.

LibreOffice details:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: bc898e2c2784e36ad4d4cdf6d962e39069d2c82d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

In 5.1 we started to be able to properly export such OLE objects, it looks the same back until then.
Comment 1 NISZ LibreOffice Team 2020-03-24 15:08:39 UTC
Created attachment 158946 [details]
The original file saved by Writer
Comment 2 NISZ LibreOffice Team 2020-03-24 15:08:58 UTC
Created attachment 158947 [details]
Screenshot of the original and exported document side by side in Writer
Comment 3 Durgapriyanka 2020-03-25 20:53:10 UTC
Thank you for reporting the bug. I cannot reproduce this in

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
	

and in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Commit Notification 2020-04-28 08:19:09 UTC
Attila Bakos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2150fdc7d0f63288ac56c33cb898589512057642

tdf#131539 DOCX export: fix position of OLE objects

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Attila Bakos (NISZ) 2020-05-14 06:30:52 UTC
Created attachment 160802 [details]
Screenshot of the sample file in the Master
Comment 6 Attila Bakos (NISZ) 2020-05-14 06:35:02 UTC
Created attachment 160803 [details]
Sample file exported by Writer (current Master)