Download it now!
Bug 131576 - Fields not displayed as expected on Page 2 of Base's Table Wizard
Summary: Fields not displayed as expected on Page 2 of Base's Table Wizard
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.3
Keywords: bibisected, bisected, regression
: 131727 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-03-25 15:33 UTC by Steve Fanning
Modified: 2020-04-03 16:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Table Wizard missing data on right hand side (8.18 KB, image/png)
2020-03-25 15:33 UTC, Steve Fanning
Details
Comparison before and after (46.03 KB, image/png)
2020-03-30 10:45 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Fanning 2020-03-25 15:33:43 UTC
Created attachment 158996 [details]
Table Wizard missing data on right hand side

Creating a table using the Table Wizard, when I press Next to go to page 2 of the wizard ("Set field types and formats"), things go awry. I can only see the Field Name on the right hand side of this area – no sign of Field type, AutoValue, Auto-increment state, and Length.

Also the title at the top of the right-hand side (Field information) is corrupted.

I've attached a screenshot.
Comment 1 Xisco Faulí 2020-03-25 15:59:38 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Steve Fanning 2020-03-25 16:05:31 UTC
I'm deliberately using an older version - I'm working in the Documetation Team checking the accuracy of a draft 6.4 Guide. However I have been assured by Drew Jensen (via the Documentation Team's mailing list) that the problem is still present in Builde 7.0.
Comment 3 Julien Nabet 2020-03-25 23:01:27 UTC
What about writing doc about 6.4 with last 6.4.2?
Comment 4 Steve Fanning 2020-03-25 23:38:03 UTC
I'm a bit confused - as far as this apparent software problem is concerned, does it matter which version of 6.4 I'm using for documentation activities? (For information I'm not writing anything, I was doing the final review of a chapter of a document that was written some weeks ago. Since I've already checked many of the chapters in this particular guide against a reference 6.4.0.3 build, it makes no sense to switch to a newer build for this activity).

The key point seems to be that I'm advised that the bug still exists in the latest build of software (via the Doc Team mailing list) and I was asked to raise this bug to address it.
Comment 5 Julien Nabet 2020-03-26 19:39:37 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this with gen rendering.
I don't reproduce this with gtk3 rendering.
Comment 6 Julien Nabet 2020-03-27 21:29:11 UTC
https://gerrit.libreoffice.org/c/core/+/91236
Comment 7 Commit Notification 2020-03-28 07:26:21 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/70adbc53e88e5b99032d63065410716c54b4f96f

tdf#131576: fix "Field information" in table wizard, step 2

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Julien Nabet 2020-03-28 07:26:44 UTC
Backport for 6.4 waiting for review:
https://gerrit.libreoffice.org/c/core/+/91286
Comment 9 Julien Nabet 2020-03-28 10:49:40 UTC
Xisco: I noticed you added "regression", on which version did it work?
Comment 10 Commit Notification 2020-03-30 09:13:55 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/15275106fec243bbe68ab8c124f1b5e8bcbcc2aa

tdf#131576: fix "Field information" in table wizard, step 2

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2020-03-30 10:04:27 UTC
(In reply to Julien Nabet from comment #9)
> Xisco: I noticed you added "regression", on which version did it work?

Yes, because Steve mentioned it...
I've bisected it and the problem started to happen after https://cgit.freedesktop.org/libreoffice/core/commit/?id=8c66efa030e98cfdf5da20be368566d64e43c5d1
Comment 12 Julien Nabet 2020-03-30 10:09:06 UTC
Thank you Xisco for having bibisected it.

Caolán: put you in cc. I must recognize I don't know how it's related with a Java part.
Comment 13 Xisco Faulí 2020-03-30 10:43:13 UTC
The issue is still no fixed in

Version: 7.0.0.0.alpha0+
Build ID: 11e6582b23b983fde4b04ece5b37c546bcd98a43
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

I'll attach a screenshot
Comment 14 Xisco Faulí 2020-03-30 10:45:54 UTC
Created attachment 159143 [details]
Comparison before and after
Comment 15 Xisco Faulí 2020-03-30 10:47:22 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2019-09-05 12:22:38 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2019-09-12 20:28:14 +0200
commit	8c66efa030e98cfdf5da20be368566d64e43c5d1 (patch)
tree	88c9fb335349fd1b7b285d46108e5d41a3c9aac4
parent	8150219824a1d08c4a22fd8bb7cc63fe2aa88074 (diff)
weld OCopyTableWizard cluster

Bisected with: bibisect-linux64-6.4

Adding Cc: to Caolán McNamara
Comment 16 Julien Nabet 2020-03-30 10:52:10 UTC
I was focused on the shift, it seems more serious than this now.
I must recognize I can't help here.
(Perhaps we should also revert my patch on master)
Comment 17 Commit Notification 2020-03-30 13:04:42 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9383980a9f07a352c62fc09b7bea3a24e2e46b48

Related: tdf#131576 overlapping windows, move bottom one down a little

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2020-03-30 14:32:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e6573fa894a7ef1e83f9d7785a61fdcabfe24939

tdf#131576 Fields not displayed as expected in Base's Table Wizard

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Caolán McNamara 2020-03-30 14:33:14 UTC
fixed in master and backport for 6-4 in gerrit
Comment 20 Julien Nabet 2020-03-31 13:16:58 UTC
*** Bug 131727 has been marked as a duplicate of this bug. ***
Comment 21 Xisco Faulí 2020-03-31 16:01:12 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 169a10f0e4680814145b668c6320be04038d7a89
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 22 Commit Notification 2020-03-31 16:04:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/8de35cf85a0d595c3b0a0ee71325366084940948

tdf#131576 Fields not displayed as expected in Base's Table Wizard

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2020-04-03 15:52:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-3":

https://git.libreoffice.org/core/commit/9e00a9c487b622f35d6b274cee605798f0d24e6e

tdf#131576 Fields not displayed as expected in Base's Table Wizard

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.