Download it now!
Bug 131709 - Copying a large sheet is very slow - II
Summary: Copying a large sheet is very slow - II
Status: RESOLVED DUPLICATE of bug 133267
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks:
 
Reported: 2020-03-30 13:16 UTC by b.
Modified: 2020-06-05 13:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Reduced Example file (1.24 MB, application/vnd.oasis.opendocument.spreadsheet)
2020-05-22 08:46 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description b. 2020-03-30 13:16:35 UTC
Description:
i 'm in doubt if i'll ever understand @xisco, whenever i add to an old bug he want's a new one, if i open a new one he say's 'duplicate' ... 

i wanted to reactivate #125661, the patch left a performance issue: 

0.) still performance issue in special situation, see point F.) below

00.) file referenced is http://bugs.documentfoundation.org/attachment.cgi?id=150858, mentioned in https://bugs.documentfoundation.org/show_bug.cgi?id=125661#c0, 

A.) with ver 6.2.8.2 it took more than 4:30 - hours! - to do 'sheet - move or copy sheet', not finished after that time, killed the task, 

with ver. below (7.0 about 1 week old) it takes: 

B.) 11,5 seconds to open the file provided by the OP, acceptable, 

C.) +/- 2,83 sec. to copy the existing sheet to another by '+' to add sheet and then ctrl-a - ctrl-c on the old, ctrl-v on the new sheet, good, 

D.) +/- 2,05 sec. for undo after that with ctrl-z, good, 

E.) similar times for copy and undo with 'move or copy sheet' done after! C.) and D.), 

but! 

F.) more than 4:25 minutes (265 seconds!) to finish if you execute 'sheet - move or copy sheet' as the first action after loading the file (and starting the program?), 

thus there is still an unneccessary performance issue, unneccessary as F.) isn't 'more work' than C.) 

ver. tested: 

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 61d8d991a27c3bfe70e3b8d3b4ce4d8a41d18d2d
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc:

Steps to Reproduce:
see above description

Actual Results:
100 times longer for 'sheet - copy or move sheet' than for ctrl-a - ctrl-c - ctrl-v (after fresh load of file) 

Expected Results:
similar performance with 'sheet - move or copy sheet' as with copy/paste


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 61d8d991a27c3bfe70e3b8d3b4ce4d8a41d18d2d
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: 

dis - or enabling openGL makes no difference
Comment 1 Telesto 2020-03-30 15:43:35 UTC
(In reply to b. from comment #0)
> Description:
> i 'm in doubt if i'll ever understand @xisco, whenever i add to an old bug
> he want's a new one, if i open a new one he say's 'duplicate' ... 

There always be some mystery's around here.. General rule, never reopen a fixed verified bug. It's quite commonly a new (or reintroduced) bug. Similar, but not the same.

Anyway, thanks for report. I confirm:
Versie: 7.0.0.0.alpha0+ (x64)
Build ID: 4501a0ba623ad61c5a4e0b807da2e96f0e4ce82c
CPU-threads: 4; Besturingssysteem: Windows 6.3 Build 9600; UI-render: Skia/Vulkaan; VCL: win; 
Locale: nl-NL (nl_NL); UI-taal: nl-NL
Calc: CL

and appears to be in 6.4.0.2 (which would mean it never got fixed)
Comment 2 Telesto 2020-04-05 13:23:55 UTC Comment hidden (obsolete)
Comment 3 Telesto 2020-05-22 08:46:23 UTC
Created attachment 161119 [details]
Reduced Example file
Comment 4 Telesto 2020-05-22 08:46:57 UTC
Bisected to
author	Henry Castro <hcastro@collabora.com>	2018-06-26 23:32:41 -0400
committer	Eike Rathke <erack@redhat.com>	2018-06-27 13:44:07 +0200
commit	b9652803096b68a33702601aac52e78c8a4250c6 (patch)
tree	1ed7822221824417039126b7db04a8b37ebeaee8
parent	b262e6e5da0c2e66e00cd6d68d7c2df11a34ff5c (diff)
tdf#118308: Incorrect Paste Special dialog when ...
pasting content from another cell

In tiled rendering case (headless) each window has its own clipboard,
otherwise exists a unique clipboard (UNO service).

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9652803096b68a33702601aac52e78c8a4250c6
Comment 5 Telesto 2020-05-22 08:47:40 UTC
Adding CC to Henry Castro
Comment 6 Telesto 2020-05-23 17:04:19 UTC

*** This bug has been marked as a duplicate of bug 121745 ***
Comment 7 Timur 2020-06-05 13:02:17 UTC

*** This bug has been marked as a duplicate of bug 133267 ***
Comment 8 Timur 2020-06-05 13:04:57 UTC
needs test