Bug 133244 - Undo in Calc slow
Summary: Undo in Calc slow
Status: RESOLVED DUPLICATE of bug 133267
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks:
 
Reported: 2020-05-21 19:25 UTC by Telesto
Modified: 2020-06-05 13:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (104.60 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-05-21 19:26 UTC, Telesto
Details
Bibisect log (2.75 KB, text/plain)
2020-05-21 19:27 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-21 19:25:46 UTC
Description:
Undo in Calc slow

Steps to Reproduce:
1. Open the attached file
2. Select column D & E
3. press Delete
4. Press undo

Actual Results:
5 - 8 seconds

Expected Results:
1 second


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha1+ (x64)
Build ID: 442c7b95e2ee94b66a9854d0cb22f8ecb76532c6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-05-21 19:26:00 UTC
Created attachment 161094 [details]
Example file
Comment 2 Telesto 2020-05-21 19:27:40 UTC
Created attachment 161095 [details]
Bibisect log

Bisected to:
author	Henry Castro <hcastro@collabora.com>	2018-06-26 23:32:41 -0400
committer	Eike Rathke <erack@redhat.com>	2018-06-27 13:44:07 +0200
commit	b9652803096b68a33702601aac52e78c8a4250c6 (patch)
tree	1ed7822221824417039126b7db04a8b37ebeaee8
parent	b262e6e5da0c2e66e00cd6d68d7c2df11a34ff5c (diff)
tdf#118308: Incorrect Paste Special dialog when ...
pasting content from another cell

In tiled rendering case (headless) each window has its own clipboard,
otherwise exists a unique clipboard (UNO service).

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9652803096b68a33702601aac52e78c8a4250c6
Comment 3 Xisco Faulí 2020-05-22 10:25:14 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha1+
Build ID: 8209c2569f5726f9ed29f75d30efdccb94f98fe5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

takes 1-2 seconds...

OTOH, don't see why it's a high/critical bug
Comment 4 Telesto 2020-05-22 11:11:57 UTC
It's surely a thing.. same commit bug 131709

And the bug is exponential .. I reduced the file the get a result within margins.. issue issue generating a document where it would take 15 minutes.. 

And normal/medium is based on? This is a regression. It's exceptional slow (on Windows).. Based on the flow chart it's high/critical or high/major.. 

I would call 'undo' a core component of Calc..
Comment 5 b. 2020-05-22 14:28:03 UTC
@Telesto: win repro, lin not, 

win: 

~5 seconds, slower on subsequent tries, adds up to ~12 seconds, 

lin: 

no repro, milliseconds

versions: 

Version: 7.0.0.0.alpha1 (x64)
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI: en-US
Calc: 

Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: 

additional note(s): 

my construction 
"=CHAR(INT(RAND()*26+1+96))&CHAR(INT(RAND()*26+1+96))&CHAR(INT(RAND()*26+1+96))&CHAR(INT(RAND()*26+1+96))&CHAR(INT(RAND()*26+1+96))" 
is - intentionally! - nagging spreadsheets, for productive use read and keep in mind: 

https://chandoo.org/wp/handle-volatile-functions-like-they-are-dynamite/

observe: from undo you don't get back the previous state, but fresh calculated random values. maybe in win 'rand' is a little slower? 

prev. likely not the issue here as: 

with win after one copy and paste to other columns: 

much better performance even with 10 times the data, ~ 2 seconds ...??? **confused**
Comment 6 Telesto 2020-05-23 17:04:48 UTC

*** This bug has been marked as a duplicate of bug 121745 ***
Comment 7 b. 2020-05-24 12:31:20 UTC
(In reply to Telesto from comment #6)
> 
> *** This bug has been marked as a duplicate of bug 121745 ***

sure about that? both bugs are about 'slow', but 121745 is about copying of a sheet, this about undo of delete ...
Comment 8 Telesto 2020-05-24 12:48:11 UTC
Sure, no.. Expected.. Yes.. and it's always wise to check the duplicates anyhow :-). Having multiple bugs open pointing to the same commit bit unpractical..
Comment 9 Timur 2020-06-05 13:02:32 UTC

*** This bug has been marked as a duplicate of bug 133267 ***
Comment 10 Timur 2020-06-05 13:05:08 UTC
needs test