Bug 131728 - FILEOPEN DOCX Support style separators
Summary: FILEOPEN DOCX Support style separators
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL: https://c-rex.net/projects/samples/oo...
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Paragraph
  Show dependency treegraph
 
Reported: 2020-03-31 00:21 UTC by brucehatfield
Modified: 2022-01-23 21:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Word document to be saved in ODT format with equal no. lines (17.85 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-06-19 03:55 UTC, brucehatfield
Details
PDF exported from MSO 2013 (5.27 KB, application/pdf)
2020-06-19 11:33 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description brucehatfield 2020-03-31 00:21:54 UTC
Description:
Unable to import word lines containing style separator. Lines break into two in Writer, making paragraphs incompatible and meaning incomprehensible

Steps to Reproduce:
1.Type say 3 lines in Word e.g (Heading 1) Apple (style separator, Normal style) shall mean a piece of fruit
2. repeat for say 3 lines
3. Open saved Word document in Writer

Actual Results:
3 lines Word docx format breaks up into 6 lines odf format rendering 3 paragraphs into 6 (as would be for contracts etc.) 

Expected Results:
odf should return 3 lines same as docx


Reproducible: Always


User Profile Reset: No



Additional Info:
Require formulation of equivalent to Word same line style separator so that docx format can be saved to odf with no breaking apart of sentences or paragraphs
Comment 1 Dieter 2020-03-31 12:51:00 UTC
Thank you for reporting the bug. It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 brucehatfield 2020-03-31 15:29:22 UTC
Tested on LO v6.4.3.1(x64) and still unable to import word lines containing style separator. Lines break into two in Writer, making paragraphs incompatible and meaning incomprehensible
Comment 3 Buovjaga 2020-06-18 18:15:25 UTC
Please attach an example document (coming from MS Word, not touched by LibreOffice).
Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.

Please also mention the version of MS Office you used.
Comment 4 brucehatfield 2020-06-19 03:55:19 UTC
Created attachment 162196 [details]
Word document to be saved in ODT format with equal no. lines

Attached is original Word document that cannot be replicated in Writer.
Need is for a style separator equivalent in Word.
Article 1 is typical in legal documents with paragraphs normally being 1-3 lines for say 15 to 30 separate definitions. In contracts the use of the style separator enables lines to be held together tightly. Further, the abbreviated definition headings are retains in PDF versions, making full use of the PDF bookmarks index without cluttering whole lines of text into each PDF bookmark.
Article 2 for usage reference (multiple style separators used, but only first entry in a given paragraph appears in the navigation pane)
Comment 5 Buovjaga 2020-06-19 11:33:21 UTC
Created attachment 162207 [details]
PDF exported from MSO 2013
Comment 6 Buovjaga 2020-06-19 11:44:01 UTC
Thanks for the reference.
I see you already reported this 2 years ago in bug 122159

Looks like this is a bit of an obscure feature as this article says MS doesn't include any help content for it: https://office-watch.com/2016/style-separators-in-word/
Comment 7 brucehatfield 2020-07-02 17:47:45 UTC
Word style separators are perhaps the key feature lacking in Libreoffice that prevents widespread Law office/legislator usage of LO Writer. I translate patents and other documents for US Federal court (+ other jurisdictions) and first came aware of the use of style separators to minimize navigation pane content to essential content (instructions from judge's clerk). Basically it means only the essential part of a heading can now be indexed in the navigation pane/pdf bookmarks (converted from word).
There is extensive discussion of style separators in the Microsoft community demonstrating the important - not obscure - role of this function:
e.g. 
•Formatting issue with style separator when combined with equations and automatic numbering (Office 2013) Nov 19, 2015
https://answers.microsoft.com/en-us/msoffice/forum/all/formatting-issue-with-style-separator-when/e32e9e4e-5edd-4103-88a8-9cdf65a94458
•Updating TOC breaks style separators (Ctrl+Alt+Enter) Jun 17, 2020
https://answers.microsoft.com/en-us/msoffice/forum/all/updating-toc-breaks-style-separators-ctrlaltenter/a248dd2e-31e0-47de-8874-22bf1473849e
•Run-in sidehead in TOC Nov 10, 2013
https://answers.microsoft.com/en-us/msoffice/forum/all/run-in-sidehead-in-toc/0c1b77e3-4c3c-4324-8277-e8f4f51d37d7
◧ As for discussion of use in university thesis writing of style separators as an example: 
"Creating an Inline Heading" mentioning that the APA style defines a level-three heading as being indented in italic on the same line as the first sentence in the paragraph.
https://wordribbon.tips.net/T012723_Creating_an_Inline_Heading.html
So the issue is VERY IMPORTANT as it is a programming omission that renders Writer unusable in perhaps all complex document preparation.
If the task is too difficult pls advise so we know whether this key feature can finally be included or not.
Comment 8 larrybradley 2022-01-23 21:00:21 UTC
This is an ongoing issue that has been reported in at least two separate bug report and the developers have responded once with "ways to accomplish this without developing an actual style separator" (my description) and, in this bug report, "Looks like this is a bit of an obscure feature as this article says MS doesn't include any help content for it."

In the case of both bug reports with which I am familiar, the users were trying to compose legal documents that have very specific formatting requirements. I have also had this requirement when I was composing Contract documents, and I can insure the developers that the suggested workarounds (they hate that word) are not acceptable to the attorneys. That is one reason why we were forced to use MS Word, because it has a built-in Style Separator. And I can assure the developers that if this is an "obscure" feature for most users, it is not a trivial or obsolete feature and it is not obscure for those whose work requires it. It it was trivial and unnecessary, MS would not have included it in Microsoft 365 Word, and they would have by now removed it from the desktop version of Word.

If the devs simply don't want to be bothered with something that is critical to some small (but significant) portion of users and potential users, just say so; however, the tone of this and other discussions on this topic is one seems to me to be a bit too incredulous and dismissive on the dev side. If there is no appetite for ever addressing this issue with the one acceptable solution—to develop a built-in Style Separator that mimics the outcome of the MS Style Separator—please spare us any more effort on our part making the request, providing the rationale, and sending example file. 

Thanks for all that you do, and thanks for listening. LO is a great product, much better than MS Word in most respects, but not an option for those people who work with legal documents, unfortunately.