Bug 131909 - Align left/right for large dataset is slow with text wrap on
Summary: Align left/right for large dataset is slow with text wrap on
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks: Performance
  Show dependency treegraph
 
Reported: 2020-04-05 16:02 UTC by Telesto
Modified: 2022-03-11 19:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (2.62 MB, application/vnd.oasis.opendocument.spreadsheet)
2020-04-05 16:03 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-04-05 16:02:37 UTC
Description:
Align left/right for large dataset is slow with text wrap on

Steps to Reproduce:
1. open the attached file
2. Select column d (sheet 2)
3. Align right/left

Actual Results:
Takes 10 seconds

Expected Results:
2 or 3


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 4501a0ba623ad61c5a4e0b807da2e96f0e4ce82c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-04-05 16:03:01 UTC
Created attachment 159346 [details]
Example file
Comment 2 m.a.riosv 2020-04-06 22:44:45 UTC
Not too mauch different than 6.4.3
Comment 3 Xisco Faulí 2020-05-11 14:15:15 UTC
it takes 6 seconds in

Version: 7.0.0.0.alpha1+
Build ID: 86bc13248c1d9f63b10aac304bdf0361d1dcc47f
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 Xisco Faulí 2020-05-11 14:16:47 UTC
(In reply to Telesto from comment #0)
> Description:
> Align left/right for large dataset is slow with text wrap on
> 
> Steps to Reproduce:
> 1. open the attached file
> 2. Select column d (sheet 2)
> 3. Align right/left
> 
> Actual Results:
> Takes 10 seconds
> 
> Expected Results:
> 2 or 3

is it the expected behaviour because it takes 2 or 3 seconds in previous versions or is it just a personal opinion? if so, based on what? which are your computer specifications ?
Comment 5 Telesto 2020-05-11 14:46:32 UTC
The 2/3 are based on my expectations. Some hard values:
6 seconds with 4.4.7.2 and 13 seconds with 7.0
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded

Intel 3570k stock
Comment 6 Buovjaga 2020-08-28 18:09:16 UTC
I repro on Win, but not on Linux. Linux takes 3 secs while master on my Win VM takes 50 seconds. There is also some regression that makes it super slow to open the file ("adapting row height"). Telesto: have you reported this slow opening at some point? Or is it some improvement to the scientific accuracy of row heights...

Bibisected with win32-6.3 to
https://git.libreoffice.org/core/commit/b7ddc514bff9bdf682abae537f990aa01dc2c0fb
Upgrade to latest HarfBuzz 2.3.1

It seems the time got worse later, though, but bibisecting this would be insanely tedious.
Comment 7 Telesto 2020-08-28 18:30:40 UTC
(In reply to Buovjaga from comment #6)
> Telesto: have you reported this
> slow opening at some point? Or is it some improvement to the scientific
> accuracy of row heights...

See bug 124098 and for the reasoning why comment 23. Feel free to give it a bump. It's certainly slow. I don't remember doing anything special to it
Comment 8 Luboš Luňák 2022-03-11 19:01:57 UTC
Laying out 500k different strings takes a while, not much to do here.