Bug 131970 - LO Create hyperlink → Jump to the correct field by keyboard with TAB?
Summary: LO Create hyperlink → Jump to the correct field by keyboard with TAB?
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.4
Keywords: accessibility, bibisected, bisected
: 135337 (view as bug list)
Depends on:
Blocks: a11y Hyperlink-Dialog
  Show dependency treegraph
 
Reported: 2020-04-07 20:17 UTC by Viktor
Modified: 2020-12-26 21:17 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (24.74 KB, image/png)
2020-04-07 20:19 UTC, Viktor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Viktor 2020-04-07 20:17:57 UTC
Description:
░▒▓ Hello, everybody ▓▒░

I work a lot with hyperlinks in LibreOffice documents. Since some updates, creating them has become unnecessarily "complicated", because I can't work only with the keyboard anymore.

I always create hyperlinks with "Ctrl+K" and then use the menu that appears.

In the past I used to insert the link, then jumped with a few TABs into the "Text" field, added my text to it and then pressed ENTER. → "simple" way

If I now do that in the latest version 6.4 it jumps from the "URL" field to the "Help" button. If I press ENTER now it is clear what happens :). So in the current version (which runs really great!) I have to grab the mouse and click into the field "Text" to get the desired result.

I am actually on LO 6.4.3.1, but this was also a few Versions ago so.
I think this was changed with the new Hyperlink Editor.

Steps to Reproduce:
1. Calc, Writer or any othe document and add a Hyperlink "example with "CTRL+K"
2. add a link into the "URL" field
3. press TAB to jump into the nex needed field example "Text"
4. instead of jumping to the next input field, the "TAB" key unfortunately jumps to the buttons like "help"

Actual Results:
always the same @work @privat and other computers running on Windows 10
other OS not tested

Expected Results:
I think the majority of users use "hyperlinks" in combination with "text" and exactly this creation has now become more complicated.
It would be great if the Hyperlink Editor could work in this steps:
1. CTRL+K
2. opens directly in the URL field (like in the moment)
3. press "TAB" → jumps directly into the "Text" field
4. press "ENTER" → Hyperlink created succesfully

something else: would it be possible that LO remembers the previously entered "texts" in the text field more or less an auto-completion for repeated texts?
Because we process parts lists and the suppliers repeat themselves, we would not have to enter the same names regularly.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.4.3.1 (x64)
Build-ID: 4d2b2b47cca498fed6abf712a36d0788901091eb
CPU-Threads: 8; BS: Windows 10.0 Build 19041; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: CL
Comment 1 Viktor 2020-04-07 20:19:12 UTC
Created attachment 159402 [details]
Screenshot
Comment 2 Harald Berger 2020-04-08 08:05:57 UTC
confirmed with:
Windows 10 Home; Version 1909; 64-Bit | LibreOffice, Version: 6.4.2.2 (x64).
Comment 3 Regina Henschel 2020-04-15 11:38:47 UTC
Using Alt+x to jump to the 'Text' field works neither.

And when the focus is on 'Help' after the first pressing Tab-key, further pressing tab-key circles in the bottom line. Therefore the left pane, where you select the kind of hyperlink, is no longer reachable without mouse.

Therefore I add keyword 'accessibility'
Comment 4 Robert Großkopf 2020-07-15 06:25:18 UTC
This buggy behavior appears also under Linux with with  VCL: kf5; (LO 6.4.4.2) It doesn't appear under Linux with VCL: gtk3; (also LO 6.4.4.2).

Tested both on OpenSUSE 15.1 64bit rpm Linux.

So I switch the Hardware to "All".
Comment 5 Grey 2020-07-25 11:48:28 UTC
Agreed. It's unexpected behaviour/a bug. Insert Hyperlink (Ctrl/Cmd-K) is the only LO dialog panel that ignores tabbing from field to field.

Version: 6.4.3.2
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
OS: Mac OS X 10.13.6
Comment 6 Viktor 2020-10-21 09:42:30 UTC
Is there a solution for this "useability Bug".
Comment 7 Robert Großkopf 2020-10-21 14:43:40 UTC
(In reply to Viktor from comment #6)
> Is there a solution for this "usability Bug".

Please don't set the version of LO to the newest version. It has to be the version the bug first appears. So developer could find the reason for the bug much better.

And: The component for the bug isn't "Base", the database module of LibreOffice. The dialog is, for example, part in "Writer". Could also be changed to "LibreOffice", because the same dialog appears in other modules.
Comment 8 Attila Baraksó (NISZ) 2020-11-12 14:15:58 UTC
Bibisected using bibisect-win64-6.4 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=1942182a3d1817bc539229d7fda3af69f7e295b8
author: Caolán McNamara <caolanm@redhat.com>
committer: Caolán McNamara <caolanm@redhat.com>
summary: weld HyperLink Dialog

Adding Cc: Caolán McNamara
Comment 9 Commit Notification 2020-11-13 13:34:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/de34c45a8ac1f7f1264d8ef649e7b7ee5ab1d2ec

tdf#131970 enable tab-cycling between VerticalTabControl members

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2020-11-13 14:01:39 UTC
fixed in master, backport to 7-0 in gerrit
Comment 11 Commit Notification 2020-11-14 09:49:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d538de17562b2c7ca2c382aeae7c95827999abe5

Related: tdf#131970 icon-switcher should be in single-selection mode

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Viktor 2020-11-15 08:54:18 UTC
░▒▓  F I X E D  ▓▒░
now it is working again, thank you very much.

Tested with: 
Win-x86_64@tb77-TDF 	2020-11-15 04:14:37
‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗
Version: 7.1.0.0.alpha1+ (x64)
Build ID: 42a691933429dbb315de2bd7ba2724993c60411f
CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL
‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗‗
Comment 13 Attila Baraksó (NISZ) 2020-11-16 08:42:15 UTC
Verified in:

Version: 7.1.0.0.alpha1+ (x64)
Build ID: 631974dd958fe4ca1d1f2164266e1e2c81b325ce
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded

@Caolán: Thanks for fixing this issue!
Comment 14 Commit Notification 2020-11-25 08:36:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/21a0d9db670364e841e06692d3863e4e217f70a0

tdf#131970 enable tab-cycling between VerticalTabControl members

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Gabor Kelemen 2020-12-26 21:17:21 UTC
*** Bug 135337 has been marked as a duplicate of this bug. ***