Download it now!
Bug 132210 - [1] Calc crashes when I close spreadsheet file
Summary: [1] Calc crashes when I close spreadsheet file
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.4 target:6.3....
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2020-04-18 07:25 UTC by Biligt
Modified: 2020-04-21 16:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ceb53aad-336e-4768-b7bb-ebc32f9fa213


Attachments
"Move/Copy Sheet" dialog (60.07 KB, image/png)
2020-04-18 07:25 UTC, Biligt
Details
bt with debug symbols (gen) (13.05 KB, text/plain)
2020-04-18 10:54 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Biligt 2020-04-18 07:25:35 UTC
Created attachment 159672 [details]
"Move/Copy Sheet" dialog

Calc crashes when I close spreadsheet file while "Move/Copy Sheet" dialog shown from window title bar and from taskbar using right menu.

To reproduce:

1. Create new spreadsheet 
2. open "Move/Copy Sheet" dialog
3. Click Close button on Calc application
Comment 1 Julien Nabet 2020-04-18 07:50:18 UTC
Do you reproduce this with brand new LO 6.4.3?
Comment 2 Biligt 2020-04-18 10:30:17 UTC
(In reply to Julien Nabet from comment #1)
> Do you reproduce this with brand new LO 6.4.3?

On LO 6.4.3 it doesn't show up crash reporter as in LO 6.3 and Calc window disappears

But in task manager stays following ghost processes

    scalc.exe
    soffice.bin
    soffice.exe

When I try to start Calc it doesn't show any windows but in task manager a new 3 ghost processes appear. So there are 6 processes stays and Calc window doesn't show up.

I had to end 6 processes from task manager to start Calc normally
Comment 3 Julien Nabet 2020-04-18 10:54:57 UTC
Created attachment 159677 [details]
bt with debug symbols (gen)

On pc Debian x86-64 with master sources updated today, I got a crash with gen rendering only since I can't reproduce the crash with gtk3.
I suppose it's due to the modal/non modal diff between renderings.
Comment 4 Julien Nabet 2020-04-18 10:59:16 UTC
Caolán: should all these situations be fixed with a patch like:
diff --git a/sc/uiconfig/scalc/ui/movecopysheet.ui b/sc/uiconfig/scalc/ui/movecopysheet.ui
index 1da0b27928e0..a700a77edfbf 100644
--- a/sc/uiconfig/scalc/ui/movecopysheet.ui
+++ b/sc/uiconfig/scalc/ui/movecopysheet.ui
@@ -14,6 +14,7 @@
     <property name="can_focus">False</property>
     <property name="border_width">6</property>
     <property name="title" translatable="yes" context="movecopysheet|MoveCopySheetDialog">Move/Copy Sheet</property>
+    <property name="modal">True</property>
     <property name="type_hint">dialog</property>
     <child internal-child="vbox">
       <object class="GtkBox" id="dialog-vbox1">
or are there other things to check?
Comment 5 Telesto 2020-04-18 16:06:27 UTC
(In reply to Biligt from comment #2)
> (In reply to Julien Nabet from comment #1)
> > Do you reproduce this with brand new LO 6.4.3?
> 
> On LO 6.4.3 it doesn't show up crash reporter as in LO 6.3 and Calc window
> disappears
> 
> But in task manager stays following ghost processes
> 
>     scalc.exe
>     soffice.bin
>     soffice.exe
> 
> When I try to start Calc it doesn't show any windows but in task manager a
> new 3 ghost processes appear. So there are 6 processes stays and Calc window
> doesn't show up.
> 
> I had to end 6 processes from task manager to start Calc normally

Probably bug 131677
Comment 6 Caolán McNamara 2020-04-18 19:09:45 UTC
caolanm->julien: yes, that looks like the right fix. If you go ahead and submit it to gerrit, you can put me on cc for the changeset
Comment 7 Julien Nabet 2020-04-18 19:14:39 UTC
(In reply to Caolán McNamara from comment #6)
> caolanm->julien: yes, that looks like the right fix. If you go ahead and
> submit it to gerrit, you can put me on cc for the changeset

Done with https://gerrit.libreoffice.org/c/core/+/92488
Comment 8 Commit Notification 2020-04-18 21:03:50 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bc003c7d41c31509882646900c0b2cc8678f0215

tdf#132210: fix Calc crash when closing spreadsheet file

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Julien Nabet 2020-04-18 21:04:07 UTC
backports waiting for review:
- 6.4: https://gerrit.libreoffice.org/c/core/+/92437
- 6.3: https://gerrit.libreoffice.org/c/core/+/92438
Comment 10 Commit Notification 2020-04-19 15:13:35 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a0c189130f7d10722fc0dbf0a7fd354907fae725

tdf#132210: fix Calc crash when closing spreadsheet file

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-04-19 15:15:00 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/ad03784d3c1eb7119efff0d60d942256ff388c7f

tdf#132210: fix Calc crash when closing spreadsheet file

It will be available in 6.3.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-04-21 12:18:03 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-6":

https://git.libreoffice.org/core/commit/7870889a51f6c398e027faabca929511d43198ab

tdf#132210: fix Calc crash when closing spreadsheet file

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2020-04-21 16:02:29 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 850b8de31c5be5127eac16a4f5cc18c26a582e53
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Julien, thanks for fixing this issue!