Bug 132234 - Page is visible but scrolling when clicking on it
Summary: Page is visible but scrolling when clicking on it
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2020-04-18 17:12 UTC by Telesto
Modified: 2022-05-13 07:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-04-18 17:12:14 UTC
Description:
Page is visible but scrolling when clicking on it

Steps to Reproduce:
1. Open the navigator & enable formatting markings
2. Open attachment 159685 [details]
3. Type page 723 as page number in the navigator & press Enter (while document is still rendering; see page counter)
4. Search for the yellow page (should be on page 723, but isn't)
5. Click in the empty area (empty paragraphs) of the yellow page. page will scroll, but you can't access


Actual Results:
Can't access the page

Expected Results:
Should be possible


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 4475bcd83aac7e033fc5250f268eb922bd471e7b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-04-18 17:55:17 UTC
Hmm.. cause.. cursor is still inside navigator, causing the jumping
Comment 2 Telesto 2020-04-18 17:55:43 UTC
(In reply to Telesto from comment #1)
> Hmm.. cause.. cursor is still inside navigator, causing the jumping

Pressing ESC before clicking solves the issue
Comment 3 Buovjaga 2020-08-25 17:49:11 UTC
No repro

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 8700bace8c0714d853f5df6918ab9c8bb3d81f77
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: e2fe4fde592564d35099ad1e2659ad682dfb77f5
CPU threads: 8; OS: Linux 5.8; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 25 August 2020
Comment 4 nme 2021-02-20 19:07:36 UTC
I could not reproduce the scrolling effect, but encountered some other strange behavior.
What I did to reproduce it:


Version 7.1.1.1 (64x) LibreOffice Community
Build 575c5867c4cc13d7ae78f9ce39a54a52ed38c769
CPU threads: 12; OS: Windows 10.0 Build 18363, UI render: Skia/Vulkan; VLC: win
Locale: en-US (de_DE); UI: en-US
Calc: threaded


1. Open a new document in Writer, enable formatting marks 
2. Open the attached file
3. Displayed page number while rendering: 692. The page number decreases then, the zoom changes to 46%. 
4. Type page 723 as page number in nagivator and pressing enter results in the number getting corrected to the maximum page number already rendered and jumping to the end of the document.
5. After some seconds, the total amount of 731 pages is laoded. Entering page 723 in the navigator results in landing on the yellow page. 
6. Clicking on the empty area results in access to that page, no scrolling.
Comment 5 nme 2021-02-20 19:17:24 UTC
Following the same steps on another version:

1. Open a new document in Writer, enable formatting marks 
2. Open the attached file
3. Displayed page number while rendering: 692. Zoom changes to 46%
4. Type page 723 as page number in nagivator and pressing enter results in the number getting corrected to the maximum page number already rendered and jumping to the end of the document.
5. After some seconds, toal amount of pages increased. Yellow page is on page 725 now (total: 734 pages).
6. Clicking on the empty area results in access to that page, no scrolling.


Version 7.0.1.2(64)
Build dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 12, OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Loacle: de-DE (de_DE); UI: de-DE
Calc: CL
Comment 6 Natali Eroshenko 2021-08-04 14:53:41 UTC
nme@kuk-is.de 
Maybe you want to make it a separate error
Comment 7 Natali Eroshenko 2021-08-04 14:54:50 UTC
on the issue Telesto don`t repro in Version: 7.1.5.2 (x64) / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 6; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: en-US (ru_RU); UI: en-US
Calc: threaded
Comment 8 Lena Dodul 2021-08-15 14:41:08 UTC
no repro in 

Version: 7.3.0.0.alpha0+ (x86) / LibreOffice Community
Build ID: ee5a1b61b4460b965413a3f7ed4f9152322f1c02
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 9 Xisco Faulí 2022-05-02 12:04:34 UTC
Dear Telesto,
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build