Bug 148913 - Crash mergedlo!SfxViewFrame::Notify+0xf87 for some users
Summary: Crash mergedlo!SfxViewFrame::Notify+0xf87 for some users
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0 alpha1+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.5.0 target:7.4.0.2 target:7.3.6
Keywords: bibisected, bisected, regression
: 143731 (view as bug list)
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2022-05-03 20:32 UTC by Telesto
Modified: 2022-08-18 17:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
BT without symbols (9.44 KB, text/plain)
2022-05-03 20:32 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2022-05-03 20:32:38 UTC
Description:
Crash mergedlo!SfxViewFrame::Notify+0xf87

Steps to Reproduce:
1. Open Writer
2. Activated the sidebare page tab
3. Close the document -> Go back to Start Center
4. Open attachment 159685 [details] -> Crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 00e43c14558fa4d0369820fa3d2cd7b987e61377
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (nl_NL); UI: en-GB
Calc: CL
Comment 1 Telesto 2022-05-03 20:32:52 UTC
Created attachment 179904 [details]
BT without symbols
Comment 2 Telesto 2022-05-03 20:37:21 UTC
And in
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: ff2ba77f22b2e96f96f5537aec1705956b47583d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

not in
Version: 7.0.7.0.0+ (x64)
Build ID: 626ea4e62a3e5005fe9825923a1c0c5bdb61cc08
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 3 Xisco Faulí 2022-05-04 08:00:37 UTC Comment hidden (obsolete)
Comment 4 Telesto 2022-05-04 08:57:47 UTC
(In reply to Xisco Faulí from comment #3)
> Not reproducible in
> 
> Version: 7.4.0.0.alpha0+ / LibreOffice Community
> Build ID: 75fe4051320ef9b1f4323fa958e8df3db2066882
> CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
> Locale: es-ES (es_ES.UTF-8); UI: en-US
> Calc: threaded
> 
> Do you reproduce it with a clean profile ?

Yes
Comment 5 QA Administrators 2022-05-05 03:54:20 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2022-05-05 20:36:25 UTC
Confirm the crash in (the Sidebar status isn't matter)

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c81f4a4ecbfa7dc97d8c28b5ec5f00d1d561b6bb
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: CL


no crash in 7.2 or 7.3

I bisected this one in win64-7.4 bisect repo and got the SHA

https://git.libreoffice.org/core/commit/5fbc7ab55a119504fc484cef28de52b6d5cf8b12

https://gerrit.libreoffice.org/c/core/+/117899

Added to CC: Jan-Marek Glogowski
Comment 7 Xisco Faulí 2022-05-12 14:30:19 UTC
I can't reproduce it in

Version: 7.3.2.2 (x64) / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 1; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

either
Comment 8 Caolán McNamara 2022-05-12 19:10:33 UTC
The crash is under windows, but the bisect points to code which isn't built under windows so there might be some variability to this.
Comment 9 Timur 2022-05-13 07:50:40 UTC
*** Bug 143731 has been marked as a duplicate of this bug. ***
Comment 10 Telesto 2022-05-17 20:02:35 UTC
I'm already seeing this in 7.2 (so BT stack(, I'm attempted a bibisect, but took the wrong turn somewhere.. 

[d489a9e1ee6173b712de05bf9a733ad9b394cfac] source sha:1a984f2ff11e1125f146824924dcc373bccb0cdf

is already crashing

it might be https://cgit.freedesktop.org/libreoffice/core/commit/?id=cb965f2cf6d68c284ccbd8a9635abfdfcc0538ca if i'm really close
Comment 11 Jan-Marek Glogowski 2022-05-24 15:12:49 UTC
(In reply to Caolán McNamara from comment #8)
> The crash is under windows, but the bisect points to code which isn't built
> under windows so there might be some variability to this.

Yup. And a non-symbol backtrace from an alpha build doesn't really help. I'll see, if I can update my Win symbol build this WE and if the STR still apply, we can get a BT or maybe even a fix.

If someone wants to re-bibiset, just don't miss the previous attempts.

(In reply to Telesto from comment #10)
> I'm already seeing this in 7.2 (so BT stack(, I'm attempted a bibisect, but
> took the wrong turn somewhere.. 
> 
> [d489a9e1ee6173b712de05bf9a733ad9b394cfac] source
> sha:1a984f2ff11e1125f146824924dcc373bccb0cdf
> 
> is already crashing
> 
> it might be
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=cb965f2cf6d68c284ccbd8a9635abfdfcc0538ca if i'm really close

It seldomly happens that stuff breaks, is fixed and the broken again. That last commit is Writer code, so looks more promising. It might be closer to the real bug, but in the end a clear bt might help more, if bisecting results are varying.
Comment 12 Timur 2022-05-24 15:49:52 UTC Comment hidden (obsolete)
Comment 13 Jan-Marek Glogowski 2022-05-25 12:30:57 UTC
(In reply to Timur from comment #12)
> Maybe it's about running Qt?

I don't follow. From all comments I got, this is really Windows-only. At least it seems nobody has tried yet to repo on Linux. Following the STR with:

1. so -env:UserInstallation=file:///tmp/tdf#148913 --writer
2. Activated the sidebar page tab
3. Close the document -> Go back to Start Center
4. Open attachment 159685 [details]

=> no crash

Version: 7.4.0.0.alpha1+ / LibreOffice Community
Build ID: 6151a28e95bd995e33ef44134350e383b4f11cd1
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded

That is a very heavily patched master with tons of VCL infrastructure patches to eventually fix tdf#141578 in the long run. IMHO none of this should affect this bug.
Comment 14 Gabor Kelemen (allotropia) 2022-07-18 08:30:51 UTC
With the steps:

$ rm -rf instdir/user/
$ instdir/program/soffice --safe-mode
* Continue in Safe mode
* Open new Writer document, display the sidebar, close the document
* Open the example file from Start Center
-> crash

I can reproduce it in current win-bibisect-75 master:

Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 04073c5fedd33654f242fecb7e39afb07cf0e273
CPU threads: 14; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: threaded

but not on Linux.

Seems to have started in 7.2 with 

https://git.libreoffice.org/core/+/d89786054715b44aa983d0752484216825c74ae2

author	László Németh <nemeth@numbertext.org>	Thu Apr 08 10:20:02 2021 +0200
committer	László Németh <nemeth@numbertext.org>	Mon Apr 12 10:44:49 2021 +0200

tdf#125909 tdf#141298 sw: show (Hidden) Track Changes infobar

Adding CC to: László Németh
Comment 15 László Németh 2022-07-19 13:19:37 UTC
Proposed fix: https://gerrit.libreoffice.org/c/core/+/137230

Gábor: thanks for the nice catch!

Telesto & all: thanks for your great help!
Comment 16 Commit Notification 2022-07-19 16:03:20 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/85a044abdf08bafa93e1caddf38f86e35d7e17f2

tdf#148913 sw: fix crash with pending infobars on Windows

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 László Németh 2022-07-19 16:05:16 UTC
Commit description:

tdf#148913 sw: fix crash with pending infobars on Windows

Usage of VclPtr<SfxInfoBarWindow> wasn't thread-safe
on Windows, resulting random crashing during loading big
documents.

Regression from commit d89786054715b44aa983d0752484216825c74ae2
"tdf#125909 tdf#141298 sw: show (Hidden) Track Changes infobar".
Comment 18 Commit Notification 2022-07-19 18:01:48 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/06229e4df02ddccb0408538271e0fbf683847355

tdf#148913 sw: fix crash with pending infobars on Windows

It will be available in 7.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 NISZ LibreOffice Team 2022-07-26 11:40:34 UTC
Verified in:
Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 5df1bb4b1b222be00d25097660c4ee33542896ea
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 20 Commit Notification 2022-08-18 17:18:24 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/8067c5a66538b2fc31bbed9d5ae7dbfcaa6821f6

tdf#148913 sw: fix crash with pending infobars on Windows

It will be available in 7.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.