Bug 132531 - "Insert Date" kb shortcut not possible with German keyboard
Summary: "Insert Date" kb shortcut not possible with German keyboard
Status: RESOLVED DUPLICATE of bug 126085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-29 19:50 UTC by Christian González
Modified: 2020-04-29 20:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian González 2020-04-29 19:50:37 UTC
Description:
The keyboard shortcut for inserting the current date is Ctrl + ";" in Libreoffice (Calc). At the German keyboard layout, ";" is located on the same kb button as the ",", but only using the "Shift" key. So Ctrl + ";" really would mean Ctrl + Shift + ";" - but this keypress combination is used for inserting the current TIME.
So Inserting the current date is virtually impossible using the keyboard.
BTW - same goes for Ctrl + ` - this is "Show formula". But ` is not available as single tapped key - you have to press Shift + ' for that - But Ctrl + Shift + ' doesn't work neither. 
Better use other key combinations for them. in German.

Steps to Reproduce:
1. Open Calc, place cursor into a cell
2. Press Ctrl + Shift + ";"
3. The current time is inserted

Actual Results:
as said. you can't insert date, there is no Ctrl + ";" combination on a German keyboard.

Expected Results:
it should be possible per keyboard shortcut. What would be possible: Maybe use Ctrl + "," - if this is not taken already.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Ming Hua 2020-04-29 20:20:45 UTC
Thanks for reporting.  This issue has already been reported as bug 126085, so I'm marking it as DUPLICATE.

*** This bug has been marked as a duplicate of bug 126085 ***