Download it now!
Bug 132634 - Copy and paste from some programs no longer works
Summary: Copy and paste from some programs no longer works
Status: RESOLVED DUPLICATE of bug 62196
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-03 12:14 UTC by jeffreyswebb
Modified: 2020-05-04 14:56 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jeffreyswebb 2020-05-03 12:14:32 UTC
Description:
I have some Bible Study software that I used to copy and paste text from into LibreOffice Writer. This copy and paste does not work with Version 6.4.3.2(x64).

I can copy the text from the Bible Study software to a browser edit field or notepad, then copy that to LibreOffice Writer but not directly.

Copying from OliveTree I get a "Requested clipboard format is not available." error. Copying from WordSearch 12, I get no error and no pasting of text.

Version: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


Steps to Reproduce:
1.Copy to clipboard from external application that contains formatted text.
2.Paste from clipboard into LibreOffice Writer


Actual Results:
Error message or no data is pasted.

Expected Results:
Text will be pasted into document


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no

[The OS is windows 10]
Comment 1 Bart 2020-05-03 17:33:31 UTC
I would like to reproduce the problem that you have, but I don't have the Bible Study software and I don't have OliveTree either. I tried it with a few other programs that I have, but they all worked fine.

Can you try to copy and paste from the various programs that you have and let us know in which cases the copy and paste doesn't work? If you can first try the programs that come with Windows, or that we find on most Windows installations, that's ideal, because many other volunteers will have those too.

I'm running Linux/Debian10 and it comes with different programs. That's why I may not be able to help, but with the programs that you mention it will be easier for others here to reproduce your problem. In other words, I'm trying to speed up the process. ;-) 

If you have added the names of a few programs, please set the status back to "unconfirmed".

PS: I'm not a developer. I'm a user myself and I submitted a few bug reports. I'm trying to confirm the bugs that other people report here.
Comment 2 Timur 2020-05-04 02:19:26 UTC
There are many paste bugs already open. 
This one is probably duplicate, reporter should have searched before reporting. 
https://bugs.documentfoundation.org/show_bug.cgi?id=62196
https://bugs.documentfoundation.org/show_bug.cgi?id=116983
https://bugs.documentfoundation.org/show_bug.cgi?id=57147
Se also 
https://bugs.documentfoundation.org/show_bug.cgi?id=129987
Comment 3 jeffreyswebb 2020-05-04 12:13:12 UTC

*** This bug has been marked as a duplicate of bug 62196 ***