Bug 116983 - Paste is sometimes deactivated in (context) menu even though text is copied to clipboard and CTRL+V functioning (steps: Comment 0 and Comment 13 and Comment 28)
Summary: Paste is sometimes deactivated in (context) menu even though text is copied t...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: highest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 116014 129291 129866 133530 133533 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-04-13 08:31 UTC by Nithin
Modified: 2020-07-18 18:09 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
The odf file for text to be pasted (8.60 KB, application/vnd.oasis.opendocument.text)
2018-04-13 08:32 UTC, Nithin
Details
The pdf file for text to be copied from (6.51 KB, application/pdf)
2018-04-13 08:32 UTC, Nithin
Details
Another PDF (93.73 KB, application/pdf)
2020-06-10 14:06 UTC, Timur
Details
Inside Clipboard file (2.15 KB, application/octet-stream)
2020-07-14 19:02 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nithin 2018-04-13 08:31:32 UTC
Description:
The paste options under, Edit-Paste, Edit-Paste_Special and Right_Click-Paste, Right_Click-Paste_Special are deactivated even though text is copied to clipboard.

Steps to Reproduce:
1.Clear clip board in your OS. There should not be anything copied into the clipboard.
2.Open pdf and odt flie.
3.Right click at the end of Line One in the odt file
4.Paste is active even though nothing is in clipboard(There is nothing to paste.)(This is the first bug)(Do click on paste to verify that clipboard is really empty)
5.Shift to the Pdf file and Copy the text(I did it with Right_click Copy in adobe reader).
6. Shift back to the odt file. Right click and try pasting the copied contents.
7. This is Bug2. The options Paste and Paste special are greyed out(deactivated). It is however possible to paste using keyboard shortcuts(Ctrl+V or Ctrl+Shift+V)

Actual Results:  
Paste options are deactivated when the stuff is in the clipboard.
Paste Options are active before.

Expected Results:
The paste options should be activated when there is text to be pasted in the clipboard.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
This bug is observed in Calc also. Therefore i selected the affected component as LO.

Sometimes this bug is not observed. Repeat steps 5-6 again a couple of time to observe it.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Nithin 2018-04-13 08:32:07 UTC
Created attachment 141323 [details]
The odf file for text to be pasted
Comment 2 Nithin 2018-04-13 08:32:25 UTC
Created attachment 141324 [details]
The pdf file for text to be copied from
Comment 3 Nithin 2018-04-13 08:41:42 UTC Comment hidden (no-value)
Comment 4 Telesto 2018-04-13 11:48:06 UTC
No repro for both issues based on the steps in comment 0 (except I used PDF-XChange)
Version: 6.1.0.0.alpha0+
Build ID: 84e2614a75a615d6c8584b13a69b3368d2a12a3d
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-12_09:11:38
Locale: nl-NL (nl_NL); Calc: CL

But the bug exists for sure.. However I can't reproduce it reliably either. This works for me 1 out of 4 attempts or so (bug 116014)

1. Open attachment 141323 [details]
2. Disable spell check
3. Insert a comment -> Add some text: say "AAA"
4. Select "AAA' with the mouse
5. Right click -> Copy
4. Right Click after Line One -> Paste (enabled)
5. Add "B" to "AAA" in the comment box - so: "AAAB"
6. Select "AAAB" with the mouse
7. Right click -> Copy
8. Right Click after Line One -> Paste should be disabled..
Comment 5 Markus Grob 2018-08-09 20:52:12 UTC
Maybe a dublicate of bug 65606?
Comment 6 yinjui 2018-11-29 08:16:06 UTC
 “Bug not reproducible in version”
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded
Comment 7 Xisco Faulí 2019-01-23 13:11:05 UTC Comment hidden (obsolete)
Comment 8 Nithin 2019-01-31 10:30:44 UTC Comment hidden (no-value)
Comment 9 Xisco Faulí 2019-07-31 11:33:40 UTC Comment hidden (obsolete)
Comment 10 Nithin 2019-08-19 14:26:15 UTC
Hello Xisco,

I checked this on 
Version: 6.3.0.4 (x64)
Build-ID: 057fc023c990d676a43019934386b85b21a9ee99

1. The paste button being active when there is nothing in the clip board exists
2. the paste button getting deactivated after i copied text from the pdf exists


I could only paste after I closed and reopened Writer.

3. The formatting being reset to original after pasting is working as expected.
Comment 11 QA Administrators 2019-09-02 09:38:36 UTC Comment hidden (obsolete)
Comment 12 Timur 2019-09-02 11:52:13 UTC
(In reply to Nithin from comment #10)
> 1. The paste button being active when there is nothing in the clip board
> exists
This is not the point of the bug. Only one bug per report and that's 2 here.  

> 2. the paste button getting deactivated after i copied text from the pdf
> exists
> I could only paste after I closed and reopened Writer.
No repro as described. But I did repro with 6.4+ first time I tried Telesto's steps, with simple comment text copy.
So I also conclude there's a bug, but we don't have reliable steps.
Comment 13 Timur 2019-10-09 14:26:57 UTC
Thanks to https://bugs.documentfoundation.org/show_bug.cgi?id=57147#c28 I have steps for part of the bug when Paste button is deactivated.
Repro OO and LO 6.4+.

1. Open a new Writer Document. I reproduce when Writer is opened before copying.
2. Open Vivaldi or Opera or Firefox or PaleMoon and go to https://www.heise.de/newsticker/
3. mark and copy (CTRL + C) some newsticker headline (but ONLY the headline. Do NOT right-click the link and copy the link, but mark the text and copy the text. 
4. go to Writer and see that paste is unavailable - and that's the BUG
Note: I may paste the clipboard with CTRL + V. Often that's also not possible and some other steps are welcome. 

Many similar reports. I set to High hoping that this will draw someones' attention.
Comment 14 Timur 2019-10-09 14:27:30 UTC
*** Bug 116014 has been marked as a duplicate of this bug. ***
Comment 15 Xisco Faulí 2019-10-10 13:42:18 UTC Comment hidden (obsolete)
Comment 16 Xisco Faulí 2019-10-10 13:49:49 UTC
it seems a duplicate of bug 57147... anyway, let's keep it open for the the time being. no need to have both as high severity bugs though...
Comment 17 Timur 2019-10-10 14:07:46 UTC
(In reply to Xisco Faulí from comment #15)
> How can you select the headline in Firefox? 
Simply with mouse from left to right. Takes some practice, though.
are you sure it doesn't work when using Firefox ?
Today I tried again and paste button was available on first copy (meaning no repro) but on the following copy button wasn't available (repro).
Comment 18 Timur 2019-10-30 11:26:07 UTC
Xisco, did you reproduce? There are many paste-related bugs and now we have steps we should raise importance and get someone to look at this. 
Hopefully this can be done without a refactoring of the XClipboard per https://bugs.documentfoundation.org/show_bug.cgi?id=62196#c62.
Comment 19 Timur 2020-01-09 15:10:14 UTC
*** Bug 129866 has been marked as a duplicate of this bug. ***
Comment 20 Marcos Queiroz 2020-01-09 17:12:29 UTC
I has the same problem in Calc, but sometimes happens sometimes not.
When I copy some text from another program and I try to paste in Calc, the buttons are disabled or the short cut doesn't work. But if I close the program and open a new sheet, I can paste the information I had copied previusly.
This bug has been ocurring for a long time and nobody fixit it.
I'm using Windows 10 and Calc 6.3.3.2.
Comment 21 Timur 2020-03-22 20:10:21 UTC
*** Bug 129291 has been marked as a duplicate of this bug. ***
Comment 22 Pierre-Alain TORET 2020-04-26 17:32:44 UTC
If that can be of any help, I want to add some details regarding version 6.4.3 (running on ArchLinux)
Here the problem can be defined as : copy/paste between different documents opened in Writer (or among sections in the same document) stops working properly after some time.

Basically to recreate the issue simply :
- have a document with some text in it, open it
- select, then copy / paste a section of it in that same document, that works
- select, then copy / paste another section and repeat that with different sections (to be able to know if you're pasting the section you've just copied or the one before), until at some point either it pastes nothing (the icons on the top of LO are greyed in that case) or it pastes the previous selection. The length of the selection itself, or of the one before doesn't seem to matter (one word, two, one paragraph, more), then after some time, it will stop to reproduce and work again, then will stop working, etc... What resets it it stopping LO and starting it again, that makes it works perfectly fine for some time again and it appears again, etc...
Comment 23 Timur 2020-06-10 12:49:15 UTC
*** Bug 133533 has been marked as a duplicate of this bug. ***
Comment 24 Timur 2020-06-10 13:41:21 UTC
*** Bug 133530 has been marked as a duplicate of this bug. ***
Comment 25 Timur 2020-06-10 13:43:01 UTC
I retested annoying paste issue. 

Reproduced Description and Comment 13 from bug 116983 in LO 6.3 as regularly no paste is available in toolbar and right-click menu, while Ctrl+V is working. Seems that LO (ex. new Writer) must already be open when text from PDF is copied. 
Easier to see if there's more text in some PDF, so you copy part1 from PDF and paste to Writer, then part2 or part3. Same with Adobe Acrobar or PDF-Xchange for me.
But I don't reproduce that in master 7.1+ which would be nice.

Similar with duplicated bug 116014, simple copy of "LibreOffice Design Blog" from https://planet.documentfoundation.org/ wouldn't work in already open LO 6.3 while would in 7.1+.
Comment 26 Timur 2020-06-10 13:55:58 UTC Comment hidden (obsolete)
Comment 27 Timur 2020-06-10 14:06:31 UTC
Created attachment 161838 [details]
Another PDF
Comment 28 Telesto 2020-06-10 14:19:57 UTC
1. Open a PDF - for example attachment 161838 [details] - with Adobe Acrobat Reader DC 
2. Select some text from the PDF in Acrobat & copy
3. Right Click Paste in Writer
4. Select some different text from the PDF in Acrobat & copy
5. Right click paste in Writer
6. Select some different text from the PDF in Acrobat & copy
 
-> Paste should show disabled by now; with CTRL+V still working properly
Comment 29 Timur 2020-06-10 14:26:02 UTC Comment hidden (obsolete)
Comment 30 Timur 2020-06-10 14:32:37 UTC
Actually: "no paste is available in toolbar and right-click menu, while Ctrl+V is working" and CTRL+SHIFT+V also not working (nor working "paste unformatted text" custom icon). 
So bug 65606 really can be the same.
Comment 31 Telesto 2020-06-10 14:34:07 UTC
Another version
1. Download Insideclipboard
2. Open Calc
3. Open notepad and type some text: say AAA
4. Clear clipboard with Insideclipboard
5. Copy AAA
6. Right Click Paste in Calc
Comment 32 Telesto 2020-06-10 14:34:31 UTC Comment hidden (obsolete)
Comment 33 Timur 2020-06-10 14:45:14 UTC
(In reply to Telesto from comment #32)
> (In reply to Timur from comment #29)
> > Telesto, which is your test LO version?
> 
> Version: 7.1.0.0.alpha0+ (x64)
> Build ID: 59939d2490726336546c7ad05082d23031074e12
> CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win

Mine is the same. If you still reproduce, I'm wrong this is resolved. 
But at least seems much better than 6.3, like there were some changes.
Comment 34 Telesto 2020-06-10 15:08:33 UTC Comment hidden (no-value)
Comment 35 Timur 2020-06-11 08:55:27 UTC
(In reply to Timur from comment #26)
> This is Win and I can't make bibisect, which would be very useful to confirm.

Xisco and Buovjaga: please see and maybe try to reverse bibisect this.

Bug 57147, bug 65606, bug 116983 look similar: 
"Paste is sometimes deactivated in toolbar and context menu and Paste Special CTRL+SHIFT+V isn't working. Text is copied to clipboard and CTRL+V and CTRL+ALT+SHIFT+V are functioning."
Bug is surely and mostly in Windows, but some reports are also for Linux. 
I can easily reproduce in LO 6.3 and LO 7.0 beta in Windows, with copying from PDF like attachment 161838 [details] (using Adobe Acrobat or PDF-Xchange) or web page like title from https://planet.documentfoundation.org/, so steps are rather reliable, but not so in master 7.1+. 
I was hoping that this was resolved, but other user reproduced again.
Normally we duplicate and merge bug reports but we have 19 reports and 31 CCed users (plus those in duplicated reports), it would be a lot of messages. 
It's of highest importance, even not of severity, to resolve these.
Comment 36 Telesto 2020-06-11 10:34:45 UTC Comment hidden (no-value)
Comment 37 Buovjaga 2020-06-12 20:33:30 UTC
(In reply to Telesto from comment #31)
> Another version
> 1. Download Insideclipboard
> 2. Open Calc
> 3. Open notepad and type some text: say AAA
> 4. Clear clipboard with Insideclipboard
> 5. Copy AAA
> 6. Right Click Paste in Calc

I tried to reverse bibisect this as I don't get this with a Win master build, but got a nonsensical result. Used the new Win 7.1 repo. The latest commit in the 7.1 repo is consistently working, though.
Comment 38 Timur 2020-06-14 15:01:28 UTC
It would be great if this is resolved, although it will take long to arrive in release in 7.1. I don't know how Telesto still reproduces. We may keep open because there may be more duplicates.
Comment 39 Telesto 2020-06-14 16:01:39 UTC
(In reply to Timur from comment #38)
> It would be great if this is resolved, although it will take long to arrive
> in release in 7.1. I don't know how Telesto still reproduces. We may keep
> open because there may be more duplicates.

I would love somebody to try comment 28 and the paste from comment from separate instance of LibreOffice (bug 133533). Yes, the second one is not a real life example.. but need it to be? Surely not a different bug. 

The only thing I care about is a confirmed reproducer.... Which still holds on 7.1 - there is IMHO. And a developer who takes a peak at it.. if we finally have some way to 'proof' the issue

I reported this in separate reports, to get a conformation or/not.. but it gets marked as duplicate without testing.. or tested and still marked as duplicate of some related bug without STR.. And the opinion changed to 'I don't see this anymore'. Without knowing any testing steps (there a multitude of steps around). Some bugs need very exact steps.. like bug 133975 (appearing, disappearing. reappearing.. superficial bibisects point to Jan-Marek, he gets the blame, and his commits did make it worse.. but the culprit being somewhere else)

Marking everything rigorously as a duplicate makes it difficult to keep track.  And the paste disabled in context menu is a facet of the copy/paste bug mess. Paste being blocked has probably a different cause. Pasting older copy.. another..

I prefer starting with stabbing the he copy context menu/ ctrl+shift+paste issue (for Windows).. The easiest to reproduce, as far I know... And look for other issues afterwards. The copy/paste bugs should be tackled step by step.
Comment 40 Buovjaga 2020-06-23 09:57:03 UTC
(In reply to Buovjaga from comment #37)
> (In reply to Telesto from comment #31)
> > Another version
> > 1. Download Insideclipboard
> > 2. Open Calc
> > 3. Open notepad and type some text: say AAA
> > 4. Clear clipboard with Insideclipboard
> > 5. Copy AAA
> > 6. Right Click Paste in Calc
> 
> I tried to reverse bibisect this as I don't get this with a Win master
> build, but got a nonsensical result. Used the new Win 7.1 repo. The latest
> commit in the 7.1 repo is consistently working, though.

I was discussing the general clipboard topic a bit in the dev chat and was pointed to this commit:
https://git.libreoffice.org/core/+/fda6ad1458fcd5087c3dde56300b9d0367af6db5%5E%21
cache foreign content in win32 clipboard code (tdf#133267)

I checked the Win 7.1 repo and unfortunately this specific commit is inside a range of commits! So it might be that this commit helped solve this particular issue.
Comment 41 Telesto 2020-06-23 11:35:55 UTC
(In reply to Buovjaga from comment #40)
Nothing changed.. the clipboard still gets 'borked' somehow. 

1. It works until it break down.. if breaks it gets unpredictable, until it returns to normal.  
2. The copy comment content from LibreOffice instance LibreOffice 7.0 b2 to master still breaks down after (copy/pasting pattern of 3/4 times). Writer/Calc no difference. Copy/Paste from Adobe acrobat reader start fail too, after the brokenness is introduced

New document doesn't solve the problem; clipboard is disable.. 

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 43c60ce1ac7629a1462e927e6ff937469f58f743
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

This is a OOO bug, IMHO. So appears goes, away, appears etc. so bibisecting is pointless exercise.
Comment 42 Buovjaga 2020-06-23 12:30:37 UTC
(In reply to Telesto from comment #41)
> (In reply to Buovjaga from comment #40)
> Nothing changed.. the clipboard still gets 'borked' somehow. 
> 
> 1. It works until it break down.. if breaks it gets unpredictable, until it
> returns to normal.  
> 2. The copy comment content from LibreOffice instance LibreOffice 7.0 b2 to
> master still breaks down after (copy/pasting pattern of 3/4 times).
> Writer/Calc no difference. Copy/Paste from Adobe acrobat reader start fail
> too, after the brokenness is introduced
> 
> New document doesn't solve the problem; clipboard is disable.. 
> 
> Version: 7.1.0.0.alpha0+ (x64)
> Build ID: 43c60ce1ac7629a1462e927e6ff937469f58f743
> CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
> Locale: nl-NL (nl_NL); UI: en-US
> Calc: CL
> 
> This is a OOO bug, IMHO. So appears goes, away, appears etc. so bibisecting
> is pointless exercise.

I was talking about the variant involving using InsideClipboard to clear the clipboard. You still repro it with master?
Comment 43 Telesto 2020-06-23 12:50:32 UTC
(In reply to Buovjaga from comment #42)
> I was talking about the variant involving using InsideClipboard to clear the
> clipboard. You still repro it with master?

Yes, when copy/pasting from a comment note from LibO instance a to LibreOffice instance B.. And if it's broken.. it will affect other copy/pastes for a while
Comment 44 Buovjaga 2020-06-23 13:23:22 UTC
(In reply to Telesto from comment #43)
> (In reply to Buovjaga from comment #42)
> > I was talking about the variant involving using InsideClipboard to clear the
> > clipboard. You still repro it with master?
> 
> Yes, when copy/pasting from a comment note from LibO instance a to
> LibreOffice instance B.. And if it's broken.. it will affect other
> copy/pastes for a while

Just want to make things super duper clear, as I am looking at these steps, which have nothing to do with comments and different LibO instances:
1. Download Insideclipboard
2. Open Calc
3. Open notepad and type some text: say AAA
4. Clear clipboard with Insideclipboard
5. Copy AAA
6. Right Click Paste in Calc

I just tried again and I can consistently reproduce with 6.4.4, but NEVER with master. So on my system this case is WFM. I'm not saying Nithin's original report is WFM as I didn't try it.
Comment 45 Timur 2020-06-23 14:30:31 UTC
I already wrote that I find Telesto's LO instances argument wrong for troika 
Bug 57147, bug 65606, bug 116983.
Because:
1. these are real usage bugs and not theoretical
2. at least one instance is probably older LO.

I suggest Telesto reopens some of his bugs for LO instances and tests with two fresh master instances and that we close these.  
Buovjaga, please confirm and I'll do.

As for Nithin's Comment 0:
Even if we clear clipboard, say with ‘echo off | clip’ (no quotes) in Win CMD, Paste is active. I wouldn't consider it a bug and is not this one. 
Paste bug in step 7 is the same as other paste issues from PDF, WFM now in LO master.
Comment 46 Telesto 2020-06-23 15:17:46 UTC
(In reply to Timur from comment #45)
> I already wrote that I find Telesto's LO instances argument wrong for troika..

1) You need a reproducer.. It does exactly what is described.. Working until it suddenly stops. And successive copy/paste from other apps to LibreOffice go off track  after such an event.. And the problem is limited to LibreOffice (copy/paste is functional). And if this also happens between master builds using the system clipboard, it's still means something is off. Between LibreOffice instances (same master version) it should work. I you never know where the issue is when pasting from Firefox/Chrome.. Could be a Firefox/Chrome bug..

It is not explicitly relevant 'how' it reproduced.. that there is a reproducer which fits the description and can be reproduced... in contrast to many many other reports.. This could be 'timer' based or solar mutex being lock/unlocked. So depending content & some quirky timing. 

2) Closing this bug; no complains issue

3) Would like bug 57147; bug 65606 being closed also.. maybe after someone asking if the issue is resolved with 7.0/ 6.4 (not sure where the 'good' starts)
 
4. Leave my 'lovely' troika case open.. and lets wait if some new come in (hopefully not). I acknowledge there is some improvement.. or the problem is better hidden. However have seen it happen - again while testing copy/pasting.. in a different setting. Without registering the steps (if this possible at all). And of course being sporadic It could be caused by how order of of clipboard formats. So pure text, against RTF, against HTML and or timing etc. Way to many variables.
Comment 47 Telesto 2020-06-25 18:32:04 UTC
Another (dubious?) way based on bug 99623
1. Download CLCL https://www.nakka.com/soft/clcl/index_eng.html
2. Run it
3. Copy three snipped plain text from this bug doc or bug 99623
4. Open Writer
5. Check the Right Click context menu in Writer (working)
6. Change the snippet on the clipboard with CLCL by click in the Deskbands in the task bar and click on CLCL icon and pick a different item
7. Repeat 5 -> Probably already disabled.
8. Else repeat it 2/3 times.. with some different content..
Comment 48 Buovjaga 2020-06-26 12:42:15 UTC
(In reply to Nithin from comment #0)
> Description:
> The paste options under, Edit-Paste, Edit-Paste_Special and
> Right_Click-Paste, Right_Click-Paste_Special are deactivated even though
> text is copied to clipboard.
> 
> Steps to Reproduce:
> 1.Clear clip board in your OS. There should not be anything copied into the
> clipboard.
> 2.Open pdf and odt flie.
> 3.Right click at the end of Line One in the odt file
> 4.Paste is active even though nothing is in clipboard(There is nothing to
> paste.)(This is the first bug)(Do click on paste to verify that clipboard is
> really empty)
> 5.Shift to the Pdf file and Copy the text(I did it with Right_click Copy in
> adobe reader).
> 6. Shift back to the odt file. Right click and try pasting the copied
> contents.
> 7. This is Bug2. The options Paste and Paste special are greyed
> out(deactivated). It is however possible to paste using keyboard
> shortcuts(Ctrl+V or Ctrl+Shift+V)

I don't reproduce either bug1 or bug2 with 6.4.4 or master on Win 10. Used InsideClipboard to clear and Adobe Reader for PDF.

I don't think it's good to pile on variations from different reports in this one.

I'm going to put this in needinfo and kindly ask Nithin to test with a fresh master https://dev-builds.libreoffice.org/daily/master/current.html Win-x86_64@tb77-TDF
Comment 49 Timur 2020-06-26 12:53:00 UTC
Buovjaga, did you see Comment 45?
This went more than from reporter and we need to decide on all 3 bugs.
Comment 50 Buovjaga 2020-06-26 12:59:33 UTC
(In reply to Timur from comment #49)
> Buovjaga, did you see Comment 45?
> This went more than from reporter and we need to decide on all 3 bugs.

You want to close Bug 57147, bug 65606, bug 116983?
Comment 51 Timur 2020-06-26 16:59:55 UTC
Bug 57147 (Win), bug 65606 (Win and Lin), bug 90120 (Win), bug 99818 (Lin), bug 116983 (Win) look similar: 
"Paste is sometimes deactivated/greyed in the toolbar and context menu and Paste Special with CTRL+SHIFT+V isn't working. 
Text (from PDF or web) is copied to clipboard and CTRL+V and CTRL+ALT+SHIFT+V are functioning."
There can be differences, though. One reports that even Ctrl+V isn't working.

It's a lot of reports and random behavior, so single reporter with so many duplicates is not relevant per se. 
I think we should wait for 6.4.5.2 and than ask all to upgrade and test and in addition to test daily master. 
And than close with hopeful positive feedback, taking into account Win and Lin and shortcut behavior.
Comment 52 Telesto 2020-06-26 20:44:34 UTC Comment hidden (no-value)
Comment 53 Telesto 2020-06-29 11:19:37 UTC
@b
The whole copy/paste disabled issue is spread around some bug reports :-(
Would you mind testing comment 47 and/or this one:


Have two instances of LibreOffice; run them in parallel (ideally 2x master or b2 or something like that. Else the internal clipboard will be used.. but the problem is with the 'external' system clipboard. 

1. Open attachment 141323 [details] in instance A
2. Insert a comment -> Add some text: say "AAA BBB CCC"
3. Select "AAA' with the mouse
4. Right click -> Copy
5. Go to second instance (B) -> Right click paste -> Working
6. Repeat 3-5 (3x).. Paste should be disabled.. (maybe changing the selection to BBB)
Comment 54 b. 2020-06-29 22:00:53 UTC
(In reply to Telesto from comment #53)
> @b
> The whole copy/paste disabled issue is spread around some bug reports :-(

it's old and it's nasty :-( :-( :-(

but it should be eradicated shortly as it's severely undermining LO's 'user experience' ... "what is this program, can not copy and paste?" 

A.) > Would you mind testing comment 47 

afaics that's installing some helper program, i don't see any sense in that, on the one hand libreoffice should first learn to handle the normal clipboard, and then you never know after such installations whether malfunctions on the computer are caused by this installation or by remnants of it ... 

B.) > and/or this one:
> 
> Have two instances of LibreOffice; run them in parallel (ideally 2x master
> or b2 or something like that. Else the internal clipboard will be used.. but
> the problem is with the 'external' system clipboard. 
> 
> 1. Open attachment 141323 [details] in instance A
> 2. Insert a comment -> Add some text: say "AAA BBB CCC"
> 3. Select "AAA' with the mouse
> 4. Right click -> Copy
> 5. Go to second instance (B) -> Right click paste -> Working
> 6. Repeat 3-5 (3x).. Paste should be disabled.. (maybe changing the
> selection to BBB)

tried it, had much fun, 'copy' in right click menu for text in comment not available, used strg-c for it, worked fine besides paste in writer got a paragraph mark added after every 'AAA' 'BBB' or 'CCC', also tried from 'AAA BBB CCC' added as text on the sheet, 'AAA' was pasted as ' AAA' - with an additional space in front, same for 'BBB' but not for 'CCC' ... please do NOT! ask if i accidentally had a space included in the copy source ... did some dozen copies, pastes and paste specials, no problems except the formatting shortcomings described. imho they are a hint for confused code. 

C.) regarding 'internal' and 'external' clipboard i tried something further, as this bug description asked to 'empty clipboard' before repro-test i looked for something to do this / check clipboard content, tried a little utility 'insideclipboard' and had the following fun copying from opera - heise newsticker to writer: 

- sometimes - i think it was with writer 6.3.6.1 - on copy of a headline insideclipboard was emptied, but i could paste in writer (forgot to test if paste in other prog. would work), 

- reproducibly the copy (ctrl-c) and then paste (ctrl-v) of a headline to writer 7.1 was pasted 'in color' (light blue) on the first try (newly marking a headline), and in 'grey' if i reactivated the opera window with the still marked headline, pressed ctrl-c without any other action on that window, changed to writer and pasted, 

- and just now did a short recheck, on the eleventh copy - paste of alternating a newly marked headline and a repetition of it in grey neither paste nor paste special work ... 

- and subsequent opened writer 6.3.6.1, copied a fresh marked headline and pasted it, coloured but 'insideclipboard' shows clipboard as empty, subsequent copy of the same marked headline fills insideclipboard with content and pastes in grey into writer, 

assumption ... from behaviour and snippets here and there in bugs ... there are more than one procedure for 'clipboarding', 'external' (normal windows) and 'internal' (invented because 'standard' couldn't fullfill all of LO's requirements?) and they work in competition, or sometimes 'race condition', and results are unpredictable as no programmer or user can decide which wins which part of the cake at what time? ... just an assumption, sorry @Eike, 

regarding exact this bug: 

> 1.Clear clip board in your OS. There should not be anything copied into the clipboard.
did with 'insideclipboard', 
> 2.Open pdf and odt flie.
opened 'files', 
> 3.Right click at the end of Line One in the odt file
> 4.Paste is active even though nothing is in clipboard(There is nothing to 
> paste.)(This is the first bug)(Do click on paste to verify that clipboard is 
> really empty)
norepro, paste options grey, 
> 5.Shift to the Pdf file and Copy the text(I did it with Right_click Copy in 
> adobe reader).
ok, 
> 6. Shift back to the odt file. Right click and try pasting the copied 
> contents.
> 7. This is Bug2. The options Paste and Paste special are greyed 
> out(deactivated). It is however possible to paste using keyboard 
> shortcuts(Ctrl+V or Ctrl+Shift+V)
repro! 

setting 'new' as at least a part of this flavour of bug remains, 

with ver: 
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 006c65bbd472cb1d7d44e095714e28190b76be0d
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

and a last recheck ... having only writer 7.1 open for the test from OP worked fine longer than i liked to invest time, opening writer 6.3.6.1 in parallel brought both error conditions (clipboard empty, paste works, clipboard filled, paste grey) in both writer ver. after short time ... 

and the very last: only writer 7.1, first try to paste copy from adobe doesn't work with any option, not even with ctrl-shift-alt-v, 

one armed bandit's are! easier ... 

P.S. consider i lived with theese bugs without taking notice for years! i had some nastinesses sometimes but found a workaround and concentrated back to my normal work, the danger from this bug is tolerable as a user mostly recognizes that something went wrong and corrects it, but ... what a poor picture ... 

just to countercheck win problems i'd run 'sfc /scannow', found some pending renames, restarted system, headline copying from opera - heise newsticker to writer 7.1, four attempts ok, all in colour! :-) , fifth failed :-( , cleared clipboard content, copied again, pasting works ... grey ... 

women are complicated - i love! women, cars are complicated - i love! cars, computers are complicated - i love! computers, one-armed bandits are complicated - i love! one-armed bandits, LibreOffice is ... let's talk about something else ... 

@Timur: 'So I also conclude there's a bug, but we don't have reliable steps.' ... we neither have a reliable program ... and it's a little overtuned to expect reliable fails from an unreliable program ...
Comment 55 Telesto 2020-07-14 19:02:08 UTC
Created attachment 163026 [details]
Inside Clipboard file

1. Download https://www.nirsoft.net/utils/insideclipboard.zip
2. Download the attached file
3. Open Inside Clipboard 
4. File -> Clear all clipboard data (Inside Clipboard )
5. Launch Writer
6. Right Click in side the document -> Disabled -> Fine
7. File -> Load .CLP -> attached file
8. Right click inside the Writer document -> Paste enabled (fine)
9. File -> Clear all clipboard data (Inside Clipboard )
10. Right Click in side the document -> Disabled -> Fine
11. File -> Load .CLP -> attached file
12 Right click inside the Writer document -> Paste enabled (fine)
13 File -> Clear all clipboard data (Inside Clipboard) 
14. File -> Load .CLP -> attached file
15 Right click inside the Writer document -> Paste disabled(wrong)

-> Sometimes it happens on the second time already
Comment 56 b. 2020-07-15 20:44:46 UTC
hello @Telesto, 

i tried to rework your recipe, with 6.1.6.3 you get a very strange file with a lot of ASCII garbage, sample: 

'MCS0/#####TABELA DE DESEMPENHO RF
Potˆncia de transmissÆo m xima (dBm)'

not the AAA BBB CCC DDD i expected, with 7.1.0.0.a0+ - which is the only which makes sense to test - i get: 

'The file 'ABCD.clp' is corrupt and therefore cannot be opened. LibreOfficeDev 7.1.0.0.a0 2020-07-10 can try to repair the file.

The corruption could be the result of document manipulation or of structural document damage due to data transmission.

We recommend that you do not trust the content of the repaired document.
Execution of macros is disabled for this document.

Should LibreOfficeDev 7.1.0.0.a0 2020-07-10 repair the file?'

and after clicking 'yes': 

'The file 'ABCD.clp' could not be repaired and therefore cannot be opened.' 

'it will get worse before it gets better'? or

'don't think you're at rock bottom, there is always a way further down.'?
Comment 57 Buovjaga 2020-07-15 20:47:34 UTC
(In reply to b. from comment #56)
> hello @Telesto, 
> 
> i tried to rework your recipe, with 6.1.6.3 you get a very strange file with
> a lot of ASCII garbage, sample: 
> 
> 'MCS0/#####TABELA DE DESEMPENHO RF
> Potˆncia de transmissÆo m xima (dBm)'
> 
> not the AAA BBB CCC DDD i expected, with 7.1.0.0.a0+ - which is the only
> which makes sense to test - i get: 
> 
> 'The file 'ABCD.clp' is corrupt and therefore cannot be opened.
> LibreOfficeDev 7.1.0.0.a0 2020-07-10 can try to repair the file.

You are supposed to open the .clp file with Inside Clipboard, not LibreOffice.
Comment 58 b. 2020-07-18 17:35:09 UTC
(In reply to @Buovjaga from comment #57)
 
> You are supposed to open the .clp file with Inside Clipboard, not
> LibreOffice.

*ROFL*, how could i have been that stupid ... *LOL*, thanks, you made my day ... 

for the records: nice reproducibility! 

(small hope, may be the receipt wasn't 120% accurate ... but even if ... nice error *lol*)
Comment 59 Telesto 2020-07-18 18:09:19 UTC
@Mike Kaganski
Any change to get you so crazy to look as this :-). It appears we have reproducer; finally (comment 55). A nasty one to track down; 

Paste is sometimes disabled (under Windows). Not over the full line, but only for 'active documents'. So paste not working in a open writer document. However it works fine in a new document. 

This is lovely thing is already happening since 3.3.0. And I hope it's related to/ also causing the 'pasting' prior content bug. Because the paste is stopped working once, it often bit odd on sub-sequential copy/paste before normal function is restored. 

Anyhow, paste / Paste RTF being disabled frustrating enough and enough reports about it.