Bug 133975 - Empty page inserted on file open (re-occurrence of an old bug)
Summary: Empty page inserted on file open (re-occurrence of an old bug)
Status: RESOLVED DUPLICATE of bug 134298
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Additional-Blank-Pages
  Show dependency treegraph
 
Reported: 2020-06-14 08:00 UTC by Telesto
Modified: 2021-04-14 19:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Bibisect log (2.74 KB, text/plain)
2020-06-14 08:02 UTC, Telesto
Details
Bibisect log (4.14 KB, text/plain)
2020-06-14 09:27 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-14 08:00:05 UTC
Description:
Empty page inserted on file open (re-occurrence of an old bug)

Steps to Reproduce:
1. Open attachment 125603 [details] bug 95595
2. Shows 19 pages (with an empty page on page 15).. Should 18 pages.. without the empty page

Actual Results:
19 pages; with empty page

Expected Results:
18 pages without empty page


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: a201ab6f47c2d5a7ba4c5f998b0aa231cae82010
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-06-14 08:02:12 UTC Comment hidden (obsolete)
Comment 2 Telesto 2020-06-14 08:33:51 UTC
Also in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

using multi page view
Comment 3 Telesto 2020-06-14 09:27:05 UTC
Created attachment 161980 [details]
Bibisect log

And now  the real culprit.. Bisected to
author	Oliver-Rainer Wittmann <orw@apache.org>	2014-07-15 12:15:37 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2014-07-16 09:01:02 +0100
commit 133d6d8d4dec497276c3a9b0ba6761cffd322f81 (patch)
tree 26282ae68d27e44ff6bf7ad22023272cf4d1bf54
parent 7dd5f9308895644ae6ece56253c892046cc6ed5e (diff)
Resolves: #i121443# register text frames and graphics...
on the correct page frame

- trigger formatting of selected object when moving view to the selected object
or when graphical horizontal line has been inserted.

(cherry picked from commit 82fafc47de0c59c783c5df596c976a429ff8a21d)

Conflicts:
	sw/source/core/frmedt/feshview.cxx
	sw/source/core/layout/fly.cxx
	sw/source/ui/shells/textsh.cxx

https://cgit.freedesktop.org/libreoffice/core/commit/?id=133d6d8d4dec497276c3a9b0ba6761cffd322f81
Comment 4 Telesto 2020-06-14 09:38:17 UTC Comment hidden (obsolete)
Comment 5 Telesto 2020-06-14 09:39:09 UTC Comment hidden (obsolete)
Comment 6 Telesto 2020-06-14 10:07:00 UTC
FWIW; additional blank pages also appear undoing resizing of an image the the bug doc (see bug 133979; inherited). Not sure if comment 3 is affected by it somehow
Comment 7 Buovjaga 2020-07-04 15:07:41 UTC
Confirmed

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 777f9cec0985f99451ecb804d5ae139a0be32253
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 4 July 2020
Comment 8 Xisco Faulí 2021-04-14 18:57:16 UTC
No longer reproducible in

Version: 7.1.2.2 (x86) / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: es-ES
Calc: threaded

nor in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: a199e4ea389c934d169a178433f4b94033e60f93
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Closing as RESOLVED WORKSFORME
Comment 9 Xisco Faulí 2021-04-14 19:04:54 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9ef71476fd70bc13f50ebe80390e0730d1b7afb
Closing as duplicate of bug 134298

*** This bug has been marked as a duplicate of bug 134298 ***