Bug 137938 - FILEOPEN DOCX: Very very slow
Summary: FILEOPEN DOCX: Very very slow
Status: RESOLVED DUPLICATE of bug 120351
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, perf, regression
Depends on:
Blocks:
 
Reported: 2020-11-02 16:18 UTC by Telesto
Modified: 2021-02-19 19:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX with LibreOffice 7.1 Alpha 30 oct 2020 (989.77 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-11-02 16:29 UTC, Telesto
Details
Bibisect log Saxparse (3.66 KB, text/plain)
2020-11-03 07:26 UTC, Telesto
Details
Bibisect log (701 bytes, text/plain)
2020-11-03 07:50 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-11-02 16:18:00 UTC
Description:
FILEOPEN DOCX: Very very slow

Steps to Reproduce:
1. Open attachment 127161 [details] (bug 122894)
2. Export to DOCX -> Kind of slow.. but working (crashing with 4.4.7.2)
3. File -> Reload -> Hang/slow

Actual Results:
Waited 90 seconds.. and quite

Expected Results:
File should open


Reproducible: Always


User Profile Reset: No



Additional Info:
Found 7.1
Comment 1 Telesto 2020-11-02 16:19:47 UTC
They Export DOCX can be opened with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 2 Telesto 2020-11-02 16:23:36 UTC
Also in
5.4 alpha
Comment 3 Telesto 2020-11-02 16:28:58 UTC
Also found in LibreOffice
5.1

LibreOffice 5.0.2 throws saxparse exception

File format error found at unsatisfied query for interface of type com.sun.star.lang.XComponent!
SAXParseException: '[word/endnotes.xml line 2]: unknown error', Stream 'word/endnotes.xml', Line 2, Column 21394
SAXParseException: '[word/document.xml line 2]: unknown error', Stream 'word/document.xml', Line 2, Column 115746(row,col)
Comment 4 Telesto 2020-11-02 16:29:32 UTC
Created attachment 166950 [details]
DOCX with LibreOffice 7.1 Alpha 30 oct 2020
Comment 5 Telesto 2020-11-03 07:26:08 UTC
Created attachment 166960 [details]
Bibisect log Saxparse

The SAXParse error being introduced with 

author	Michael Stahl <mstahl@redhat.com>	2015-01-22 12:50:07 +0100
committer	Michael Stahl <mstahl@redhat.com>	2015-01-22 13:58:10 +0100
commit	ebf767eeb2a169ba533e1b2ffccf16f41d95df35 (patch)
tree	81946ae1fdee22ebf6f2543d0a965304528205f7
parent	825e4995220209362c13ed5f07c98e43a5f456de (diff)
writerfilter: DOCX import: better error handling than "catch (...) {}"
If there is a SAXParseException, OOXMLDocumentImpl::resolve() should not
ignore it, because if it occurs in a substream some end tag handlers may
not have been run and the DomainMapper may be in an inconsistent state,
so continuing to parse the outer document is probably not a good idea.

Also add some exception mangling so sfx2 can present a useful error
dialog.

before they file could be opened fast (but probably lacking number of pages)
https://cgit.freedesktop.org/libreoffice/core/commit/?id=ebf767eeb2a169ba533e1b2ffccf16f41d95df35
Comment 6 Telesto 2020-11-03 07:50:07 UTC
Created attachment 166961 [details]
Bibisect log

Saxparse exception disappeared and becoming slow (as far I can tell) with
author	Oliver-Rainer Wittmann <orw@apache.org>	2014-07-15 12:15:37 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2014-07-16 09:01:02 +0100
commit	133d6d8d4dec497276c3a9b0ba6761cffd322f81 (patch)
tree	26282ae68d27e44ff6bf7ad22023272cf4d1bf54
parent	7dd5f9308895644ae6ece56253c892046cc6ed5e (diff)
Resolves: #i121443# register text frames and graphics...
on the correct page frame

- trigger formatting of selected object when moving view to the selected object
or when graphical horizontal line has been inserted.

(cherry picked from commit 82fafc47de0c59c783c5df596c976a429ff8a21d)

Conflicts:
	sw/source/core/frmedt/feshview.cxx
	sw/source/core/layout/fly.cxx
	sw/source/ui/shells/textsh.cxx

https://cgit.freedesktop.org/libreoffice/core/commit/?id=133d6d8d4dec497276c3a9b0ba6761cffd322f81
Comment 7 Dieter 2020-11-18 08:44:24 UTC
I even can't save as docx; LO hangs (version 7.0.3.1)

Document contains macros. So my question is, are you sure, that the macros don't trigger the problem you describe? What happens without the makro? I'm not sure, but I don't think that it is our task to make every makro work.
Comment 8 Xisco Faulí 2021-02-15 18:03:08 UTC
Hi Telesto,
Could you please try to reproduce it with a master build from
http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the master build
Comment 9 Xisco Faulí 2021-02-19 19:16:45 UTC
import time goes from 1m50,408s to 0m32,519s after https://git.libreoffice.org/core/commit/7dd8f8aace536a8e60e87e61ee1d90d61fba15eb. Closing as dupe of bug 120351

*** This bug has been marked as a duplicate of bug 120351 ***