Download it now!
Bug 132678 - Crash running mail merge wizard for doc from tdf#119942
Summary: Crash running mail merge wizard for doc from tdf#119942
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Mail-Merge 119942 Crash
  Show dependency treegraph
 
Reported: 2020-05-04 13:25 UTC by Michael Weghorn
Modified: 2020-06-24 11:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2020-05-04 13:25:29 UTC
Description:
LibreOffice crashes after running the mail merge wizard for the doc attached to tdf#119942.

Steps to Reproduce:
1. open attachment 144966 [details] from bug 119942
2. run mail merge wizard, e.g. using the sample data from attachment 144965 [details] (also from bug 119942) (leave default values, don't insert an address block)
3. at the end of the wizard, click "Finish"

Actual Results:
LibreOffice crashes

Expected Results:
LibreOffice doesn't crash and shows the mail merge toolbar.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.0.0.0.alpha0+
Build ID: 934fd1c617d1f7fba90f922bf2d526ea3f35f9b7
CPU threads: 4; OS: Linux 5.5; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Michael Weghorn 2020-05-04 13:28:06 UTC
Bibisecting using the bibisect-linux-6.4 repo indicates that this happens since

    commit 8c66efa030e98cfdf5da20be368566d64e43c5d1
    Author: Caolán McNamara <caolanm@redhat.com>
    Date:   Thu Sep 5 12:22:38 2019 +0100

        weld OCopyTableWizard cluster
        
        Change-Id: I52547defb0e7ba328ec20d41a955e545556ffd16
        note: get the toplevel parent by getting it from the XInteractionHandler
        Reviewed-on: https://gerrit.libreoffice.org/78751
        Tested-by: Jenkins
        Reviewed-by: Caolán McNamara <caolanm@redhat.com>
        Tested-by: Caolán McNamara <caolanm@redhat.com>

Adding CC: to Caolán McNamara
Comment 2 Xisco Faulí 2020-05-04 13:59:37 UTC
Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: 800085d4fb0831f2065e86bfd99164cd89998fcd
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

but not with gtk3
Comment 3 Caolán McNamara 2020-05-06 20:29:59 UTC
seems to be an unhandled exception from pDocShell->GetStorage()->removeElement(m_pDBManager->getEmbeddedName()); on teardown of SwOneExampleFrame::~SwOneExampleFrame in DisposeControl. Though why its just in gen needs a look
Comment 4 Commit Notification 2020-05-07 13:22:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/403776b17706107001d49cf5eed3c4415c4d8b9d

Related: tdf#132678 select first entry if nothing else selected

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-05-19 08:10:33 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/1f31f36fb92befc66f507d45f8a020f89f49e93b

Related: tdf#132678 select first entry if nothing else selected

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-05-20 13:41:53 UTC
Hi Caolán,
The crash is still reproducible in

Version: 7.0.0.0.alpha1+
Build ID: 8209c2569f5726f9ed29f75d30efdccb94f98fe5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc:
Comment 7 Caolán McNamara 2020-05-20 16:19:05 UTC
I haven't claimed otherwise
Comment 8 BogdanB 2020-06-22 20:13:11 UTC
No problem in
Version: 7.1.0.0.alpha0+
Build ID: a3c8ea5e644ca2fc04de9f01ba9f8ace47f520f0
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-17_02:21:20
Calc: threaded
Comment 9 Michael Weghorn 2020-06-24 08:03:23 UTC
Can't reproduce anymore either:

Version: 7.1.0.0.alpha0+
Build ID: 526c4bd5dbe0225a1ff14ff1e7fe32151ab7d29d
CPU threads: 4; OS: Linux 5.6; UI render: default; VCL: x11
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

-> closing as WORKSFORME
Comment 10 Xisco Faulí 2020-06-24 09:25:36 UTC
(In reply to Xisco Faulí from comment #6)
> Hi Caolán,
> The crash is still reproducible in
> 
> Version: 7.0.0.0.alpha1+
> Build ID: 8209c2569f5726f9ed29f75d30efdccb94f98fe5
> CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc:

I can't even reproduce it with the same commit I reproduce it in the past

Version: 7.0.0.0.alpha1+
Build ID: 8209c2569f5726f9ed29f75d30efdccb94f98fe5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

weird...
Comment 11 Caolán McNamara 2020-06-24 11:59:34 UTC
maybe it was the case that you had to do it twice in a row ?