Bug 132819 - Anchoring the anchor to a different character also changes shape position
Summary: Anchoring the anchor to a different character also changes shape position
Status: RESOLVED DUPLICATE of bug 144611
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2020-05-07 14:42 UTC by Telesto
Modified: 2021-10-06 14:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-07 14:42:26 UTC
Description:
Changing anchor to character position changes shape position 

Steps to Reproduce:
1. Open the attachment 160505 [details]
2. Click the image
3. Grab the anchor an drop at different places.. shapes moves

Closely related to bug 132818

Actual Results:
Shape moves when anchoring position changes

Expected Results:
Not an expert on anchoring.. I tend to think.. Anchor is the position where the image is fixed to. When it jump to different page etc.. and unrelated to the position.. So position stays the same on change of the anchoring position.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc:
Comment 1 Buovjaga 2020-08-31 17:28:56 UTC
In your steps there is no "change anchor to 'To character'". Is this intentional?
The shape upon opening is anchored To paragraph.
Comment 2 Telesto 2020-08-31 20:30:09 UTC
(In reply to Buovjaga from comment #1)
> In your steps there is no "change anchor to 'To character'". Is this
> intentional?
> The shape upon opening is anchored To paragraph.

The bug title wasn't to obvious. It's more a technical question.  Should moving the anchor change the image position too, or not.

You can move the image with arrow keys, without any change to the anchor. However change the anchor position does change the image position.

Say you only want to change the anchor position (default is to character nowdays). This will always affect the image position. This might be frustrating. So after changing the anchor, you have to re-position the image.

As long as you simple drag & drop the image the anchor will go all over the place. So setting a specific anchor position nearly pointless. 

So this s more a in principle discussion. How it is supposed to be in the grand design.
Comment 3 Telesto 2020-08-31 20:49:45 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2020-09-01 16:07:31 UTC
(In reply to Telesto from comment #3)
> See for a sample case where this matters for example: bug 132819

bug 132819 is this report itself.
Comment 5 Telesto 2020-09-01 17:36:56 UTC
(In reply to Buovjaga from comment #4)
> (In reply to Telesto from comment #3)
> > See for a sample case where this matters for example: bug 132819
> 
> bug 132819 is this report itself.

LOL, a circular reference ;-). Should be bug 136343 (see also)
Comment 6 Dieter 2021-09-09 13:44:03 UTC Comment hidden (spam)
Comment 7 Justin L 2021-10-06 13:34:52 UTC
(In reply to Telesto from comment #2)
> Should moving the anchor change the image position too, or not.

Of course it should in this example. The rest of the settings give locations relative to the paragraph or margin.

If you change those settings to be relative to the page, then of course it won't move around with the anchor (unless you drag to a different page).
Comment 8 Telesto 2021-10-06 14:33:51 UTC

*** This bug has been marked as a duplicate of bug 144611 ***