Bug 132871 - Text in LO brand logo truncated in About LibreOffice dialog
Summary: Text in LO brand logo truncated in About LibreOffice dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks: About-Dialog 130778
  Show dependency treegraph
 
Reported: 2020-05-09 14:23 UTC by Ming Hua
Modified: 2020-05-31 23:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of About LibreOffice dialog (92.94 KB, image/png)
2020-05-09 14:23 UTC, Ming Hua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ming Hua 2020-05-09 14:23:29 UTC
Created attachment 160555 [details]
Screenshot of About LibreOffice dialog

Maybe this should be a follow-up to bug 132180, but that one is marked as FIXED, so I'm reporting a new one.

On Windows 10 with 7.0.0 Alpha1, in the "About LibreOfficeDev" dialog, the text "The Document Foundation" at the bottom of the brand logo is truncated.  See attahced screenshot.  It seems my system is not using the correct font for the logo SVG?
Comment 1 Heiko Tietze 2020-05-10 05:54:07 UTC
It's not a follow-up since the whole image was stretched before. The issue affects only the text.

[1] <text style="..." style="-inkscape-font-specification:'Vegur, Normal';... font-family="Vegur">The Document Foundation</tspan></text>

Tomaz, any idea why this happens? The SVG image fits perfectly with Inkscape or GIMP. But maybe it requires Vegur to be installed.

[1] https://opengrok.libreoffice.org/xref/core/icon-themes/colibre/brand/shell/logo.svg
Comment 2 Buovjaga 2020-05-11 10:25:06 UTC
(In reply to Heiko Tietze from comment #1)
> It's not a follow-up since the whole image was stretched before. The issue
> affects only the text.
> 
> [1] <text style="..." style="-inkscape-font-specification:'Vegur,
> Normal';... font-family="Vegur">The Document Foundation</tspan></text>
> 
> Tomaz, any idea why this happens? The SVG image fits perfectly with Inkscape
> or GIMP. But maybe it requires Vegur to be installed.
> 
> [1]
> https://opengrok.libreoffice.org/xref/core/icon-themes/colibre/brand/shell/
> logo.svg

Heiko: why not convert the text to path? I don't see a reason to keep it as <text> element. I mean, the only reason would be accessibility, but I think it is irrelevant in this case.
Comment 3 Heiko Tietze 2020-05-11 10:41:26 UTC
(In reply to Buovjaga from comment #2)
> Heiko: why not convert the text to path? I don't see a reason to keep it as
> <text> element. I mean, the only reason would be accessibility, but I think
> it is irrelevant in this case.

Sure, that's a workaround. I'd like to get confirmation first as this issue wasn't reported before.
Comment 4 Buovjaga 2020-05-11 10:59:01 UTC
(In reply to Heiko Tietze from comment #3)
> (In reply to Buovjaga from comment #2)
> > Heiko: why not convert the text to path? I don't see a reason to keep it as
> > <text> element. I mean, the only reason would be accessibility, but I think
> > it is irrelevant in this case.
> 
> Sure, that's a workaround. I'd like to get confirmation first as this issue
> wasn't reported before.

Well, I guess the issue itself is interesting, but I would not call it a workaround to convert the text to path. To me it seems like the thing you absolutely need to be doing. Why would we serve the users an incorrect logo, if they don't have this exotic font installed?
Comment 5 Commit Notification 2020-05-14 13:20:41 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/20b3c706ccef238171af41daa7add2c6f80934fb

Resolves tdf#132871 - Truncated text in brand image

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Ming Hua 2020-05-29 19:58:17 UTC
Verified in 7.0.0 beta1.  Thanks Heiko!
Comment 7 Ming Hua 2020-05-31 23:12:58 UTC
*** Bug 133544 has been marked as a duplicate of this bug. ***