Download it now!
Bug 130778 - Branding for 7.0
Summary: Branding for 7.0
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords: needsUXEval
Depends on: 133024 133199 132701 132871
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2020-02-19 16:54 UTC by Bayu Rizaldhan Rayes
Modified: 2020-05-20 16:58 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice 7.0 Logo Proposals (3.86 MB, application/pdf)
2020-03-01 21:33 UTC, jackandmixers
Details
LibreOffice7 Splash, About, Mac OS (74.90 KB, application/pdf)
2020-03-03 19:01 UTC, jackandmixers
Details
Screenshot of LO by TDF on Linux (59.39 KB, image/png)
2020-04-17 14:25 UTC, Mike Kaganski
Details
Start Center art 5, 6 & 7 (360.51 KB, image/png)
2020-04-17 14:30 UTC, V Stuart Foote
Details
Startcenter's cornucopia at 400px (222.23 KB, image/png)
2020-04-20 13:55 UTC, Heiko Tietze
Details
Grayscaled image (46.20 KB, image/jpeg)
2020-04-20 17:24 UTC, Rizal Muttaqin
Details
Today's splash screen (110.49 KB, image/png)
2020-04-22 08:18 UTC, Mike Kaganski
Details
Splash screen sources (115.69 KB, application/zip)
2020-04-22 08:55 UTC, Heiko Tietze
Details
installer packaging will need new 7 artwork (27.49 KB, image/png)
2020-04-23 16:20 UTC, V Stuart Foote
Details
macOS installer dialog proposal (92.23 KB, application/zip)
2020-04-23 22:51 UTC, Rizal Muttaqin
Details
Sifr version (169.54 KB, image/png)
2020-05-10 18:40 UTC, BogdanB
Details
About Dialog with splash schreen image (1.10 MB, image/png)
2020-05-13 13:00 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bayu Rizaldhan Rayes 2020-02-19 16:54:11 UTC
Description:
Hi, I'd like to submit design proposition for Libre office 7 about dialog. 
This is still work in progress, but might already shown the idea.

It would be great if you can give feedback whether this concept suit or aligned with LibreOffice brand. Whether i should continue to polish it more.

The concept showing elements in libre office icons set, colors and general office productivity stuff in isometric style.

The initial inspiration is from illustration like in editorial, book cover or late 90s boxed software, but with more modern style.

Please see image in this url.
https://raw.githubusercontent.com/bayubayu/opensource-design/master/proposition1.jpg

Vector done in Inkscape. Sketch in photoshop.
other font used in this concept: Quicksand by Andrew Paglinawan (OFL).

Thanks
Bayu R

Steps to Reproduce:
1.Please see image below https://raw.githubusercontent.com/bayubayu/opensource-design/master/proposition1.jpg

Actual Results:
N/A

Expected Results:
N/A


Reproducible: Always


User Profile Reset: No



Additional Info:
N/A
Comment 1 andreas_k 2020-02-19 19:33:10 UTC
Like it.

I prefer the alternative image with the big 7.
Comment 2 Roman Kuznetsov 2020-02-20 09:56:42 UTC
I like left image in middle row

Thanks for very nice proposals!
Comment 3 Heiko Tietze 2020-02-20 14:44:42 UTC
Thanks a lot for this great proposal. I love to read concepts and not just the final artwork. What you write makes a lot of sense and I can easily follow the idea of streaming everything around office into the TDF's paperclip logo. To some extend I see also the swatch [1] being represented, at least the colors are greenish. We could also update the color swatch (it's on my todo list anyway). Or, if you want to play, make the drawing more #18A303-ish. But I'd prefer a new swatch.
Regarding the About dialog we would have to move things around a bit but that's not a big deal. 


However, I would like to open the topic for the whole branding. That is:

* icon-themes/*/brand/intro.png
* icon-themes/*/brand_dev/intro.png
=> splash screen for development and final versions with and without TDF tagline
currently 661 x 169, 8-bit/color RGBA, interlaced

* icon-themes/*/brand/flat_logo.svg
=> image on top of the about box
currently 810 x 133

* icon-themes/*/brand/shell/about.svg
=> background of the about box, empty for 6.x
currently 648 x 667

* instsetoo_native/inc_common/windows/msi_templates/Binary/Banner.bmp
=> image used for the Windows installer progress
PC bitmap, Windows 95/NT4 and newer format, 632 x 57 x 8

* instsetoo_native/inc_common/windows/msi_templates/Binary/Image.bmp
=> image used for the Windows installer first page
Windows BMP image 162 x 312

* setup_native/source/packinfo/osxdndinstall.png
=> image for macOS package
PNG image data, 550 x 443, 8-bit/color RGBA, non-interlaced


Archive for 6.x and 5.x branding is here https://wiki.documentfoundation.org/Marketing/Branding#Releases. For the 6.x version we tried to eat our own dogfood but I think Inkscape is fine. Some proposals are stored here https://wiki.documentfoundation.org/Marketing/Branding/Ideas, in particular Rizal's seven.

[1] https://wiki.documentfoundation.org/Marketing/Branding#Colors
Comment 4 jackandmixers 2020-03-01 21:33:20 UTC
Created attachment 158290 [details]
LibreOffice 7.0 Logo Proposals

Hello all!

Thought I'd throw my hat into the ring also.

Here are some ideas I put together I thought might help market the new version of LibreOffice. Happy to hear feedback. Thank you!
Comment 5 jackandmixers 2020-03-03 19:01:33 UTC
Created attachment 158353 [details]
LibreOffice7 Splash, About, Mac OS

Based on Heiko's feedback, I've created 3 possible new designs for Libre 7.0. These are for the splash page, the about page, and the mac OS startup page, respectively.

Looking forward to any constructive comments. Thank you!
Comment 6 Heiko Tietze 2020-03-04 06:30:04 UTC
(In reply to jackandmixers from comment #5)
> Looking forward to any constructive comments. Thank you!

* I like the pronounced ligature and the superscripted seven.
* The cubes were artwork for version six and don't need to be in the brand anymore.
* The sheered (? there is likely a better word for it) logo looks a bit like a door but the L and the b won't go through it.
* We have branding guidelines [1] that proscribe changes to font type, colors, letter spacing, and modifications to the symbol. That's not carved in stone, or it is but it's sand stone and we can redo this guideline. But is it necessary?

[1] https://wiki.documentfoundation.org/Marketing/Branding#Logos
Comment 7 Heiko Tietze 2020-03-04 06:33:48 UTC
(In reply to Heiko Tietze from comment #3)
> However, I would like to open the topic for the whole branding. That is:
> ...

One is missing.

* icon-themes/*/sfx2/res/logo.png
=> shown at the start center without any recently used documents; PNG image data, 263 x 263, 8-bit/color RGBA, non-interlaced
Comment 8 Rizal Muttaqin 2020-03-14 14:07:18 UTC
When we take decision about this proposal?
Comment 9 Heiko Tietze 2020-03-27 11:42:31 UTC
jackandmixers: Please share the raw content so we can implement your artwork perhaps at the Windows installer. Extracted from the PDF it would be bad quality.
Comment 10 Adolfo Jayme 2020-03-28 07:55:16 UTC
Comment on attachment 158353 [details]
LibreOffice7 Splash, About, Mac OS

This attachment 158353 [details] doesn’t present a high-quality logo IMO.

Also, it violates the branding guidelines (there should be no numbers inside the Document icon). And citing myself for the thousandth time: https://redmine.documentfoundation.org/issues/2905#change-16960
Comment 11 Bayu Rizaldhan Rayes 2020-03-29 17:38:25 UTC
Hi all,

Thanks for previous feedback & guidance. 
Here's latest update on my preposition.
I've updated about box and added new proposition on app icons and splash screen.
Some SVG source files are also published.

## About Box
status: in progress
concept: https://raw.githubusercontent.com/bayubayu/opensource-design/master/about.jpg
SVG: https://github.com/bayubayu/opensource-design/blob/master/libreoffice/libreoffice-about.svg
comment: may need more polish/finishing.

## Intro/splash screen
status: draft/concept
concept: https://raw.githubusercontent.com/bayubayu/opensource-design/master/splash-concept.jpg
comment: waiting for feedback.

## Icons
status: in progress
concept: https://raw.githubusercontent.com/bayubayu/opensource-design/master/icons-concept.jpg
SVG: https://github.com/bayubayu/opensource-design/blob/master/libreoffice/libreoffice-icons.svg
comment: Inspiration is based on recent trend on google material and microsoft fluent design.

## windows installer progress
status: not yet. pending on concept approval on about/splash

## windows installer first page
status: not yet

## OSX installer
status: not yet

## Start center
status: not yet

Please let me know if you have any feedback.

Thanks
Bayu R
Comment 12 Telesto 2020-04-13 22:17:51 UTC
Not sure if I'm supposed comment on the artwork, but related to Intro/splash screen.. 

I like the first and second alternative the most (so yellow 7 and blue 7 variant)
* The yellow is most neutral. 
* Related to your main choice & third ("blue") variant. I'm seeing a formula, chart, base icon. I relate those to Math/Calc/Base. In my perception I'm missing an "impression Writer, Impress, Draw). Not saying it is necessary to have reference to every module. And I don't like the 3D pie chart around the 7.

Thanks for all the effort!
Comment 13 Heiko Tietze 2020-04-14 09:33:44 UTC
(In reply to Telesto from comment #12)
> Not sure if I'm supposed comment on the artwork

Everyone's comment is of course welcome. I also don't like the isometric seven, but  the blue 7 in #3 with some nice flying toasters, meaning memes, is nice. Something for Writer could be fine. 
And last but not least we have people who disagree with the number on versions.

As soon artwork is ready in a usable form (SVG or two PNG with 1000x256 and 661x169px) we can put it live to receive more opinions.
Comment 14 Telesto 2020-04-14 10:34:45 UTC
## About Box
Looks fine; Except for the isometric seven (depending on Intro/splash screen chosen)

## Icons
It's quite hard to tell the difference between the draw & impress icon, IMHO.  And I don't get the 'notebook' icon. Looks nice, but not sure about where to put it (Start Centre shortcut?)
Comment 15 Commit Notification 2020-04-15 15:36:45 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0db34d1c5dd7d06435c5a5d58a42da2cbe007006

Related tdf#130778: New images for splash screen

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-04-15 15:36:53 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9b1c9ac6edcdeae431d6104c586ca7feffbb6483

Related tdf#130778: New About dialog

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Heiko Tietze 2020-04-15 15:40:11 UTC
(In reply to Commit Notification from comment #15)
> https://git.libreoffice.org/core/commit/
> 0db34d1c5dd7d06435c5a5d58a42da2cbe007006
> 
> Related tdf#130778: New images for splash screen

This patch uses a cutout from Bayu's proposal and should be improved. It also misses hi-res variant.

(In reply to Bayu Rizaldhan Rayes from comment #11)
> ## windows installer progress
> status: not yet. pending on concept approval on about/splash
> 
> ## windows installer first page
> status: not yet
> 
> ## OSX installer
> status: not yet

Still pending.
Comment 18 Mike Kaganski 2020-04-17 09:37:31 UTC
New about box (after https://git.libreoffice.org/core/+/9b1c9ac6edcdeae431d6104c586ca7feffbb6483):

1. Tabbing into the information is broken;
2. Selected state on entry into that box is also broken (see https://git.libreoffice.org/core/commit/504d9e75f663497e7ba08ea4124c8a1b06d658ce);
3. The information now is unreadable. Either it must be shortened, and add an option to see complete information (in another dialog?), or make it visible here like before. It is not only useful for people who know what they are doing, but also for novices who open this dialog for the first time when they need to look "which VCL plugin it uses" (because they read on Ask site that they need that, whatever that is), or select and copy to a bug report that they are filling for the first time ever. They don't even have an easy way to know if they have selected it all, or their mouse skipped starting/ending part of the text.
4. There's no link to the commit log. It was useful - both in development versions, and in releases, to answer user questions like "where do I get a full changelog".
Comment 19 Heiko Tietze 2020-04-17 13:40:11 UTC
(In reply to Mike Kaganski from comment #18)
> 1. Tabbing into the information is broken;
> 2. Selected state on entry into that box is also broken

Discussed on IRC. The actual question is accessibility, ie. copy the text per keyboard. I introduced a button for this purpose and made the text non-selectable. See bug 132179 

> 3. The information now is unreadable. 

Addressed in bug 132181 and circumvented by making the text not selectable, I guess.

> 4. There's no link to the commit log. It was useful - both in development
> versions, and in releases, to answer user questions like "where do I get a
> full changelog".

Didn't remove anything, Release Notes are now accessed via link.
Comment 20 Mike Kaganski 2020-04-17 13:50:03 UTC
(In reply to Heiko Tietze from comment #19)
> > 4. There's no link to the commit log. It was useful - both in development
> > versions, and in releases, to answer user questions like "where do I get a
> > full changelog".
> 
> Didn't remove anything, Release Notes are now accessed via link.

Please open a current release (e.g., 6.4), and see the link available in the About box. Click it, and see where it goes. Then try to find *the same* link in the new dialog.

Please note that while Release Notes is a good addition, it does not replace the link to the verbose change history - both for devs, *and* for users who ask for full change log.
Comment 21 Heiko Tietze 2020-04-17 14:02:38 UTC
(In reply to Mike Kaganski from comment #20)
> Please open a current release...

Apparently it depends on the OS. See https://imgur.com/a/qwiizL9 for Linux.
Comment 22 Mike Kaganski 2020-04-17 14:25:26 UTC
Created attachment 159661 [details]
Screenshot of LO by TDF on Linux

(In reply to Heiko Tietze from comment #21)
> Apparently it depends on the OS. See https://imgur.com/a/qwiizL9 for Linux.

Rather on branding. Current dialog allows branding to define the link (or remove it); you broke that.

Arch Linux does not provide the link in its repo version; so does Ubuntu. But here's the version from TDF bibisect repo on Linux.
Comment 23 V Stuart Foote 2020-04-17 14:30:00 UTC
Created attachment 159662 [details]
Start Center art 5, 6 & 7

(In reply to Commit Notification from comment #15)
> Heiko Tietze committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/core/commit/
> 0db34d1c5dd7d06435c5a5d58a42da2cbe007006
> 
> Related tdf#130778: New images for splash screen
> 
> It will be available in 7.0.0.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

So the new "cornucopia" artwork ends up oversize and rather busy on the empty Start Center, a bit radical compared to the clean lines of the LO 6 and 5 releases which are 

Although its visibility is transient (i.e. once documents are present, it is hidden) the artwork is flawed on screen and has an annoying white edging showing on round and rectangle. That edge needs to be cleaned up (taken into the grays) if we are keeping this motif for the Start Center and About dialog.
Comment 24 V Stuart Foote 2020-04-17 14:32:06 UTC
(In reply to V Stuart Foote from comment #23)
> and 5 releases which are 

... better scaled.
Comment 25 Heiko Tietze 2020-04-20 13:11:15 UTC
(In reply to Mike Kaganski from comment #22)
> But here's the version from TDF bibisect repo on Linux.

We could add one more link. Do we need this access to the log?

(In reply to V Stuart Foote from comment #23)
> So the new "cornucopia" artwork ends up oversize and rather busy on the
> empty Start Center

I politely disagree, the start center was boringly empty in previous releases. But open for more opinions - we can scale the SVG to any size.
Comment 26 V Stuart Foote 2020-04-20 13:15:45 UTC
(In reply to Heiko Tietze from comment #25)
> 
> I politely disagree, the start center was boringly empty in previous
> releases. But open for more opinions - we can scale the SVG to any size.

OK, reduce SVG scale about 25%?
Comment 27 Heiko Tietze 2020-04-20 13:55:57 UTC
Created attachment 159761 [details]
Startcenter's cornucopia at 400px

(In reply to V Stuart Foote from comment #26)
> OK, reduce SVG scale about 25%?

Better? Could also scale the image depending on the initial size.
Comment 28 V Stuart Foote 2020-04-20 14:11:49 UTC
(In reply to Heiko Tietze from comment #27)
> Created attachment 159761 [details]
> Startcenter's cornucopia at 400px
> 
> (In reply to V Stuart Foote from comment #26)
> > OK, reduce SVG scale about 25%?
> 
> Better? Could also scale the image depending on the initial size.

Yes, that is more reasonable--now fits between the "a" in Drop a, and the "e" in create one.  

Scaling when resizing StartCenter might be visually appealing. Currently while the welcome text wraps, we just clip the graphic when reducing StartCenter width.  Expect we would start to scale once the Welcome/MRU pane width reaches width of artwork--shrink it from there as text continues its wrap.
Comment 29 Heiko Tietze 2020-04-20 15:08:17 UTC
(In reply to V Stuart Foote from comment #28)
> Scaling when resizing StartCenter...

Nope, what I meant is only once when the window is created. The image is an SVG and it takes some time to read and convert so on-the-fly is not possible other than using raster image methods. 

The point of changing the size initially is that people use different sizes depending on screen size, resolution, and personal preference. 400px is a sane average but if you run 4k displays just some flyspeck.
Comment 30 Heiko Tietze 2020-04-20 15:54:24 UTC
(In reply to Heiko Tietze from comment #29)
> ...changing the size initially...

Was too curious and did this with the upcoming splash screen patch. The start center image is now 50% the size of the recent documents list, either width or height if smaller.
Comment 31 Rizal Muttaqin 2020-04-20 17:24:31 UTC
Created attachment 159767 [details]
Grayscaled image

How if we ommit the color?
Comment 32 Commit Notification 2020-04-21 15:06:02 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/951b7eef8894bce7f119ecc0123c7e37fe6b4b4f

Relates tdf#130778 - Branding for 7.0

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 33 Mike Kaganski 2020-04-22 08:18:28 UTC
Created attachment 159805 [details]
Today's splash screen

It shows the dark background; dark status text on that background; and displacement of status text. These are problems (the dark background is possibly a matter of taste, but IMO it doesn't fit well into the branding).

I had been told by Heiko that the background is different for "dev" vs "non-dev" builds; I believe that this is a problem on its own. Please don't introduce differences between "dev"/"non-dev" builds (whatever that could mean) unless absolutely necessary. When the difference allows devs to see some info easily, where user needs not that, the difference is justified; in other cases, it only disallows me to see and reports problems that users will only see in builds that I don't use.
Comment 34 Heiko Tietze 2020-04-22 08:55:07 UTC
Created attachment 159807 [details]
Splash screen sources

SVG sources for the splash screen kindly provided by Muhammad Rivan (based on the work by Bayu, I presume)
Comment 35 V Stuart Foote 2020-04-23 16:20:57 UTC
Created attachment 159866 [details]
installer packaging will need new 7 artwork

@Heiko, *

Noticed when installing today's TB77 build of master for Windows, that the installer has artwork needing refresh as well.

Clip attached.
Comment 36 Rizal Muttaqin 2020-04-23 22:51:37 UTC
Created attachment 159879 [details]
macOS installer dialog proposal

Here my proposal for macOS installer dialog
Comment 37 Heiko Tietze 2020-04-24 06:49:11 UTC
(In reply to Rizal Muttaqin from comment #36)
> Here my proposal for macOS installer dialog

Looks like a vote for dark background :-).
Will submit together with the Windows installer.
Comment 38 Telesto 2020-04-28 18:05:51 UTC
(In reply to Heiko Tietze from comment #37)
> Looks like a vote for dark background :-).

For the record: I'm not to happy with the dark splash screen background. It sends a message, about what to expect. I expect a dark themed application. However it doesn't match the look of the suite (on Windows/MacOS?). And there is no Dark Mode nor proper dark theming either. Linux is probably different story.

However no clue what the alternative would be (not white, IMHO)
Comment 39 Commit Notification 2020-04-30 10:27:32 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/492675180203b3409074923d7993429237611f99

Resolves tdf#130778 - Branding for 7.0

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 40 Rizal Muttaqin 2020-04-30 14:13:55 UTC
(In reply to Telesto from comment #38)
> (In reply to Heiko Tietze from comment #37)
> > Looks like a vote for dark background :-).
> 
> For the record: I'm not to happy with the dark splash screen background. It
> sends a message, about what to expect. I expect a dark themed application.
> However it doesn't match the look of the suite (on Windows/MacOS?). And
> there is no Dark Mode nor proper dark theming either. Linux is probably
> different story.
> 
> However no clue what the alternative would be (not white, IMHO)

There's no such message thing exist. I have not found any HIG that tells correlation between two.
Comment 41 Telesto 2020-04-30 18:22:52 UTC
(In reply to Rizal Muttaqin from comment #40)
> (In reply to Telesto from comment #38)
> > (In reply to Heiko Tietze from comment #37)
> > > Looks like a vote for dark background :-).
> > 
> > For the record: I'm not to happy with the dark splash screen background. It
> > sends a message, about what to expect. I expect a dark themed application.
> > However it doesn't match the look of the suite (on Windows/MacOS?). And
> > there is no Dark Mode nor proper dark theming either. Linux is probably
> > different story.
> > 
> > However no clue what the alternative would be (not white, IMHO)
> 
> There's no such message thing exist. I have not found any HIG that tells
> correlation between two.

Not referring to HIG. It's only stating my personal opinion/feeling/impression. The splash screen color scheme doesn't come back in application (except we are using a dark theming/dark mode). I personally would consider a different background. Maybe something like this:
http://www.ocsmag.com/wp-content/uploads/2017/06/libreoffice-logo.png or this
https://zinniaplus.com/wp-content/uploads/2019/09/LibreOffice.jpeg

However, I'm only a single person.. without much say in the matter anyhow..

There is another issue (if we keep the dark splash screen), something should be done about the font color. Text is showing in the splash screen, but it can't be read.  Another alternative: remove the loading progress text all together..
Comment 42 Commit Notification 2020-05-01 14:15:22 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/53828269ce1eeef8c188d9d462b207277eadbd04

Update for tdf#130778: Windows installer banner and icons. about images

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 43 Commit Notification 2020-05-06 12:03:41 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b8fb2f0b136e688e76ef8d6f09fd75f61ed4c99f

tdf#130778 revert Windows installer legend images

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 44 BogdanB 2020-05-10 18:40:43 UTC
Created attachment 160621 [details]
Sifr version

It's ok on linux. Also on my windows computer at work.
See the screenshot for linux.

Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 45 Commit Notification 2020-05-12 17:51:54 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9d573bca549861ecdbce6826804e5db0471307e6

tdf#130778 update About Dialog

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 46 Commit Notification 2020-05-13 02:38:36 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6911b895baedd669af18d2d08deab044f63baee5

tdf#130778 remove old 6.x centered logo in the Star Center

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 47 andreas_k 2020-05-13 13:00:20 UTC
Created attachment 160754 [details]
About Dialog with splash schreen image

I propose instead of two images in the About dialog (one on top and one on the left) to use the intro image. The good thinks are:

- reuse of the intro image, so highres is possible and if you think on CIB Office, Collabora Office, ... you have to update only one image
- as you can see the intro image was used at the BZ page it's widely used
- the about dialog isn't unbalanced cause there is only one image

And the best is that instead of nice mockups, this about dialog can be done with glade without any hack.
Comment 48 Mike Kaganski 2020-05-13 13:39:41 UTC
It seems that the text overlap shown on attachment 159805 [details] from comment 33 is forgotten?
Comment 49 Heiko Tietze 2020-05-13 17:34:23 UTC
(In reply to Mike Kaganski from comment #48)
> It seems that the text overlap shown on attachment 159805 [details] from
> comment 33 is forgotten?

Yes, missed that. Unfortunately I never see any text so it's hard to find the right position. But will look into it.
Comment 50 Heiko Tietze 2020-05-14 06:36:39 UTC
(In reply to andreas_k from comment #47)
> Created attachment 160754 [details]
> About Dialog with splash schreen image

The dialog is arranged by the text length. And images are loaded from SVG and scaled accordingly to 50 and 90% of the text width. If you take the splash screen, which is a PNG with ~650px and 1000px respectively for high-res, the image needs to be scaled up/down with impact on the quality.
Design-wise it feels wrong to me if the splash screen shows up on some other place. The pleasing aspect of a white heading separated from the grey window is doomed for dark themes - we do not have different splash screens since routines should be very simple in the early stages of the program start.

In general I recommend to create new tickets on issues around the branding and use this one as meta ticket.