Bug 133024 - Misplaced text on splash screen
Summary: Misplaced text on splash screen
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks: 130778
  Show dependency treegraph
 
Reported: 2020-05-14 06:28 UTC by Heiko Tietze
Modified: 2020-07-13 10:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Today's splash screen (80.15 KB, image/png)
2020-05-15 08:26 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2020-05-14 06:28:06 UTC
Reported in bug 130778 comment 33, see attachment 159805 [details]
Comment 1 Heiko Tietze 2020-05-14 10:00:30 UTC
Not a surprise that Linux has no text in splash screen 

unxsplash.cxx:

void SAL_CALL UnxSplashScreen::setText( const OUString& /*aText*/ )
{
    // TODO?
}
Comment 2 Heiko Tietze 2020-05-14 13:18:41 UTC
Please check the nightly builds. Not sure if the value is okay.
Comment 3 Commit Notification 2020-05-14 13:19:14 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a165bb8565539e2d0533362a99236829c23e9be8

Resolves tdf#133024 - Position of text in splash screen

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Mike Kaganski 2020-05-15 08:26:13 UTC
Created attachment 160845 [details]
Today's splash screen

(In reply to Heiko Tietze from comment #2)
> Please check the nightly builds. Not sure if the value is okay.

Almost there. I suppose that moving it down to the same amount would be okay.
Comment 5 Commit Notification 2020-05-15 12:57:34 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/692efa7bdaf8d143602f23520c230202f2bafdf7

Resolves tdf#133024 - Position of text in splash screen

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Heiko Tietze 2020-07-13 10:44:20 UTC
Seems to be fixed now.