Download it now!
Bug 132892 - Drag and drop to the left removes formatting
Summary: Drag and drop to the left removes formatting
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.1 rc
Hardware: All All
: high critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.2 target:6.4....
Keywords: bibisected, bisected, dataLoss, needUITest, regression
: 131976 134244 135868 136000 (view as bug list)
Depends on:
Blocks: Drag-and-Drop
  Show dependency treegraph
 
Reported: 2020-05-09 21:03 UTC by Telesto
Modified: 2020-09-03 20:33 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (8.62 KB, application/vnd.oasis.opendocument.text)
2020-05-09 21:03 UTC, Telesto
Details
Bibisect log (3.07 KB, text/plain)
2020-05-10 10:18 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-09 21:03:03 UTC
Description:
Drag and drop of text apply's to the begin of the line apply's wrong formatting

Steps to Reproduce:
1. open the attached file
2. Select DEF & drag it before ABC -> Formatting of DEF gone
3. Unod
4. select GHI & drag it before ABC -> GH formatted

Actual Results:
Formatted text

Expected Results:
DEF should stay formatted and GHI unformatted


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded

but not in
6.1
Comment 1 Telesto 2020-05-09 21:03:16 UTC
Created attachment 160570 [details]
Example file
Comment 2 Telesto 2020-05-10 10:18:06 UTC
Created attachment 160591 [details]
Bibisect log

Bisected to:
author	Ashod Nakashian <ashod.nakashian@collabora.co.uk>	2018-09-28 06:27:09 -0400
committer	Ashod Nakashian <ashnakash@gmail.com>	2018-12-03 08:10:45 +0100
commit	b402d0112a0bb53221b847fa372bfa3f6390a0e2 (patch)
tree	770cf33fa2b14159ca62a469b6bf75110d435182
parent	349748e63c698076bb44f75da9eaa104489e959c (diff)
sw: paragraph-sign: erase metafields from copied text correctly
This is relevant for paragraph signatures where the
metadata is not yet copied and so we exclude it.
The issue was that in some cases we didn't use
the proper range of text and an assertion was
triggered in debug builds.

Otherwise there should be no change of behavior
in release builds with this patch.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b402d0112a0bb53221b847fa372bfa3f6390a0e2
Comment 3 BogdanB 2020-05-16 17:49:52 UTC
Confirm it with
Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 4 Telesto 2020-06-23 07:53:11 UTC
Adding CC: to Ashod Nakashian
Comment 5 Attila Baraksó (NISZ) 2020-06-27 09:46:09 UTC
*** Bug 134244 has been marked as a duplicate of this bug. ***
Comment 6 Telesto 2020-06-29 20:26:20 UTC
Increasing priority. There is "dataloss". Of course, most of the time it will be noticeable, and you can use undo. But if you drag and drop larger sections etc.. this might slip through.

See bug 134244. 
Or drag & drop text with footnote left (footnote will disappear)

@Xisco
Please adjust to proper priority if I picked the wrong one (again)
Comment 7 Xisco Faulí 2020-06-30 07:32:43 UTC
(In reply to Telesto from comment #6)
> @Xisco
> Please adjust to proper priority if I picked the wrong one (again)

it seems fine to me
Comment 8 Telesto 2020-08-13 20:04:52 UTC
@Caolán
Any change to take a small peak at this one.. The commit [1] isn't that large and 
advertised as "there should be no change of behavior in release builds"

[1] https://cgit.freedesktop.org/libreoffice/core/commit/?id=b402d0112a0bb53221b847fa372bfa3f6390a0e2
Comment 9 Caolán McNamara 2020-08-14 15:58:11 UTC
@Telesto
I know nothing about this, but it does revert cleanly. https://gerrit.libreoffice.org/c/core/+/100753
if that fails in a relevant test-case we might see what the original change wanted to do.
Comment 10 Timur 2020-08-16 07:10:49 UTC
Same commit in crash Bug 131976. As I wrote there, I don't remember seeing Ashod responding in Bugzilla to his regressions. More, those commits are not related to Bugzilla to see the original case. So two outcomes here:
1. Ashod should either respond to his regressions or be deprived commit access to Bugzilla, because he committed those himself. 
2. commit should be reverted, until we have a great case for it.
Comment 11 Commit Notification 2020-08-17 08:21:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bb4ebb8bd143f641577fef69276da8dff62b197c

tdf#132892 Revert "sw: paragraph-sign: erase metafields ... correctly"

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2020-08-17 08:22:57 UTC
reverted in master, backport to 7-0 and 6-4 in gerrit
Comment 13 Caolán McNamara 2020-08-17 08:29:30 UTC
*** Bug 131976 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2020-08-17 11:28:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/13c3e22bcea72aa1b41e5891ff65647f7eeb02d9

tdf#132892 Revert "sw: paragraph-sign: erase metafields ... correctly"

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-08-17 11:28:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/213030a165adeb0d452fa4568b736193d5657ea6

tdf#132892 Revert "sw: paragraph-sign: erase metafields ... correctly"

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Telesto 2020-08-18 08:44:10 UTC
Adding needUITest (or unit test) to prevent this happening again (not sure which bug qualifies most the duplicates or this one)
Comment 17 Telesto 2020-08-18 09:09:56 UTC
*** Bug 135868 has been marked as a duplicate of this bug. ***
Comment 18 Telesto 2020-08-22 07:49:38 UTC
*** Bug 136000 has been marked as a duplicate of this bug. ***
Comment 19 Telesto 2020-08-22 13:25:18 UTC
@Caolan
Is it possible to  push this into LibO 7.0.1.2? Would be nice, IMHO Or to much fuzz?
Comment 20 Caolán McNamara 2020-08-22 13:35:43 UTC
I can propose it: https://gerrit.libreoffice.org/c/core/+/101152
Comment 21 Commit Notification 2020-08-27 14:44:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0-1":

https://git.libreoffice.org/core/commit/04d2a330f7b9db6a8e2a340b119f474946b84d44

tdf#132892 Revert "sw: paragraph-sign: erase metafields ... correctly"

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 BogdanB 2020-09-03 20:33:20 UTC
It's ok now
Version: 7.1.0.0.alpha0+
Build ID: e2f4e65a7b8024c00b049eebf0d87637efda7f24
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded