Bug 132912 - An image is disappearing on cut and repaste
Summary: An image is disappearing on cut and repaste
Status: RESOLVED DUPLICATE of bug 132744
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2020-05-10 11:12 UTC by Telesto
Modified: 2020-06-12 16:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Image tripled after CTRL+X, CTRL+V on table. LibreOffice 7 (376.50 KB, image/png)
2020-05-11 10:44 UTC, Artur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-10 11:12:14 UTC
Description:
An image is disappearing on cut and repaste

Steps to Reproduce:
1. Open attachment 160593 [details]
2. Enter cell A1
3. CTRL+A
4. CTRL+X
5. CTRL+V -> Table shrinks.. an image is missing

Actual Results:
Image is missing

Expected Results:
Should not be so?


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Artur 2020-05-11 10:44:54 UTC
Created attachment 160655 [details]
Image tripled after CTRL+X, CTRL+V on table. LibreOffice 7
Comment 2 Artur 2020-05-11 10:47:22 UTC
Tried and found a different bug (Windows 10). The image was tripled and several additional rows appeared. See attatchment. Please clarify steps to reproduce bug (which cell is A1? Which OS?). Do you get any similar issues?

(In reply to Telesto from comment #0)
> Description:
> An image is disappearing on cut and repaste
> 
> Steps to Reproduce:
> 1. Open attachment 160593 [details]
> 2. Enter cell A1
> 3. CTRL+A
> 4. CTRL+X
> 5. CTRL+V -> Table shrinks.. an image is missing
> 
> Actual Results:
> Image is missing
> 
> Expected Results:
> Should not be so?
> 
> 
> Reproducible: Always
> 
> 
> User Profile Reset: No
> 
> 
> 
> Additional Info:
> Version: 7.0.0.0.alpha0+ (x64)
> Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
> CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL:
> win; 
> Locale: nl-NL (nl_NL); UI-Language: en-US
> Calc: threaded
Comment 3 Telesto 2020-05-11 11:29:45 UTC
1. A1 is Left top cell (coordinates are based on Calc)
2. File shows 4 images on file open 1 first page 3 second -> Three after cut and paste
3. OS: See about info: Windows 6.3 Build 9600
4. The image was tripled and several additional rows appeared -> No clue;
Comment 4 Artur 2020-05-11 11:40:58 UTC
Yes, sorry didn't see the OS! I followed the instructions, selecting the top left cell when pressing CRTRL+X, then selected the line above where the table was to do CTRL+V. Anyone able to confirm either bug?
Comment 5 Maliha 2020-06-10 02:40:46 UTC
Thank you for reporting the bug. I can confirm that the bug is present in 

Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 8; OS: Windows 10.0 Build 17763; UI render: default; VCL: win; 
Locale: en-CA (en_CA); UI-Language: en-US
Calc: threaded
Comment 6 Xisco Faulí 2020-06-12 16:44:57 UTC
This is fixed by https://git.libreoffice.org/core/commit/cc4b5091e739116a7ec83513fa1cd856f0130330
Closing as duplicate of bug 132744

*** This bug has been marked as a duplicate of bug 132744 ***